HELP with SmartSDR CAT and FLDIGI

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I've read and have followed the guidelines the Smart SDR CAT documentation but have been able to enable CAT for transmit control using FLDIGI. I would appreciate knowing how others have configured Smart SDR CAT. Within FLDIGI, I'm using RigCAT and the SmartSDR.xml file. I have no problem with DAX only Smart SDR CAT.
Kirk, K6KAR
Photo of Kirk, K6KAR

Kirk, K6KAR

  • 39 Posts
  • 6 Reply Likes

Posted 6 years ago

  • 1
Photo of W4YXU

W4YXU

  • 75 Posts
  • 6 Reply Likes
I use the following:
Hardware PTT , Device: COM6 and check "Use RTS" and DON'T FORGET to "Initialize" (Wonder how I know?!)

RigCAT , SmartSDR.xml Device: COM5 nothing checked except Use RigCAT at top and initialize, (Bit me here also!)
Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
Here is my configuration:
Photo of jim WB5AAA

jim WB5AAA

  • 41 Posts
  • 4 Reply Likes
I still don't get a freq display
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
Did you press the Initialize button? If the CAT is not working you will notice the QSY button on fldigi is greyed out. Usually a refresh of the Initialize button resolves the problem for me.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
I found that after initializing my RigCAT setup, I had not only to save, but to close FlDigi and restart it. Then things worked really well.

I also found that it always helps to open SmartSDR CAT and refresh its port list so I can observe which ports are open and whether or not they are dedicated or shared. As I get older and more "seasoned" it helps to have these visual reminders, because I can't remember any more!

For most of the simple Digi modes, I have found that FlDigi was easier to use than HRD. ..... so far.....
Photo of W5UN_Dave

W5UN_Dave

  • 316 Posts
  • 30 Reply Likes
I am using the SmartSDR.xml file that Tim wrote and loaded it into fldigi, but I cannot make fldigi retain the com port I assign. It always reverts to com 12 for some reason. that is not the port that I assigned form SmartCAT. fldigi is not getting info from the radio, of course. Can someone explain to me how to make this work> I have PTT working OK.
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
Is it possible the com port you assigned is in use by another program? You created the comports thru SmartCAT. Did you check Control Panel/Device Manager/Ports to see what the system thinks you have?
Photo of W5UN_Dave

W5UN_Dave

  • 316 Posts
  • 30 Reply Likes
Don, fldigi is not saving what I enter on the RigCat entry window. I click the red initialize button and then the SAVE button at the bottom of the entry window. But it does not get saved. When I exit the rigCat form and then bring it back up. The entries are all back to the default values. I am using SmartSDR.xml, Am I saving incorrectly? Where else must I save?
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
Dave

There is also a another save configuration. When you go to the Configure Tab look at the bottom of the drop down and you will see "Save Config". Select that and see if that keeps your changes.

Don
Photo of W5UN_Dave

W5UN_Dave

  • 316 Posts
  • 30 Reply Likes
All working in fidigi now, thanks for all the help. Now I can help others because I figured this out mostly on my own. But at my age, memory will fade fast :-)
Photo of Steve - N4TTY

Steve - N4TTY

  • 103 Posts
  • 11 Reply Likes
I'm stumped as well. There seem to be some gremlins in this procedure somewhere. I followed the YouTube video to the letter but never saw any waterfall display indicating that FLDigi was hearing the radio. Although CAT seemed to be working at one time as I used the mouse wheel to change freq and FLDigi followed on its freq display. Now that seems to have stopped working and no amount of clicking on the 'Initialize' button seems to have an effect.

Steve G./N4TTY
Photo of Steve - N4TTY

Steve - N4TTY

  • 103 Posts
  • 11 Reply Likes
Looks like a reboot of the computer and toggling the TX button in the DAX Control Panel has me working.

Steve G./N4TTY
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
That is always my first step when things get weird. If that doesn't help, then I do a complete power-off reset of both rig & computer.

BTW> In setting up FlDigi, I found about three of four different places where I had to go in and select the sampling rate of 48000 (in the sound card set up, and at least two places in the windows control panel>sound devices> properties, etc) in both the RX and TX paths. I was getting some higher IMD on PSK31 before I rechecked all of the settings. I had thought I had gotten them all, but apparently I had missed one!

Good Luck!
Photo of Kirk, K6KAR

Kirk, K6KAR

  • 39 Posts
  • 6 Reply Likes
After trying many changes and along with these changes, doing computer re-boots, I've finally been able to get SmartSDR CAT working and functional with FLDIGI. I've gone through so many varying combinations that I really don't know what finally caused it to work.
Photo of W4EY

W4EY

  • 153 Posts
  • 7 Reply Likes


Kirk: This is possibly late to help. However, Each Time I start Fldigi, I have to Open the Fldigi configuration window and initialize the Hardware PTT, reload the SmartSDR.xmj file and initialize both before SmartCAT or DAX works correctly. The necessary boxes in Fldigi configuration  are checked and each new Fldigi configuration is saved after changes are made. This configuration process has to be repeated each time Fldigi is started, because the Fldigi configuration is not saving  the new settings..

Bill

W4EY

Photo of Bryan Weber

Bryan Weber

  • 5 Posts
  • 0 Reply Likes

Honestly, this is horrible quality engineering for a program that does not interface with the radio and Smart SDR.  This is not even beta quality work.  I've wasted two hours trying to get CAT to transmit again.   I've done everything by the letter and it no longer works.  You talk about horrible engineering, this is it!  Shame on you guys. 


Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 975 Posts
  • 180 Reply Likes
Bryan, if you update to fldigi 3.22.13 and use the newest xml rig
description files for RigCAT, fldigi should work for you.
It runs here with these settings:

+

I have created an extra serial port 8 in SmartSDR CAT for it.
Note, that I use RigCAT, not Hamlib, which doesn't work for me.
Also please note that I use SmartSDR-SliceA.xml from the fldigi
webpage xml depository. You can find tutorials on this forum,
how to use 2 slices with fldigi.



I have created PTT port 7 in SmartSDR CAT and these are the settings for it.

I must confess although that I mostly use HamRadioDeluxe DM780, with
MiniDeluxe as a server.

73, Alex DH2ID
(Edited)
Photo of W5UN_Dave

W5UN_Dave

  • 316 Posts
  • 30 Reply Likes
Remember to enable the DAX button.
Photo of Bill

Bill

  • 42 Posts
  • 2 Reply Likes
I use FlDigi and MultiPSK with my Flex 6500 and have had no problems setting up the equipment. I found the RigCat file from http://www.w1hkj.com/xmlarchives.html made things very simple to get FlDigi to run but to get FlDigi to receive, all you need to do is to set a DAX Channel, I set mine to 1 and in the FlDigi, set the input to look for this channel. I hope that helps but I can send yo some screen shots of how mine is set up if that will help you. I always recommend that people start with FlDigi as it is easy to get running with nearly any rig.
Bill
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 977 Posts
  • 180 Reply Likes
Bill, thank you for your comment, as I also find fldigi easy to use and to set up.
It also is a very stable program, in this way better than DM780. I only wish
it would do FSK and WinKey...
RigCAT works for me, although I have problems with Hamlib, which OTOH works with my TS-2000X
(Edited)
Photo of Bryan Weber

Bryan Weber

  • 5 Posts
  • 0 Reply Likes
Guys, I got it to work fine many times.  It is when the program is closed and then opened again.  Settings do NOT hold and when they are changed to the correct settings again, it still will not transmit the rig.  Most of the time, it requires all the settings be put in again, initialize again, and then a complete reboot of the computer.  I have another friend with the exact same issue.  Perhaps this is a Windows 8 issue, who knows, but it doesn't hold the settings and life is too short to try and correct the problem each and every time I attempt to use the program.
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 975 Posts
  • 180 Reply Likes
Windows 7 Home Edition 64bit here, Bryan. Could it be a Windows permission problem?
I had that many problems with permissions, that I work all my PC's in this network as an administrator and have all internet connections run through a LINUX firewall PC...
(Edited)
Photo of Jay / NO5J

Jay / NO5J

  • 1674 Posts
  • 262 Reply Likes
Alex
Ditto!
73, Jay - NO5J
Photo of Mal

Mal

  • 47 Posts
  • 0 Reply Likes
I can't figure out how to download smartsdr.xml
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
You have to copy it and then paste it into notes or similar application and save it as the original name.  This worked for me.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Right-click and save target as..... I think that was how I did it.

Then move it to the Program Files\Fldigi folder of the version you are using. Each new version installs to a different directory.
Photo of Mal

Mal

  • 47 Posts
  • 0 Reply Likes
TNX goy it used save as