Having trouble connecting a laptop directly to Flex 6300

  • 1
  • Problem
  • Updated 2 years ago
  • Solved

I normally use a desktop computer to run my Flex 6300 via my wired home network.  The desktop has been upgraded to 1.9.7 and works fine.   I wanted to take the radio to a friend’s house to show him how it works so I loaded SSDR 1.9.7 onto my lap top running Win 8.1 that had never had SSDR loaded.  It was not connected to my Flex 6300.   After the load completed the laptop was restated.  I started SSDR, it came up but did not show a radio. The laptop was connected directly to the 6300 with a network cable.  I powered up 6300 by turning on the power supply and after a minute or so the radio came up.  The Radio then showed as available on the SSDR.   I clicked to select the radio and then “connect”.    The connect bar went from light green to a slightly darker green after a few seconds of the little runaround thing the Radio Setup box changed to: “Radio Setup (not responding)” the runaround thing ran around for another few second then I got a dialog box:  Radio Connection Failed: “Unable to connect to radio.   Please power cycle the radio and try again”.   I power cycled the radio (removed the 12VDC for 10 seconds) – same result.   I closed SSDR – power cycled the radio so it was on before I started SSDR – same result.   I rebooted the computer – same result.  I tried every combination I could think of for rebooting/ starting SSDR / having the 6300 powered up before or waiting to power up the 6300 until after SSDR was started.   When I reconnect the 6300 to my network if still works fine with my desktop.  I reviewed the manual and did not find anything that helped.   Any suggestions as to what I should try now?    Any help is greatly appreciated. 

Photo of John AD6NR

John AD6NR

  • 34 Posts
  • 8 Reply Likes

Posted 2 years ago

  • 1
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 814 Posts
  • 191 Reply Likes
I would start with a quick check of the Windows firewall. I don't have a win8 computer around so I don't remember the exact steps but in Win10 I find it in control panel. Then go to "Allow an app or feature through the Windows Firewall."

This should give you a list of apps including the Flex Systems apps. I have mine set to be allowed on Private and Public.

Why some are listed twice I don't know but every time I tried to mess with this I blew something up so I just leave it all alone now.

If you are running some other security software it should have a similar feature.

Photo of John AD6NR

John AD6NR

  • 34 Posts
  • 8 Reply Likes
My windows firewall is off - double checked via the control panel. 
Photo of John AD6NR

John AD6NR

  • 34 Posts
  • 8 Reply Likes
PROBLM SOLVED!    I had not used this laptop for quite some time and for some reason I can not recall, it was set to a static IP.  When I re-set I to dynamic the radio connected just like it should.  Many thanks to for all the responses and help.   This group is great!   I'm a happy camper but my bartender is lamenting all the lost business!         
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4070 Posts
  • 1267 Reply Likes
Some questions for investigation...
Did you have the rig set for Static IP? If so, the rig and computer may not be on the same subnet and will not connect properly.

Have you tried connecting through a simple switch?

Is the laptop already connecting via wifi to an internet router? Again, this may be causing DHCP IP addressing problems.

Can you try it again with you virus protection or firewall momentarily disabled?

Good luck.

Ken - NM9P
Photo of John AD6NR

John AD6NR

  • 34 Posts
  • 8 Reply Likes
Thanks Ken!   I do not have the rig set for static IP.  I have temporarily defeated my virus protection.  I tried connecting through a simple switch - no luck.   Although I did find out I could connect through my WiFi!     
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1770 Posts
  • 541 Reply Likes
Is your laptop connecting to a WiFi network as well? I think you have a networking issue if it is not what Kevin mentioned about Firewall/AntiVirus blocking it.

My guess is you Wireless adapter is connected to a HOME network without restriction but your Wired connection between the laptop and flex might have different settings.

I will try to turn off or disable the WiFi adapter to see if you can get a solid wired connection to the Flex and go from there.

Good luck.
Photo of HCampbell  WB4IVF

HCampbell WB4IVF

  • 220 Posts
  • 53 Reply Likes

Maybe try another cable to connect the laptop to the radio?


Howard

Photo of KC7ES

KC7ES

  • 40 Posts
  • 2 Reply Likes
A Cross-over cable should be used if no switch is available. Follow subnet suggestions as well. GL!
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1770 Posts
  • 541 Reply Likes
If that is the case you can get crossover adapters https://www.amazon.com/CableCreation-Crossover-Ethernet-Computers-Standard/dp/B01FHBZMW2/ref=sr_1_2?...
And make any ethernet cable a crossover cable.


Photo of KC7ES

KC7ES

  • 40 Posts
  • 2 Reply Likes
Good find on those adapters! They are red for a reason ...just like commercial X-over cables.
Photo of Mike W9OJ

Mike W9OJ

  • 90 Posts
  • 29 Reply Likes
According to the hardware reference manual no X-over cable is needed :

This is the network connection for the radio. It is an auto-sensing 100 megabit or 1 gigabit Ethernet port. It auto-senses polarity as well, so if you are using a direct connection to your PC, you do not need a crossover cable. Refer to the SmartSDR documentation for information as to the network configuration options.
Photo of Ross - K9COX

Ross - K9COX

  • 340 Posts
  • 104 Reply Likes
Not necessary with the flex, it will sense what is needed to connect with a standard cable.
Photo of KC7ES

KC7ES

  • 40 Posts
  • 2 Reply Likes
I stand corrected. Thank you for the research.
Photo of Lee

Lee, Elmer

  • 677 Posts
  • 285 Reply Likes
I had this issue when direct feeding my Anan 10.

In the computer open: TaskManager > Perfrormance and in the Ethernet tab should be the IPv4 address

In the radio open: Settings > Radio Setup > Network and read the IP address  I believe the first 3 numbers in each address should be the same.

If they are not the same you can change the computer adapter to something static and it will probably work.  

73  W9OY
Photo of John AD6NR

John AD6NR

  • 34 Posts
  • 8 Reply Likes
Thanks Lee - Bingo - the laptop was set to static IP!!!   I had not used this laptop in quite some time and did not realize (remember?) it had been set to a static IP.   When I set it to run dynamic IP it connected right away.   
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 207 Posts
  • 23 Reply Likes
The most likely problem, if you are connecting the two without any kind of switch or router, is that you need a specialty cable called a "crossover cable".  There is actually a difference between what a router port wants and needs from the connection and what a device like a PC port.  Some newer ethernet ports support both transparently, but many still do not.  I would either insert a router (some of us have extras laying about!) or else find a crossover cable from someone (they are getting harder to find but do exist) and try that.

This conversation is no longer open for comments or replies.