GPSDO Failure?

  • 1
  • Problem
  • Updated 6 months ago
Hello--I have a Flex 6600, v2.28,  I took delivery of in early February with GPSDO installed by Flex before it was shipped.  It has worked flawlessly since February.

I booted the radio up yesterday and noticed the power button was no longer blue, but green instead.  I tried a factory reset and removing power and the GPSDO was operational when rebooted (blue power button).  I shutdown overnight and when booting up this morning, no GPSDO, just a green power button.  The Settings>>Radio Setup>>GPS settings no longer sees the GPSDO module and a factory/power reset will no longer restore it.  I normally maintain 13.8V to 6600 so the GPSDO module stays powered up.  

Are there any other resets for the GPSDO I can try?  Seems I may have a hard failure.


Chuck  
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 33 Posts
  • 8 Reply Likes

Posted 6 months ago

  • 1
Photo of Larry - W8LLL

Larry - W8LLL

  • 406 Posts
  • 78 Reply Likes
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 293 Posts
  • 58 Reply Likes
Sometimes, there's a GPSDO-to-mainboard connector issue.  My experience is at https://blog.aa6e.net/2018/02/gps-is-looking-up.html

73 Martin AA6E
Photo of Jay / NO5J

Jay / NO5J

  • 1581 Posts
  • 230 Reply Likes
Mouser sells an identical antenna, that is rated for outdoor installation, if the problem is an obstructed view from an interior window mounting, I have mine on the shack roof now, with a clear view of the sky, it maintains lock on the satellites much better, but it will still occasionally loose lock and occasionally even goes into holdover, and I suspect rain fade might be part of the problem, it will eventually lock again all by itself. sometimes I've tried a factory reset of the rig, with mixed success. the antenna is powered and a disconnect from the radio sometimes will get it out of holdover faster. Not much better than it worked when the antenna was inside mounted on the window glass. The GPSDO seems to require 7 or more Tracked satellites to maintain lock if it drops to 6, it will begin the flashing blue relocking indication. most of the time mine Tracks 7-10 now. It is what it is. I'm kinda 99.99% satisfied, now that it works FB, 99.98% of the time.
Mouser's product page ...

https://www.mouser.com/ProductDetail/PulseLarsen-Antennas/W4000G197?qs=%2fha2pyFadujt8lX9lncR%252bcZ8DVV%252bBfQ%252bZPzy9L5USaGfpylvEPv19g%3d%3d

I tried that part as a replacement (I bought 2) after I accidentally ripped the coax right out of the SMA connector and suspected my repairs were the problem. Maybe the outdoor mounting helped, but maybe not much.    

#FlexRadio IRC chat

   73, Jay - NO5J

(Edited)
Photo of roger na4rr

roger na4rr

  • 83 Posts
  • 5 Reply Likes
I may be wrong but this looks to be just a GPS antenna and not the GPSDO receive module.  

Photo of W9WLX-Chuck

W9WLX-Chuck

  • 33 Posts
  • 8 Reply Likes
OK, I'll look into it.  If this is the case, then SDR needs some work in how they report it.  If my antenna had failed, I would expect it to report "hold-over" or "locking", not "GPSDO Module Not Present".
(Edited)
Photo of W9WLX-Chuck

W9WLX-Chuck

  • 33 Posts
  • 8 Reply Likes
OK, I tried cleaning the contacts and re-seating.  It did not change anything.  Seems I can get the 6600 to recognize the GPSDO module if I uninstall and install the option in the GPS tab multiple times.  Eventually is sees it and starts the warming-up, locking, lock cycle.  If I shut the radio down and boot it back up, I'm back to where I started, no GPSDO.  What I find interesting is at the end of the boot cycle, the power button goes from flashing green to blue to solid green.  The blue lasting only about 0.25 sec.  

I think either the module has failed or something in the chain on the Flex hardware.  Otherwise, for the past 4.5 months it worked flawlessly.  At lease it is not critical to operation.
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 293 Posts
  • 58 Reply Likes
FRS always seems to say to try a full factory reset when strange things are  happening.
Photo of Ernest - W4EG

Ernest - W4EG

  • 206 Posts
  • 38 Reply Likes
My GPS failed on my 6700 as a result of lighting strikes nearby. 
Replaced with similar GPS antenna with 28db gain from Amazon. My Flex-6700 and GPS is working quite well; which makes me a very happy camper