GPSDO Active, but No Blue Button

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)
New 6600, v2.4.9, self-installed GPSDO (from previous 6500).  Worked fine for a couple of weeks.  Now, no Blue power button (solid green only).

All other indications/settings are normal: GPS tab shows active (with all the normal GPS data), and RX tab shows GPSDO Locked (with a green check mark).

Haven't done a factory reset yet.  Any thoughts?

Photo of Jim, KJ3P

Jim, KJ3P

  • 93 Posts
  • 14 Reply Likes

Posted 7 months ago

  • 1
Photo of Bob G   W1GLV


  • 818 Posts
  • 145 Reply Likes
If you installed the GPSDO, one of the two small coax cables may have come loose. These cables use very small micro connectors to connect to the circuit board. Open the radio and check it out. If I remember correctly the GPSDO is located on the bottom side of the radio.
Photo of Jim, KJ3P

Jim, KJ3P

  • 93 Posts
  • 14 Reply Likes
Yep, tried that...nice and tight.  As I mentioned, all GPS indicators show normal except the power button (green, not blue).  If the cables were loose, I'd expect the GPS info to be flakey, but it's rock solid., but I checked the cables anyway.

BTW, the GPSDO module is on the TOP chassis of the 6600.  But it was on the bottom for the 6500.  Of course, I opened the bottom of the 6600 first, but it gave me a nice tour of the new radio <grin>.

Guess I'll open a ticket.
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 325 Posts
  • 77 Reply Likes
Try a full power off reset. (Remove DC for several seconds then power up. ) Then try a factory reset, if still needed. Then consult Austin. That's what I'd do.

73 Martin AA6E
Photo of Justin - KL2D

Justin - KL2D

  • 121 Posts
  • 47 Reply Likes
I had something similar with my 6700, the advice from Austin, TX was go into settings, “remove” the GPSDO, then add it again. It was something with the way the radio sees the module.

Don’t know if that will work for you, but it worked for me when factory reset and power removal had not worked.

Good luck!