Got my Maestro today - mixed blessing

  • 1
  • Problem
  • Updated 4 years ago
  • Acknowledged
What a day.  An 8 month wait and my Maestro finally shows up.  Up to now I've had many happy hours with my Flex-6700 running SSDR v1.5.1. 

I followed the instructions on the plastic protective cover on the Maestro screen, powering it with the AC supply.  I didn't need to turn it on because as soon as I plugged the AC power supply in, the Maestro came on by itself, it found my WiFi and after I entered my network password it  successfully logged on to my network.  The Maestro screen then stated I needed a software update, so I did that.  So far so good!  The Maestro linked to my Flex-6700 and I was tuning around the bands, activating 2nd slice, mode changing, bandwidth changes, etc, all worked fine. 

Next I plugged in the Flex supplied hand held Maestro mic (into Mic1 jack) but noticed the PTT button on the handheld mic didn't work.  Later I tried to turn the Maestro off but noticed the on/off button didn't work either (holding off button 5-10 seconds). 

Thinking the problem might be a result of a conflict with my older SSDR version being on my PC I deinstalled v1.5.1, and then installed the latest version of SSDR, v1.7.30.160.  Restarting my Flex-6700 the SSDR software screen popped up saying I needed to load a software downgrade.  (About now I'm thinking... am I having fun yet?)  There were no other options available so I loaded an older version of the software; v1.7.30.78 loaded.  I started SSDR on my PC next (Maestro is not powered up).  SSDR started but I had no spectrum display or waterfall (audio and tuning worked fine).  Not much in the way of success.

So... I turn everything back off and start over, this time starting the Maestro.  The Maestro started saying I needed a software upgrade... (go figure) so I did that.  The Maestro eventually started and its spectrum and waterfall was working fine, but still no PTT on the hand mic, and the on/off button (holding 5 seconds) still doesn't work.

Not sure where to go from here.  No SSDR working on my PC, and no fully operational Maestro either.  Quite frustrating. 
Photo of KF4HR


  • 935 Posts
  • 307 Reply Likes
  • like turning on my ICOM 7800.

Posted 4 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9480 Posts
  • 3666 Reply Likes
Official Response
I have converted this topic to a support HelpDesk ticket ( for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.