Funny start up issue

  • 3
  • Problem
  • Updated 5 years ago
  • In Progress
This has been happening for a
long time, Maybe day 1.

When I click on the SmartSDR v1.3.8 icon, SmartSDR starts on my screen.
But it does NOT connect to the radio.
The program starts but is devoid of any signals, even though a frequency is displayed in the Flag.
Nothing I can do will connect it to the radio to make it operational.

The fix is simply to delete SSDR, and restart.
The 2nd time I click on the desktop icon SSDR starts but shows a two line frequency display.
By that I mean the radio starts on the last used band, and starts at the beginning of the band, runs to the end of the display and then creates a 2nd band display below it.
I can delete that second portion and the rig operates normally.

I suppose that when I installed v1.3.8, I did something wrong to create this anomaly but have never been able to fix it.

Anybody have a clue?

as always, pse et tu de W9OL
Photo of Bill-W9OL

Bill-W9OL

  • 726 Posts
  • 56 Reply Likes
  • embarrisingly stupid

Posted 5 years ago

  • 3
Photo of Jon - KF2E

Jon - KF2E

  • 679 Posts
  • 222 Reply Likes
Mine does this occasionally but only after it hasn't been shutdown improperly. If I leave the radio running for an extended period I often will return to find SSDR had closed. If I try to restart SSDR I get the symptoms you are. I usually restart the radio to correct the problem.

Don't worry...it will be fixed in 1.4:)

Jon...kf2e
Photo of SteveM

SteveM

  • 272 Posts
  • 44 Reply Likes
I know what I would do, if I were you - factory reset that puppy. Down side to this action is, as you probably know, profiles and persistence is wiped out.
Photo of Jay / NO5J

Jay / NO5J

  • 1674 Posts
  • 262 Reply Likes
For about the last week or so,I'm seeing something possibly related. When I turn on the 6500 and start SmartSDR, The gui opens up but doesn't open a panadapter,  and won't open one by clicking the add panadaoter icon in the lower left. When I close the useless gui and reopen SmartSDR it opens with two panadapters running. I just close the extra panadapter and things work normally afterwards. it happens often enough to be annoying, I doubt its ethernet related, Powersaving is turned off on that PC the radio connects directly to the PC via a 3' patchcord, the PC stays on 24/7 SmartCat runs 24/7. The only thing not connected to the shack's single point ground is the operator. I've only ever run 1.38 which was released while UPS was transporting the radio. so I can't claim it started with 1.38, I don't think it started this behavior recently. Factory resets have been tried several times with no effect. Currently SmartSDR either opens correctly, or it doesn't.  One other detail that may help to locate a bug, If the prior session was shut down with 2 panadapters running, after restarting SmartSDR to clear the hung gui, it opens with 4 panadapters. Which proves to me that SmartSDR is smart enough to be able to multiply by 2. Fix me, before I multiply again said the bug!
Photo of Larry da Ponte

Larry da Ponte

  • 159 Posts
  • 15 Reply Likes
I have experienced this several times using 1.3.8. There are no pans displayed even after a minute of waiting and the open new pan button is grayed out. Close and open ssdr will give my pan adapters back. Perhaps some state stored in the radio that is not consistent with the GUI.
Photo of Bill-W9OL

Bill-W9OL

  • 726 Posts
  • 56 Reply Likes
Yes, I didn't mention in my post that I also have this situation, Open SSDR and it opens to a blank screen with just the TX P/CW Phone RX EQ on the right side
Close it with the Red X and Restart SSDR click on Connect and it starts normally and displaying signals, although again sometimes it opens multiple slices.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3755 Posts
  • 1617 Reply Likes
I am experiencing the same issues. But my pain threshold is pretty high. So for the rare occasions I turn off SSDR I just restart it a couple of time and that seems to fix it. So far rarely if ever reboot the radio.

More annoying is that if I kill SSDR the radio keeps on receiving unless I specifically delete the receiving window before I shut down. PIA when I run remote and it does not stop so the radio blairs away when I am not there to stop it...great way to annoy the XYL.
Photo of Jay / NO5J

Jay / NO5J

  • 1674 Posts
  • 262 Reply Likes
Howard

Yes, restarting SmartSDR has worked every time it's done it. It's less annoying knowing I'm not special. I only tried rebooting the radio to factory defaults a couple of times. The radio stays on when I'm in the shack, and gets shutdown when I'm not. GPSDO has to stay powered so It only gets power cycled about once a week when the utility company forgets to make electricity.

 Thanks.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3548 Reply Likes
Official Response
We have worked on some things for v1.4 that should improve this situation.  I am not making any promises it will fix all of the issues, but for me (doing alpha testing) I have seen an improvement in the missing panadapter on start up issue.
Photo of Bill-W9OL

Bill-W9OL

  • 726 Posts
  • 56 Reply Likes
I don't turn the rig off...I just close the software. The rig is back, in a cabinet.
So turning it off and on is slightly inconvenient. Plus, I'm always here.
(the back of the cabinet is open so the rig gets plenty of air. Overheating is NOT an issue.
But glad to hear you and the staff are aware....
I'm old...so patient....but hopefully I don't have to be patient for long. LOL
Photo of Jay -- N0FB

Jay -- N0FB, Elmer

  • 539 Posts
  • 213 Reply Likes
This has happened to me on the 6300, but it is so infrequent that I can't say that it is much of a problem.  I just reboot the 6300 and all is fine.  I notice that it occurs when my 6300 has been left to run for nearly a week.  Seems that it may be a memory leak or something similar.
In any case, thanks FRS in advance for once again looking into this problem and fixing it!  
(Edited)