FT8 setup with updated SmartSDR

  • 1
  • Problem
  • Updated 2 months ago
Looking for help with FT8 setup using WSJT-X and RECENT versions of Smart SDR.  I have tried to YouTube videos the Mike has created for us as well as the post I see here BUT most are 1 to 2 years old and in every case, something in the Newer versions of SmartSDR are just a bit different.  Everything I do works except NOTHING ever shows up in the band activity window.  Yes its getting audio, I'm in  DIGU,  the little green bar audio goes up and down, my PC time is perfect, but still a black band activity screen.  Anyone know of a new setup I can learn from?  (NOW I am assuming the stuff I see on 40 Meters at 7.074 MHz is FT8, correct)  FLEX 6400 , SmartSDR version 3.1.7 and Windows 10.
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 100 Posts
  • 13 Reply Likes

Posted 2 months ago

  • 1
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 100 Posts
  • 13 Reply Likes
Black Band should read Blank
Photo of Dwayne - NA6US

Dwayne - NA6US

  • 104 Posts
  • 16 Reply Likes
I’m traveling and returning Wednesday evening to California - if you want to a zoom meeting so I can review your configuration, happy to do so Wednesday/Thursday.
(Edited)
Photo of Mike Hoing

Mike Hoing

  • 281 Posts
  • 43 Reply Likes
I can help if you PM or email me (QRZ.com).  I will look at your set up and get you on the air.  Free anytime

Mike
NN9DD
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 100 Posts
  • 13 Reply Likes
Thanks Duane and Mike (gotta love hams).
Photo of Gary m0gme

Gary m0gme

  • 14 Posts
  • 0 Reply Likes
All sounds to me like you haven't installed Omnirig or set up omnirig. If that's the case install it, set it up,  and choose omnirig as, THE RIG in WSJT-X settings.
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 99 Posts
  • 13 Reply Likes
What does Omnirig do?  I don’t see Flex as supported on their website but I assume from you that Flex is supported.
thanks
Brian
Photo of Timo - OH5KW

Timo - OH5KW

  • 23 Posts
  • 0 Reply Likes
After recent SSDR update, I had this kind of no decode problem too. Resetting WSJT-X did help.

Go to Configurations -> Default -> Reset.

You will lose all your WSJT-X settings, so take notes before doing this. 

73, Timo OH5KW
(Edited)
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 99 Posts
  • 13 Reply Likes
Thanks I’ll try that as well.
Photo of Erika - KØDD

Erika - KØDD

  • 48 Posts
  • 22 Reply Likes
I updated from a 1500 running KE9NS 2.8, HRD 6.5, and WSJT-X 2.0, to the latest release 1903 win 10Pro, a 6500, 3.1.7, HRD 6.6, and WSJT-X 2.1...  Lets just say da latest and greatest...  Or completely scienced out software to becoming all alone and a test pilot.  I ended up with wired Ethernet connections between WiFi Router, radio and computer... The 1gig hunk of wire really made that route solid.

The thing is up and making QSO's hand over fist however quirkier than the old system.  It does need rebooting to give me a clean waveform.

The biggest thing to get functioning for me was the integrated logbook...  3.1.7 and WSJT-X were rock solid right from the get go.  It was getting HRD to play nice. For them to work you need to have the frequency reported between all the software packages...

You need to get DAX running and configured and CAT ports created.  For me those seemed more intuitive than the VAX software and com0com was from the old system...  The first thing I would suggest is if you have any of the VAC or com0com software and ports and routes on your win 10 machine strip it off.  I saw suggestions for installing omnirig? 

I was having T/R fits until I setup the cat as a Kenwood TS-2000 then bingo...  Everything instantly started playing nice.  For me even the latest HRD stuff is an antique compared the latest from JT and FRS...  I ended up adding DDUtil v4 and FRstack3 to integrate the log and give me radio function equivalent to what I was used to with PowerSDR...  Hopefully an integrated full functioning package will be available from FRS someday.

Sounds like you have some configuration volunteers....  The thing I really need to state emphatically is YOU NEED to prepare your Windows 10 machine first...  If I haven't cleaned house of all the old drivers I'd still be configuring spaghetti code in circles...
(Edited)
Photo of Michael Walker

Michael Walker, Employee

  • 1102 Posts
  • 328 Reply Likes
Hi Brian

Some of the videos are much newer.  Did you watch the one using SliceMaster?  

https://youtu.be/_ww8CcGNAzg

You may find that makes it a few mouse clicks long.  

Make sure you watch in the Flex Channel.

Mike
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 99 Posts
  • 13 Reply Likes
Mike:
yes I did but I figured if I was having trouble with one program, adding a second to the mix might not be the best idea BUT, I’ll try anything.  BTW I am a recently retired Engineer from the Aerospace and Defense (that’s the American spelling :o) ) business and bought my first PC in 1978. I appreciate so many trying to help.

Brian KB1VBF
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 99 Posts
  • 13 Reply Likes
EE I forgot to say
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 100 Posts
  • 13 Reply Likes
Mike:
your videos are great and I have gone through both.  The CAT is working perfectly and I can transmit.  But that band activity just stays blank.  Now the app is saving sound files in the save folder.  I am also trying to verify somehow if it’s not getting 44khz data.  I’m stumped.
Brian KB1VBF
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1490 Posts
  • 325 Reply Likes
Brian,

if you would like assistance via a TeamViewer session, let me know

my email is good on QRZ and I am available all day. Just email your phone number and I will call.

one thing to check is make sure you are using the latest version WSJT-X. 
Dave wo2x
Photo of Rick WR0H

Rick WR0H

  • 34 Posts
  • 7 Reply Likes
Is the 'monitor" button (just about the WSJT-X frequency readout) green?  If not, click it.
Photo of Harold Rosee

Harold Rosee

  • 160 Posts
  • 39 Reply Likes
Brian,

Have you changed the mode in WSJT-X to FT8?  It is not the default.

Harold
Photo of Erika - KØDD

Erika - KØDD

  • 48 Posts
  • 22 Reply Likes
Brian,
Have you selected on the receiver slice DIGU and more importantly on the right of the receiver slice flag push the DAX button and select Dax channel 1...  I'd be surprised if you didn't get your band activity lit up...

Erika DD
(Edited)
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 100 Posts
  • 13 Reply Likes
OK reset WSJT-X.  The mess that followed caused me to re-install the newest WSJT-X (I had 1.9.1 now I have 2.1.0)  Now the settings page doesn't show my network server ID.  It's just blank.  I didn't have this problem before.  Got to figure this out before I can try again.
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 100 Posts
  • 13 Reply Likes

Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1490 Posts
  • 325 Reply Likes
Brian,

the 1.91 explains why no decoding. That is why I posted to check your version.

In SmartSDR CAT you need a TCP CAT port dedicated to WSJT-X. I personally created CAT TCP 5004.

Then in WSJT-X radio settings choose Flex 6xxx.
In the address box enter 127.0.0.1:5004 (replace 5004 with whatever TCP CAT port you created)
on same page select data/pkt and Fake It. 
Set the audio tab to the appropriate DAX selections.

you should be good to go.

Dave wo2x
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 100 Posts
  • 13 Reply Likes
Thanks Dave will try...
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1490 Posts
  • 325 Reply Likes
Here’s my CAT setting and WSJT-X radio settings
l


(Edited)
Photo of Brian Denley  KB1VBF

Brian Denley KB1VBF

  • 100 Posts
  • 13 Reply Likes
Dave:
Got it!  With your help as well as all the others who offered help!
CAT is working PTT is working (but those worked before with 1.9.1) but now I see lots of Band Activity!  Thanks again to Dave and Mike and everyone else.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1490 Posts
  • 325 Reply Likes
Excellent! Now go have fun ;-)

Dave wo2x