FT8 Flex6500 configuration - not connecting to rig

  • 2
  • Question
  • Updated 2 years ago
  • Answered
When starting up FT8 I get an error message "Rig control error, do you want to reconfigure the radio interface?"       "Hamlib error: IO while opening connection to rig"

Apparently not connecting to radio which works fine with FLDIGI, DX Labs Suite

I could use a tutorial but couldn't find one.

Here are my FT8 settings that I think are the issue somewhere.

Config RADIO tab
Rig: FlexRadio 6xxx
Network Server: blank [tried 127.0.0.1:5004]
PTT: CAT
Mode: None [will use DIGU]
Split Operation: Rig

AUDIO tab
Input: DAX Audio RX1
Output: DAX Audio TX





Slice DAX set to channel 1, matches DAX Control Slice A which is on/streaming

DAX Control TX on/streaming

Network server - I did read in another post somewhere not to use the radio IP (192.168.168.144) but to use 127.0.0.1:5004 which did not work either. Default seems to be to leave this blank.


This looks to be simple, but...

Any help would be appreciated..



Flex6500, Win 10 Creator's ed, - latest updates, SmartSDR v1.10.16, rig working fine otherwise.
Photo of Tom

Tom

  • 33 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 2
Photo of Tom N5MOA

Tom N5MOA

  • 94 Posts
  • 24 Reply Likes
Official Response
If you using DXLabs Commander, set your "RIG"  to that.

Here is a link on it  http://www.dxlabsuite.com/dxlabwiki/WSJT-X_Flex6000



Tom
N5MOA
Photo of Tom

Tom

  • 33 Posts
  • 2 Reply Likes
Tom - That seemed to work right off the bat. Next step is to learn how to use FT8!

I would still like to learn the settings without DX Labs Suite Commander if anyone else cares to chime in.
Photo of Ray Andrews, K9DUR

Ray Andrews, K9DUR, Elmer

  • 251 Posts
  • 63 Reply Likes
Tom,

Try changing your Network setting in the WSJT-X software to "localhost:#####", where ##### is the TCP port number set up in SmartCAT.

That is what got it going for me.

73, Ray, K9DUR
Photo of Denley W3XY

Denley W3XY

  • 21 Posts
  • 5 Reply Likes
Ray, do you use Fake It or Rig for split operation setting?
Photo of Ray Andrews, K9DUR

Ray Andrews, K9DUR, Elmer

  • 251 Posts
  • 63 Reply Likes
It is set to "None". -- 73, Ray, K9DUR
Photo of Rudy HB9MHB

Rudy HB9MHB

  • 12 Posts
  • 0 Reply Likes
Tom,
I set rig: Kenwood TS-2000 like in Tips and Tricks, Configuring WSJT-X and SmartSDR for Windows from FRS.
73, Rudy HB9MHB
Photo of Cal Spreitzer

Cal Spreitzer

  • 449 Posts
  • 113 Reply Likes
Tom,

Like Rudy here is my settings on my 6500: 



I'm using DDUtil along with HRD Logbook. 

73 de Cal/N3CAL
Photo of Lasse Moell

Lasse Moell

  • 129 Posts
  • 21 Reply Likes
Here is my screen dump from WSJT-X 1.80 RC1
Note I have port 5002 set in SmartSDR CAT, and this should match your setting in WSJT.
And localhost:XXXX seems to work for me, not 127.0.0.1 etc...
If I recall I may have had to close and reopen the program once to get it to respond.

/Lasse SM5GLC
Photo of Mike - W7TUS

Mike - W7TUS

  • 16 Posts
  • 2 Reply Likes
Hi Tom,
I've been thrashing around for a couple of days trying to get WSJT-X to work with my Flex 6500 on V 1.10.16.  I didn't have any luck using the FLEX6xxx and the TCP address but I did get it to work using the Kenwood TS-2000 method as described by Cal and in the Flex Tips as  he mentioned in the previous comment.  

My error was not going into the SmartSDR CAT and adding Virtual Serial port 4.  Once I did that radio started talking to the program.  

Here is the Flex Tip URL
https://helpdesk.flexradio.com/hc/en-us/articles/202037343-Configuring-WSJT-X-and-SmartSDR-for-Windo...

Good luck - you'll get there.

73, Mike - W7TUS
Photo of willy

willy

  • 2 Posts
  • 0 Reply Likes
use kenwood ts2000 for radio
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1420 Posts
  • 308 Reply Likes
WSJT-x 1.80 or newer now support TCP connection to SmartSDR CAT. 1.70 and older only supported TCP for 6500 and 6700.

Dave wo2x
Photo of David H Hickman

David H Hickman

  • 48 Posts
  • 4 Reply Likes
I use two slices on my 6300 for FT8.  Set the radio to a Kenwood TS 2000 and things will work great.
Photo of k3Tim

k3Tim

  • 924 Posts
  • 195 Reply Likes
With FlexRadio 6xxx selected and network server set to localhost:<port #>  all modes working. Cat has to have <port#> setup, using 5002 here for slice B. With shortcut to program launch set properly,. all 4 slices on 6500 can be accessed by multiple instances of WSJT independently. Dax channels need to be configured.

 
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1445 Posts
  • 309 Reply Likes
I would recommend using a port other than 5002.

5002 is the port DDUtil uses and it may cause a conflict if you are either running DDUtil pr plan to in the future.

I use 5004 for WSJT-x

Dave wo2x
(Edited)
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Yes.  Thanks for reminding us of this.  Port conflicts can be frustrating to solve down the line, so it makes sense to avoid them in the first place.

I have sometimes set up 4 different TCP ports, 5003, 5004, 5005, 5006 and have them linked to Slices A-D on my 6500 for "Auto-Switch".  I change the port assignment in WSJT-X if I am wanting to use a different slice other than A.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
As you have noticed, there is more than one way to skin this cat...
Both of them require setting up either a TCP port or a COM port in SSDR-CAT.

My preferred method is to set up TCP ports (I use port 5003) you can link them to a particular slice if you want, of leave the auto switch OFF and it will key whatever slice you have active.  For RIG: use "FlexRadio 6xxx) and for port use "Localhost:5003" or whatever port # you are using.  Then for "PTT Method" select "CAT."

Alternately, you can set up a COM port in SSDR-CAT  (I use 12) and set up RIG = Kenwood TS-2000.  Select the COM port you defined.  For "PTT Method" use CAT.

For both methods, I use NONE for the MODE box in setup.

I Use NONE for split.

(The two other selections seem to be for rigs that do not have a wide TX filter option, or a flat TX bandpass available.

"Fake it" is a workaround for rigs that do not have a wide enough TX and RX filter to be able to run JT65 and JT9 at the same time.  the Flex rigs CAN.  so we do not need to "fake it" by shifting the VFO.) 

Either way, after you have defined the ports, then hit the "Test CAT" button.  It should turn green.

Once that is working, then hit the TEST PTT button and see if the rig switches into transmit mode.

Be sure to use DigiU for the mode on the rig.  And turn the DAX button ON.
Set your MIC PROFILE to an appropriate width for the mode you are running with WSJT-X.  
25-2500 Hz is usually good enough for FT8 on most bands.  Some use a wider sub band on FT8.
You may want to use 25-5000 Hz for JT65/JT9.  
I tend to leave it set from 25-5000 on TX for all the WSJt-X modes.

NOTE:  The frequencies in your WSJT-X waterfall (from 0 to 5000) are the audio frequencies that will be sent and received by our rig..  If your TX filter is set too narrow, some of the transmit audio frequencies will not pass through.   

Receive filter width?  I usually use 5K  receive filter, and manually shift the low end to 25 Hz.
On some bands, I will drag the upper end of the receive bandpass down a little when running FT8 if I see that some JT65 signals are too close in frequency,... just to keep things clean.


The most common problems I have encountered with folks are:

Failure to set up TCP or COM ports in SSDR-CAT.
Forgetting what TCP or COM port numbers to use in the config tabs..
Using the wrong Rig definition for the interface you plan to use
Selecting the wrong PTT Method.
Selecting the wrong RX and TX DAX channels in the "Audio" tab.
Failing to select the proper DAX buttons and levels in the TX Control Panel and DAX Control Panel.
Improper adjustment of DAX RX & TX levels.

Good luck.

Ken - NM9P
Photo of k3Tim

k3Tim

  • 913 Posts
  • 189 Reply Likes
Thanks for the heads up Dave. I'll reassign ports based on the "Ken Standard Numbering System for WSJT Ports".

Regards,
k3Tim / 6 
Photo of Kevin

Kevin

  • 931 Posts
  • 271 Reply Likes
I always use Fake-it. From the WSJT-X website:

Split Operation: Significant advantages result from using Split mode (separate VFOs for Rx and Tx) if your radio supports it. If it does not, WSJT-X can emulate such behavior. Either method will result in a cleaner transmitted signal, by keeping the Tx audio always in the range 1500 to 2000 Hz so that audio harmonics cannot pass through the Tx sideband filter.
I have never found a problem using this and I feel it makes a difference when I answer a call between 0 and +500 Hz. I'm not sure how much I can believe the panadapter when transmitting but when split is off and I'm transmitting at +200 I see this:


When I change to split = fake-it then I see this when calling at +200 Hz:


I feel much more comfortable with fake-it enabled. It might be a false assumption on my part but I get no complaints and have been quite successful with these modes.

73,
Kev K4VD
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1402 Posts
  • 306 Reply Likes
I use Fake It also. No issues. It also allows me to operate combined JT9/JT65 without opening my TX bandwidth to accommodate the JT9 range.

Dave wo2x