Frequency Tuning Delay

  • 3
  • Question
  • Updated 1 month ago
I have a 6600m and a Maestro v2. I am using 2.4.9. On the 6600m there is a very noticeable delay between turning the tuning knob, and the frequency actually changing. The 6600m is wired directly to the router. The Maestro does not exhibit and noticeable delay, and it is running on the wifi network. The delay on the 6600m is severe enough that it makes it difficult to tune a station in. Does anyone have an idea why this behavior is happening, and what I can do about it?
Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes

Posted 2 months ago

  • 3
Photo of Duane, AC5AA

Duane, AC5AA

  • 463 Posts
  • 104 Reply Likes
I have the same problem, Al.  I have a 6600 and Maestro.  I don't see that delay when using SSDR on the PC with the FlexTuner knob, but it's quite obvious on the Maestro.  I had the Maestro linked via 5G WiFi to the rig, and thought WiFi might be the problem, so recently I ran a CAT6 directly between the router and the Maestro, and no real change.  I mentioned this to Matt Youngblood recently at Austin Summerfest because they had a Maestro running remotely to a rig somewhere else, and it did not display the same lag.  On mine, the cursor seems to move quickly, but the digital frequency readout is what lags.  It pauses, then "catches up."  Matt had no experience with the problem so didn't have any suggestions.  I notice it more on CW than on SSB/Digital modes, but I won't swear to that.

Quick edit:  I was running 2.4.9, but also upgraded to 2.5.1 and see the same problem.
(Edited)
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 580 Posts
  • 206 Reply Likes
Just another datapoint: I have a 6600M and experience zero delays tuning on either VFO knob. Running 2.4.9.
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 325 Posts
  • 77 Reply Likes
I have seen something similar with a Maestro A and a 6500 with 2.4.9. My hypothesis is that it's the router doing some kind of extra buffering or bloat. Next time I will compare with a direct wire btw Maestro and 6500. Bet that will eliminate the problem. If so, try swapping in a different router or (shudder) fiddling with router parameters.
Photo of WW1SS - Steve

WW1SS - Steve

  • 807 Posts
  • 269 Reply Likes
I sometimes have the delay also. Mine gets so bad that even with vox enabled I'll speak and 3 seconds later the radio will start transmitting.
Photo of Duane, AC5AA

Duane, AC5AA

  • 463 Posts
  • 104 Reply Likes
Thanks, guys, for some suggestions and data points.  I should note that my router is a "Technicolor" cable modem/router/VOIP combo unit as provided by Spectrum.  Just in case someone else experiences the same issue.
Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes
That’s very interesting Duane. My WiFi connected Maestro V2. Has no lag but the 6600m has significant lag. I am using the same router that you are.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 580 Posts
  • 206 Reply Likes
One other thought: You mentioned that the tuning knob on the M front panel showed a serious delay. This interface is directly connected internally to the 6600 radio. However, they are on a common network connected via the internet jack on the back of the radio. What happens if you disconnect all internet connections from the 6600M? Does the tuning behaviour change?

My thought is if there is a large flood of traffic on the network, it could definitely interfere with communication between the front panel and the radio. It’s easy to verify, and just a thought.
Photo of Duane, AC5AA

Duane, AC5AA

  • 462 Posts
  • 103 Reply Likes
Actually, he said a Ver 2 Maestro was where he found the slow response - but I also wonder how the response is on the M front panel.
(Edited)
Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes
The serious lag on the 6600m is still there without the Ethernet connection.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 580 Posts
  • 206 Reply Likes
Since the only way you can run an M with no Ethernet is with the internal UI, it sounds like it’s internal to the radio, so a matter for Flex to solve.

Edit: Have you tried a factory reset of the radio?
(Edited)
Photo of Duane, AC5AA

Duane, AC5AA

  • 462 Posts
  • 103 Reply Likes
Sorry - missed Al's response above when I responded.  Carry on!
Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes
No Ted, I haven’t tried a factory reset of the 6600m yet
Photo of John - AI4FR

John - AI4FR

  • 219 Posts
  • 60 Reply Likes
Not sure if this is of any help but thought I'd post it just in case. If nothing else it'll give you one more thing to check.

Below is a copy and paste from a post today from the WSJT-X reflector concerning a windows update and slow CAT port.


7a Delayed PTT via USB since Window update
Sat Aug 31, 2019 11:45 am (PDT) . Posted by: "Ken Arck" ah6le

Anyone else noticing that the latest Windoze update introduced
several seconds of delay (seems to be around 3 or 4) when PTT is
asserted via the USB port? I'm noticing this with both WSJT-x and WSJT-10

Ken



7b Re: Delayed PTT via USB since Window update
Sat Aug 31, 2019 1:50 pm (PDT) . Posted by: "Ken Arck" ah6le

Found the culprit (maybe help someone else)...

Turns out the update enabled Power Saving for the ports, by default.

Simply go into Device Manager > COM & LPT, find
the comport designation for the 9700 USB CAT
driver, right click on and go to the Power
Management tab. Uncheck "Allow the computer to
turn off this device to save power" and click OK. Back out and you're done

Hope this helps somebody

Ken



Photo of N8AUM

N8AUM

  • 119 Posts
  • 12 Reply Likes
I gave up with my Maestro, sometimes it works, and sometimes it dosnt and just locks up. PC and Laptop dont have any problems with WI-FI. Anybody using AT&T U-Verse modem/router ? Hopefully its some setting that just needs to be changed?
Tried all the different flavors of SSDR

Vidas
(Edited)
Photo of Michael Walker

Michael Walker, Employee

  • 1047 Posts
  • 311 Reply Likes
Hi Vidas

For a data point, I use a Maestro A and B both remotely with zero delays on the VFO's.  It is surprsingly good actually.

When we see this, we need to look at all the pieces of the path between the Maestro and the radio.  Even though you mention your WiFi works normally, most user operations do not required less than 100ms response time.  Moving Web data isn't the same as move HF radio data.  

If I was in your shows, I would look at ensuring that your hardware drivers are up to date for your devices.  I've seen this some solutions as simple as this.  

For your slow Maestro issues, if you did a test with a LAN cable connected to your router and not use WiFi do you still see the same Maestro slowdowns?  The other thought is you can try lowering your MTU value in the Maestro to a value like 1400 and see if that helps.  It is in the network settings/advanced.  

Mike va3mw
Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes
I have made some simple tests to discover the scope of the problem. When I turn the main tuning dial on the 6600m, there is an approximate 1.5 second delay before the frequency actually changes. This makes is extremely difficult to tune in any signal. If, for example, I spun the dial quickly for a change of 50khz or so, it might take 2 or 3 seconds to catch up. I tried without the internet connection, and no change in the behavior. The Maestro v2 on wifi, has no problem at all. SmartSDR also works perfectly. The issue only exists with the 6600m. Since there seem to be a number of us with this issue, and it makes the 6600m very difficult to use, I will file a report with support and ask for help.  
Photo of Harold Rosee

Harold Rosee

  • 150 Posts
  • 33 Reply Likes
6600M here on V3.0.27 and no lag at all.
Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes
Thanks for the info Harold. It doesn’t seem to be universal.
Photo of Duane, AC5AA

Duane, AC5AA

  • 463 Posts
  • 104 Reply Likes
My problem occurs with a 6600 (non-M) and the Maestro Ver 2.  However, I've been watching it for the last day or so - at least when I first start it up, it shows no lag.  Other times it will start lagging.  So, my issue is different from yours.  (It also shows no lag with SSDR and the FlexControl on the main PC.  'Tis a puzzlement.

Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes
Hmmm. It’s a puzzler Duane. My issue exists from boot up. The maestro and Pc work well without problem, and they are both on WiFi. It’s only the 6600m
Photo of Mark - WS7M

Mark - WS7M

  • 1350 Posts
  • 503 Reply Likes
I notice delays when on WiFi.  When hardwired there are no delays both on SSDR Windows and on Maestro.
Photo of Duane, AC5AA

Duane, AC5AA

  • 463 Posts
  • 104 Reply Likes
When mine lags, it happens regardless of whether I'm on 5G WiFi or ethernet.  I had hoped that hardwiring it would eliminate the problem.  (Always using the router, however - I have not tried direct CAT6 between Maestro and 6600.  SSDR works great.
Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes
Here is an interesting development. The issue has resolved itself with no changes to the operating state, other than turning the rig on this afternoon. The rig has been turned on and off many times while this problem persisted, but today, it is gone completely. It has been having this issue for about a month.
Photo of Warren-K6WKW

Warren-K6WKW

  • 16 Posts
  • 1 Reply Like
Just caught up on this thread. Al, if the problem comes back remember that shutting off power to the rig really has two levels - the usual level using the button on the front or the remote on/off on the back is the first level. The second level is removing power from the rig and letting voltages settle. There could be a difference to the internal face to radio connection reset when power is completely removed. This became more apparent reading the Flex upgrade instruction when changing from 2.4.9 to 2.5.1. This intermediate power-reset option might be preferred before doing a full factory reset. Of course, none of this probably matters if the problem does not recur.
Warren - K6WKW
Photo of Al Matthews

Al Matthews

  • 31 Posts
  • 6 Reply Likes
Actually, the problem has returned. Before the factory reset, I will try removing the power from the supply. Thanks Warren.