Found issue with Version 3.0.19 running remote

  • 1
  • Problem
  • Updated 4 days ago
running remote using a RS-232 serial cable with CAT control PTT RTS for my PTT I am having so weird Key and Un-key issues
Photo of WX7Y

WX7Y

  • 695 Posts
  • 139 Reply Likes

Posted 4 days ago

  • 1
Photo of Mack McCormick

Mack McCormick, Elmer

  • 424 Posts
  • 147 Reply Likes
It’s impossible to diagnose “weird”. Can you describe your issues? Are you using a key denounce circuit?

Mack
W4AX
Alpha Team
Photo of WX7Y

WX7Y

  • 695 Posts
  • 139 Reply Likes
I did but some reason it truncated my issues, here you go

Been running remote here for a year and a half (1.5) years using a RS-232 serial cable with CAT control PTT RTS for my PTT I am having some weird Key and Un-key issues with SSDR 3.0.19, this is a intermittent issue that keeps radio keyed or won't key, if it Keys the radio and stays keyed then several PTT clicks will usually stop it, audio also goes over the radio when it is stuck on but MOX button sometimes shows clouded out when it fails to key so I am certain it is NOT a PTT hardware error. I have Hard reset the radio, removed the CAT Drivers and manually re-installed them, rebooted the computer etc.
I have to restart SmartSDR for this to stop this behavior the next time it happens I will try to restart CAT.
Going back to version 2 I have no issues and this is with both my 6700 and 6600M running Remote.


I am  just letting people know this may be a issue if your running remote. 
I will be reporting this to FLEX tomorrow whom may already have this in the list of things to fix, I can't remember seeing it in the Release notes.

SSDR v3.019
Win10 Pro with 1809 update installed
Heil PTT switch and foot switch
PGXL Amp
Flex6700 and 6600M


73's
Bret WX7Y

Just tried it again and stuck on, Restarting CAT did not clear the stuck on MOX button 
(Edited)
Photo of Larry - W8LLL

Larry - W8LLL

  • 463 Posts
  • 100 Reply Likes
I experienced the same thing, I ended up going back to using the Remote MOX feature with frstack.

I discussed this with eric and they could not duplicate this issue on their end.

I made a video showing the issue.    https://youtu.be/8aYl8UUzJbM

I noticed when I had the log window open for that PPT port in the cat control panel it corrected itself, close the log window and it started again. I think Weird describes it pretty good.
(Edited)
Photo of WX7Y

WX7Y

  • 695 Posts
  • 139 Reply Likes
Glad to hear I'm not the only only one
thanks Larry