FLRig & Mac

  • 1
  • Question
  • Updated 3 months ago
Anyone had success with FLRig and a 6000-series on Mac? Easy enough to have the OS X versions of FLDigi and FLRig talk, but not sure how to get the rig into the mix via IP.
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1594 Posts
  • 561 Reply Likes

Posted 3 years ago

  • 1
Photo of Chip Swett

Chip Swett

  • 15 Posts
  • 1 Reply Like
Did you ever get this sorted out, George.  I've been unable to get fldigi on my mac to talk to my 6500.  I've tried RigCat with SmartSDR_SliceA.xml and Hamlib with Hamlib Net rgctrl (beta).  I don't know about flrig.   Of course it works easily when I run it on my PC.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 138 Posts
  • 41 Reply Likes
On a Mac, use xCat. Works great for me, with Fldigi and wsjt-x on a MacBook. Can set it up as IP or (pseudo)serial.
Photo of Chip Swett

Chip Swett

  • 15 Posts
  • 1 Reply Like
Thanks, Ted. I must not be setting xCat up properly in fldigi because it’s not working. Do you have a config screenshot or something else that can guide my setup?
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 138 Posts
  • 41 Reply Likes
I wrote an article on just this thing - getting Fldigi working on a Mac - it's here, Chip:
https://community.flexradio.com/flexr...

And here:
https://community.flexradio.com/flexr...

(Edited to reorder the two articles to make better sense in sequence)
(Edited)
Photo of Chip Swett

Chip Swett

  • 15 Posts
  • 1 Reply Like
Ted - Your 'how to' article is great and contains all the information I've been painfully pulling from other sources.  I'm going to put it in my reference file.

I am still not getting fldigi to read frequency. As you can see from the screen shot, I have Hamlib set up like your screenshot.  I notice when I initialize it, the Hamlib checkmark goes away. When I restart fldigi, Hamlib is not checked.  Occasionally I get the error message shown in the other screenshot.  
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 138 Posts
  • 41 Reply Likes
What is your xCat setup, Chip? That's where the connection from the rigctrl port is made to the radio. If that port is not set up to go to the correct slice on the radio, nothing will happen.

Also, in xCat, I set the "Mask as Flex6500" because I have a 6600, thus making my 6600 look like a 6500 to rigctl - you have that by default :-). In xCat make sure you have "Local" picked and your radio shows up.


Also, the rigctrl port must set up in the xCat slice configuration. It's the RigCtlD Port: number that is important here, although the exact number does not matter. I have the TCP port set up for wsjt-x.


Good luck. All the moving pieces, from radio, to xCat/xDax, Loopback and then app all need to have their interfaces connected properly. It;s not rocket science, but it is exact and a bit fiddly. The version of Fldigi I am using in the Mac is 4.0.17 with Hamlib NET rigctl. You also probably want to uncheck the "Audio on Auxilliary Port".
Photo of Chip Swett

Chip Swett

  • 15 Posts
  • 1 Reply Like
Victory!  You are a bloody genius, Ted. I didn't have xCAT configured properly. I have been beating this problem up for way too long now.  Now I can sleep again.  Thanks.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 138 Posts
  • 41 Reply Likes
The only thing better than a happy Flex user, is a happy Mac Flex user :-)