Flexradio 5000A is it working with Intel Skylake chipset and windows 7, windows 10??

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I tried to built a new fast PC for my Flex-5000a with PSDR 2.7.2. The mainboard was an Asus H70PRO Gaming. With windows 7 and 10 all kind of latency problems.

I build a new system with an ASROCK Z170PRO 4 mainboard. The same problems.

Is there anybody with a SkyLake chipset and a Flex-5000a without a problem?

73,

Matt PA9DX
Photo of Martin Van der Donk

Martin Van der Donk

  • 10 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2317 Posts
  • 529 Reply Likes
What I would do?, call Dudly at Flex. Know your chipset on the nic card for your firewire. I'm sure he will get things working well for you....
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 427 Posts
  • 128 Reply Likes
Martin, I have a customer who is experiencing issues with the Z170 Southbridge chip, the setup does not work on any setting except 48000Hz/512 bytes setting. 

I sincerely think its a firewire issue with the z170 chipset.

Does anyone have a firewire card working with a Z170 motherboard?

73
Photo of Martin Van der Donk

Martin Van der Donk

  • 10 Posts
  • 0 Reply Likes

The TI XIO2200 used in a lot of FW400 cards no longer works properly on any X99 / Z170 boards and your better off going for a TI based FW800 solution using the XI02213 chipset.

This card is working here with win10 and skylake.

Delock PCI Express Card > 2 x external FireWire B + 1 x external FireWire A
Item No. 89153

Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 427 Posts
  • 128 Reply Likes
Thanks Martin. Is there documentation online about the incompatibility? The card I was trying to make work was indeed the XIO2200 chipset.

BTW, this is the chipset used in the recommended firewire adapter from Flex (and the one I use in my computers).

73
Photo of Martin Van der Donk

Martin Van der Donk

  • 10 Posts
  • 0 Reply Likes
Dear Neal,

It's 100% the same problem I had! I think Flexradio shoot update their advice and advice not to use the TI XIO2200A chipset! I tried everything, but a new firewirecard with an other TI chipset made it work. After 4 months of trouble!
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 427 Posts
  • 128 Reply Likes
Martin,
I tried an 800 speed card that had 1 400 speed socket with the same result but I do not think it was the chipset you referenced. I will test with an 2213 card and see how it works.

Thanks for your feedback. I am sure this will be very common in the next months!
Photo of Martin Van der Donk

Martin Van der Donk

  • 10 Posts
  • 0 Reply Likes
Neal,

This is the card I am using. It workes fantastic!

DeLOCK FireWire PCIe Card, 1xA+2xB Port, Controller(89153, Retail)