Flexcontrol works intermittently with SmartSDR V1.10.16

  • 1
  • Problem
  • Updated 1 year ago
I recently updated SmartSDR to V1.10.16. Since the update, my Flexcontrol knob operates intermittently. It will work for several seconds, then freeze for a brief time, sometimes as long as 15 seconds, then resume. SmartSDR also will periodically "crash" displaying a dialog window that indicates it crashed while doing something with the Flexcontrol. SmartSDR continues to run and function (less the Flexcontrol functions) until the dialog box is acknowledged, at which time SmartSDR also stops running.

If I open the "Flexcontrol" dialog in the SmartSDR Settings menu, the window for configuring the flex control appears, but it, too is intermittent, toggling between greyed out GUI with "Flexcontrol not detected" displayed in the center of th GUI. The settings 'grey out' time corresponds to the times the control functions freeze.

Rig is a Flex 6300, with SmartSDR V1.10.16 running under Windows 10 on a PC with an Intel i7 CPU. The rig and the controlling PC are both connected to a wired Ethernet hub.. I see no conflicting comm ports, all looks normal.

It all worked fine until I updated SmartSDR. For now, the Flexcontrol is unplugged, it's kinda useless and actually annoying to try and use. Any ideas?

Mike, N0SO
Photo of Mike Heitmann

Mike Heitmann

  • 12 Posts
  • 2 Reply Likes

Posted 1 year ago

  • 1
Photo of WX7Y

WX7Y

  • 536 Posts
  • 98 Reply Likes
Mine does this as well and sometimes the Flexcontrol crashes my computer if I have it plugged directly into it, plugged into a powered USB HUB it acts as yours does so I can no longer use the Flexcontrol.
I think the USB chipset has gone bad at least in mine, I have not sent this to FLEX as I figured it would cost more to fix then it was worth.

73's
Bret
WX7Y
Photo of Mike Heitmann

Mike Heitmann

  • 12 Posts
  • 2 Reply Likes
Thanks, I didn't think about the control being defective.
Photo of WX7Y

WX7Y

  • 536 Posts
  • 98 Reply Likes
Before you think it is a Hardware issue, here is the Flexcontrol driver re-install routine.
https://helpdesk.flexradio.com/hc/en-us/articles/205004159-How-to-Manually-Reinstall-the-SmartSDR-Fl...

73's
Bret
WX7Y
Photo of YV5WZ

YV5WZ

  • 383 Posts
  • 47 Reply Likes
Just Change FlexControl COM Port, usually when that's happening, it's because a Com Port conflict

George, YV5WZ / PY3ZZZ
Photo of Mike Heitmann

Mike Heitmann

  • 12 Posts
  • 2 Reply Likes
Thanks, I almost always see duplicated FlexVSP comm ports after an update, so I had already corrected those. If it's a comm port conflict it doesn't show up using any of the usual tools.
Photo of YV5WZ

YV5WZ

  • 383 Posts
  • 47 Reply Likes
I lived that experience....exactly the same....I did assigned a high number port 98....and never had that problem again.....give a chance and let me know...
Best regards

George, YV5WZ / PY3ZZZ 
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
A few things.

1.) Set the FC serial port to a high number so it will not conflict with other USB serial devices and virtual serial ports.  Mine is set at 250.  Also, do not change USB ports that the FC is plugged into as this will changed the serial port number  
https://helpdesk.flexradio.com/hc/en-us/articles/202479329-How-to-Change-the-Com-Port-Assignment-for...

2.) If the FC is working intermittently, it may be because the USB controller is operating at a lower speed due to a low-speed device being connected to the same controller as the FC.  This mostly affected the FLEX-1500, but it is also applicable to the FC  
https://helpdesk.flexradio.com/hc/en-us/articles/202118498-FLEX-1500-USB-Performance-Degradation-Due...

3.) You may have a power management issue with the USB port the FC is connected to.
https://helpdesk.flexradio.com/hc/en-us/articles/204290929-How-to-Disable-Power-Management-for-USB-c...

4.) You are experiencing latency on the USB port due to FIFO buffering issues.
https://helpdesk.flexradio.com/hc/en-us/articles/202118458-How-to-Mitigate-FlexControl-Latency
(Edited)
Photo of G6VFI

G6VFI

  • 1 Post
  • 0 Reply Likes
same problem here..... new Flex control. Drops in and out all the time. tried all the above no difference, FIFO off seems to make it worse. drops out and needs a reconnect to work again.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
If you have tried all the suggestions above and are still having issues, I recommend that you open a HelpDesk support ticket.
Photo of Adrian Jones

Adrian Jones

  • 1 Post
  • 0 Reply Likes
The upgrade to V2 solves this issue.