FlexControl with v1.4.16

  • 5
  • Question
  • Updated 4 years ago
  • Answered

With v1.4.16 I have to start SmartSDR two times to get the FlexControl to work. I down grade to v1.4.11 and it works like it should. In v1.4.16 this only happens when I shutdown the computer and 6300 and power supply. If I leave the power supply and radio on  the FlexControl works first time when I start the computer. Anyone else seeing this? The FC shows up in Device Manger every time. I double check it before I state SmartSDR for the second time.

Thanks for helping

Terry

K7NY

Photo of Terry Tankersley

Terry Tankersley

  • 58 Posts
  • 5 Reply Likes

Posted 4 years ago

  • 5
Photo of Jay / NO5J

Jay / NO5J

  • 1674 Posts
  • 263 Reply Likes
Terry
My Flexcontrol had its com port reassigned by windows, when I did the upgrade, once I corrected the assigment It worked, it didn't require a reboot or a reinstall of anything.
See if you port assignment still matches.
73, Jay NO5J  
(Edited)
Photo of Jim K4JAF

Jim K4JAF

  • 371 Posts
  • 114 Reply Likes
I am seeing the same as you with the 6500.  Sure Flex will get it figured out soon.  73s Jim K4JAF
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
No problem here. BTW: I'm using Windows 8.1. What are you guys using that are having trouble with? Win 7?
Photo of Terry T

Terry T

  • 14 Posts
  • 0 Reply Likes

I am using 8.1, the com port is not changing. Like I said it works perfect in 1.4.11.

I will check the power management also.

Terry

Photo of Jay / NO5J

Jay / NO5J

  • 1674 Posts
  • 263 Reply Likes
Win8.1 here but I solved it.
(Edited)
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 562 Posts
  • 191 Reply Likes
My first guess would be that you have not turned off power management on the USB hubs inside the device manager. Go to your control panel and look for Device Manager. Then look for USB Controllers. Expand that and double click on each item that is called a hub. See if you are presented with a tab called Power Management. If so, uncheck each checkbox that you see!
73
(Edited)
Photo of Tom--W4FAS

Tom--W4FAS

  • 44 Posts
  • 10 Reply Likes

Hi Neal,

I followed your advice and it seems to have fixed the problem. I have a Flex 6500 and my computer runs Windows 8.1.

Thanks for your help.

Tom


Photo of Terry Tankersley

Terry Tankersley

  • 58 Posts
  • 5 Reply Likes

I tried that and it didn't help.

Terry

Photo of Tom--W4FAS

Tom--W4FAS

  • 44 Posts
  • 10 Reply Likes

Hi Neal,

The mystery deepens. When I booted up my system this afternoon I had no flex control. When I looked at the eight hub boxes I had unchecked, I found the first box was now checked. I unchecked the first box and my flex control is back.

Who is the mystery box checker? I bet Tim knows.

Tom

Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 562 Posts
  • 191 Reply Likes
Tom, I have seen this happen, even on the computer I am building right now for a customer and I have no idea how these get reset. 
Photo of Tom--W4FAS

Tom--W4FAS

  • 44 Posts
  • 10 Reply Likes
Hi Neal,

One last data point. I lost the Flex Control again, I looked at the eight hub boxes and they all were still unchecked.. Thus ends my career as a trouble shooter. I am really much better at drinking beer anyway.
73,
Tom
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
The mystery box checker is Windows.  It is the USB Selective Suspend feature.

Refer to this article: https://helpdesk.flexradio.com/hc/en-us/articles/204290929-How-to-Disable-Power-Management-for-USB-c...
Photo of Terry T

Terry T

  • 14 Posts
  • 0 Reply Likes

I tried this and unchecking all the boxes but it still takes two times to get the FC to work. Maybe  Windows 10 will work better. Everything else works great.

Terry


Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Official Response
We are aware of this issue.  It does not seem to be related to the FlexControl driver or Windows and its crazy interactions with all things USB.  And it is intermittent which makes it hard to find root cause.

We believe it has something to do with how SmartSDR is detecting the presence of a FlexControl that is connected to your PC.  We investigated it yesterday and will continue to look into it next week.  At this point restarting SmartSDR or possibly disabling and re-enabling it in the Setup is how to mitigate the issue.
Photo of Burt Fisher

Burt Fisher

  • 1268 Posts
  • 484 Reply Likes
I do not have Flex Control and it happens almost all the time, need to start twice
Photo of Terry T

Terry T

  • 14 Posts
  • 0 Reply Likes

I have been playing around with the FC this morning, in my desktop I have DDutil V3 for my amp only nothing else is checked. If I start DDutil before SSDR the FC works first time every time.

I went to my laptop and connected the FC ( no DDutil installed ) and it works first time every time.

I looked in Cat on the desktop and under physical ports /or foreign virtual ports shows com2 and com45 (FC ), on my laptop I don't see any other ports except the virtual com ports on both lap or desk.

Terry 

Photo of Clay N9IO

Clay N9IO

  • 633 Posts
  • 170 Reply Likes
Just got around to updating SSDR yesterday (Sat).

I am running WIN7 Pro 64. Flex control is on com12.
I notice in CAT that com4 / 14 is gone. Windows control panel sees it but not CAT.
I add a comport13 / 23 in CAT, reassign it and it turns to 4/14.
The part that makes no sense is that at this point the flex knob starts working.
Devil if I know, glad you're on the job Tim.
Lemme know what you figure out.

Clay N9IO
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
This sounds like a different problem.  One where you have "ghosted" virtual com ports that are confusing Windows and any application that uses serial ports.  Here is an article you can use to remove the ghosted com ports

https://helpdesk.flexradio.com/hc/en-us/articles/200883925-Removing-Hidden-or-Ghosted-Com-ports
Photo of Bill N3HQB

Bill N3HQB

  • 44 Posts
  • 10 Reply Likes
Here are two screenshots or error messages when trying to connect the Flex Control...

(Edited)
Photo of Jim K4JAF

Jim K4JAF

  • 371 Posts
  • 114 Reply Likes

It must be a very intermittent problem.  I had the same problem with the Flex Control not working on reboot of the computer and 6500 shut down...  Attached it via DDUtil and all fine..  Went back to controlling it on SmartSDR and has worked just fine for 2 days now with reboots, etc..

So not sure myself what is happening, sure flex will get a grip on it.. 

73s Jim K4JAF

Photo of Steve Walker

Steve Walker

  • 71 Posts
  • 10 Reply Likes
Yup am seeing this as well in the current version.

If I disable and enable the flex control driver in the device manager MMC then it's detected by SSDR the moment the device becomes active again and becomes usable.

However from power on the Flex control is not seen in SSDR, if you open the FC applet in SSDR it shows that the flex control is not present even when it is working as expected.

However and of interest DDUtil cannot take control of the knob as it says the com port is in use by another program - which I assume is SSDR even though it cannot use the control nor see its presence it has still flagged the port for itself.

No amount of reboots helps only the disable and enable the driver in the hardware MMC.

73 Steve
Photo of Bill

Bill

  • 42 Posts
  • 2 Reply Likes
Unfortunately, I am getting the same problem with the Flex Control but the software update has cured one problem I was getting and that was losing the Network connection on a regular basis. 1.4.16 seems to have cured that problem.
73, Bill
Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes
Add me to the list. Never had this problem before upgrade to last update to 1.4.16. When booting ssdr flex is not detected and i have to plug and unplug flexcontrol several times to get it to work. Again, this has not been a problem prior to 1.4.16
Photo of Peter Kirsop

Peter Kirsop

  • 36 Posts
  • 4 Reply Likes
I too have this issue. Not critical but a nusience. Hope for a fix soon.

Peter GM4WCE
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
For only one time over a period of a year, Flex Control died. This happened a few weeks ago with 1.4.16

Turning of/on SSdr had no effect.

Unplugging the FC and replugging fixed it.

This incident happened just recently after I decided to download and play with ddutil for the very first time. The reason I downloaded it was simply to observe the termperature. So I fiddled with ddutil for a while then closed it and haven't used it since. 
Windows 8.1 here...
Happened only one time and not since then. 
Photo of Mike W9OJ

Mike W9OJ

  • 104 Posts
  • 38 Reply Likes
Happens every time to me. Switched back to 1.4.11
Windows 7 Pro 64

Mike W9OJ
Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes
Yes yes!! this version does not pick up the flex control.  took me 5 times to get it working. does not happen in prior versions at all.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
This has happened to me several times now, after turning off SSDR and leaving the rig and computer powered up overnight.

If I go I nto the setup/radio tab and turn the flex control off for a few seconds, then enable it again, it comes back to life.
Photo of Steve Gw0gei

Steve Gw0gei

  • 193 Posts
  • 50 Reply Likes
Yes thats my quick work around too
Photo of K9SO

K9SO

  • 116 Posts
  • 25 Reply Likes
I just got my brand new FlexControl yesterday and it has never worked (with 1.4.16 or anything else for that matter). About to send it back for a refund when I read these posts. I'll wait a few more days I guess.
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 562 Posts
  • 191 Reply Likes
Fred,  I can bet that the Flexcontrol has been assigned a comm port address that is already in use, which is why it doesn't work. Have you looked at the Ports section of the Device Manager?
Photo of K9SO

K9SO

  • 116 Posts
  • 25 Reply Likes
Thanks for your response Neal.

Yes I have. It has not been assigned a port that is in use. I have looked at all "ghost" ports and there are no duplicates. I have reloaded SmartSDR in case the drivers didn't load properly. 

K9SO
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 562 Posts
  • 191 Reply Likes
If you send me an email ar nealk3nc@gmail.com I will be happy to conect to your computer and take a  look!
Photo of K9SO

K9SO

  • 116 Posts
  • 25 Reply Likes
Thanks for the offer Neal, but we weren't able to hook up tonight. I've changed the port number just in case and that still didn't work.

I've opened a ticket on the issue.

73,

Fred
K9SO
Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes
in the new version .16 there is a problem with picking up the flexcontrol. I never had a problem before the update. Now i have to refresh the device manager many times before it picks up. the port has not been changed. It works after some plugging in and refreshing at each boot now.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Go to Settings>Radio and Disable FlexControl for a few seconds, then Enable it again.  It works every time on my 6500.  But I must do it every time I shut down SSDR and restart it.  
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3980 Posts
  • 969 Reply Likes
The Flex control problem is a known issue, They are working on it...
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Update on Fred's Issue:  The FC was disabled in the SmartSDR setup form, which is why it would not connect.