Flexcontrol - superscrolling

  • 1
  • Problem
  • Updated 5 years ago
  • In Progress
  • (Edited)
I have disabled, rather than reducing, my com port buffers.

I was playing around with my Flex 6300 as a general coverage receiver and was spinning the Flexcontrol quite rapidly to change frequency within a reasonably short period. The tuning would continue for many MHz after the Fcontrol had stopped being used and I could not even stop it.

Is there any way to stop this excessive scrolling other than to stop using the Flexcontrol?

I even managed to get SSDR to read a negative frequency and could not get it to go above 0 Hz again.

Mni Tnx and HNY to all

Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
  • festive and optimistic

Posted 5 years ago

  • 1
Photo of David Vernier

David Vernier

  • 27 Posts
  • 8 Reply Likes
I was going to suggest a "10x" option for the Flex control buttons to reduce the amount of dial spinning when tuning with it. I have the tuning knob in the 10Hz position normally, it would be nice to just hit a button and have it bumped to 100Hz (or maybe even 1kHz) when I have a lot of "ground" to cover. A lot simpler than changing the step on the screen all the time...
(Edited)
Photo of Rich McCabe

Rich McCabe

  • 1237 Posts
  • 259 Reply Likes
The 10x option would be great. Actually, the options for flex control are really lacking. Hoping they fix that soon.
Photo of Dale KB5VE

Dale KB5VE

  • 418 Posts
  • 56 Reply Likes
Yes this is a problem. I do not remember it happening on the power sdr.
Photo of Dale KB5VE

Dale KB5VE

  • 418 Posts
  • 56 Reply Likes
Does not do it on the knob using ddutil.
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
Hi Dale,

I find I can reliably crash SSDR vy using the Flexcontrol knob quickly. I have not done enough experimenting to see if a slower speed would help - I have only used my 6300 as a general receiver for a couple of nights. I do not want tuning a few MHz slowly enough to avoid a crash to take half an hour, hi hi.

Whilst Ddiutil is a very good piece of software and I do have it installed, I do not need to use it at the moment. I would prefer that the official software is fixed rather than using another to mask the issue.
Photo of Dale KB5VE

Dale KB5VE

  • 418 Posts
  • 56 Reply Likes
I use both have two flex knobs like the way you can set it up with ddutil
(Edited)
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
Using Win 8.1. I can spin my Flex-Control madly and it stops exactly when I do and never crashes. I can even take one finger and flip-spin it insanely and it's exactly like any other knob on a radio. So something is different on your end Guy. Oh...No ddutil here...Just SSDR. 
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
Did you scroll over many MHz or just within the Ham bands?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9399 Posts
  • 3640 Reply Likes
Official Response
We have modified the adaptive accelerated tuning algorithm in the next version of SmartSDR.  However, your problem sounds like issues with the USB port the FlexControl is connected to.  

When you spin the dial you are instructing the radio to perform a lot of tuning operations, even when the accelerated tuning algorithm kicks in when the knob is rotated faster.  Tuning the radio hardware is a fairly fast operation.  Representing that tuning change on the SmartSDR console may not.  There are several reasons for the behavior you are seeing.

1.) Windows may be queuing the tuning commands.  Please refer to the HelpDesk Help Center article How to Mitigate FlexControl Latency to minimize the latency with the USB com port.  It the USB controller is shared with other devices, especially one that are polling devices, that can cause the behavior you have described.  Also, if the USB port is a USB3 port, it can have issues with USB 1.1 devices; try connecting to a USB 2.0 port if possible.  We have even had to recommend to some customer that they get a USB 2.0 add-on card and use it because the USB3 controller on their motherboards just didn't work well.

2.) The delay can be associated with the ability of the graphics adapter to render the display fast enough for the multiple tuning operations that the radio is performing when you spin the knob.  If it can't keep up, then there is a queuing lag.  We see this mostly on systems with integrated graphics because they render slower.  One reason is that they use system RAM rather than dedicated graphics ram.  In these cases, replacing the integrated graphics with a add-in graphics card resolves the issue.  This issue is compounded if the width of the panadapter is wide, if the panadapter has to tune as a consequence of the slice being tuned and if there are multiple slices visible.

3.) The Tune Step is set too high.  With a large tune step setting, rapidly rotating the FlexControl can result in large jumps in tuning.

And lastly. if you want to make large changes in frequency of a slice, spinning the FlexControl knob is not the most efficient or precise way to tune the radio.  Direct frequency input only performs one tune operation in the radio and one display rendering operation rather than possibly thousands in less than a few seconds.

Your report of a program crash leads me to believe something else is going on that is system related and not a systemic software defect.  I see you have a HelpDesk ticket opened on this issue, so the issue of the crash should be investigated first.
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
HI Tim,

It is likely to be number 2 in your answer as I stopped using my dedicated graphics card as it performs the same as the integrated one. I use the nVidia beta drivers and got fed up setting the nVidia card for SSDR with each driver change a while ago.

I'll go back to the nVidia again for this reason alone. Many thanks for your comprehensive and informative post.