FlexControl suddenly broken

  • 1
  • Problem
  • Updated 4 years ago
FlexControl suddenly does not move smoothly and push button function of the dial does not work.   Does anyone experience such problem?   Any suggestions to fix it?    I ordered one today, but it will take a week or so to arrive.
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes

Posted 4 years ago

  • 1
Photo of Stu Phillips - K6TU

Stu Phillips - K6TU, Elmer

  • 642 Posts
  • 256 Reply Likes
Yamada-san,

From your description, it sounds like the shaft encoder on the central knob has failed.  When you say the FlexControl does not move smoothly, are you saying that when turn turn the knob it is stiff to turn, or as you turn it you can feel something grating or perhaps as you turn, it feels as though you are driving over bumps?

If the feeling is something like the above and when you press the knob to activate the push function doesn't work, then it is a mechanical failure of the shaft encoder.

The shaft encoder is a mechanical device - if the FlexControl was dropped that could explain the failure.

Sorry you are having the problem.  
Stu K6TU
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
Thank you Stu for reply.
It is a hardware problem the second case you are describing.    It made me feel like; suddenly power steering turned off and becomes to 50 years ago manual steering.   Apparently, the shaft encoder was broken, however, there has been no chance to drop nor had a chance to get an abnormal power.  So, I raised a question - it is about one year old.
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
Wow!  Good news, Ken.
I will ask FRS if it is within the warranty period.
The problem here is the delivery costs more than the product and costs me >$200!!
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Disclaimer...I have no official connection with FRS and make no promises or policy statements on their behalf...But I would certainly contact FRS and open a help desk report.  If you are within the warranty period, you may have a positive result.  But, WOW!  >$200 to ship a small package your way?   
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
I emailed to order@frs if I can ask to repair with the copy of previous communication mail for the first order.  So, it will be OK.  (I might be better open help desk, first)
The shipping costs $114.  And worse, the last time it was lost on the way to hub from Austin and FRS resent the other one.
The other side of the world bears a lot of costs.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
Takeshi - please open a HelpDesk ticket so we can troubleshoot the problem.
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
Done!
Photo of Rich McCabe

Rich McCabe

  • 1050 Posts
  • 222 Reply Likes
Currently they are apparently out of stock. I am waiting for a replacement now. Mine has a wobbly shaft but spins freely.   It works OK but does not feel very good and the push click part is less than ideal. Not what I would expect from a 30 day old unit. But they are going to fix me up. Hope it was just a bad batch of encoders :)
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
Ah! again....  Months of operation without FlexControl is nothing, but a pain!!

It may not be a good idea of push switch function on dial.   Three toggle button will be enough and it might lessen the dial problem.
Photo of Stu Phillips - K6TU

Stu Phillips - K6TU, Elmer

  • 642 Posts
  • 256 Reply Likes
I can only assume there was a bad batch of encoders.  These encoders are used in many applications and are rated for very large numbers of operations.

As I said, the unit beside me is now 4+ years old and gets a SERIOUS amount of use...  the basic encoder part itself is good.

There must be some other problem here...
Stu K6TU
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
Received the message that they only can ship out the good after ARRL Ph, Monday.  Sigh....
It is not a good timing.  E3 - Eritoria starts and ARRL Ph this weekend.

73 de JI1BNU, JA2IYJ/1
Ken Yamada
(Edited)
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
By the way what kind of tool needed to put off the dial nob?
I tried plus/minus driver, square wrench (collins uses), hex wrench, but seemingly not fit....
The new one is on the way stopping at Memphis and will be available next week.  So I want to repair the broken one with zero risk.

73 de JI1BNU
Ken Yamada
Photo of Rich McCabe

Rich McCabe

  • 1050 Posts
  • 222 Reply Likes
Its an allen wrench. Standard (non metric) I believe.
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Yes. It is a very small Allen wrench. I don't remember the size, but when I found one I taped it to the side of my FlexControl Knob with black tape in case I ever need it again.
Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
Thank you Ken. 
It is hex wrench sized 1.27. 
I am trying to find shaft encoder to replace.
73 de JI1BNU
Photo of Tom--W4FAS

Tom--W4FAS

  • 44 Posts
  • 10 Reply Likes

Takeshi,

As I recall, several months a go there was an incident where a FlexControl suddenly malfunctioned. Several of the good folks on this forum jumped in with possible explanations of the problem and offers of help. About 24 hours after his original post the owner of the problem unit reported he had discovered the control knob was simply slipping on the shaft and he had repaired the problem.

Takeshi, your last post reminded me of this incident. I doubt the solution to your problem will turn out to be so simple. But while you are waiting for your replacement FlexControl, you might do a search of this forum and try and identify the writer of the post I refer to above. He could certainly answer your question concerning what kind of tool do you need.

Good Luck,

Tom


 

Photo of Takeshi Yamada

Takeshi Yamada

  • 171 Posts
  • 48 Reply Likes
It is shaft encoder problem - does not revolve.
hex wrench sized 1.27 worked and took the nob off.
I am trying to fined substitution and to replace it.

73 de JI1BNU