FlexControl Changes Functions

  • 1
  • Problem
  • Updated 11 months ago
  • In Progress
My FlexControl knob changes functions on its own.  My buttons are AUX 1 = Slice AF, AUX 2 = AGC-T, AUX 3 = RIT, main knob = Tune Slice.  SmartSDR version 1.8.4.168.  FlexControl is assigned to COM160.

I select AUX 1 for Slice AF.  I next go to the main knob for Slice Tune.  On its own, the FlexControl will go back to AUX 1.  It may take 15 seconds, it may take 5 minutes, but it will always go back.  This is a real surprise when you decide to change frequency a second time and when you turn the knob you get a blast of AF instead of a different frequency.

Not a huge thing, but annoying.

Just me?  A fix?

73 de K1ESE
John
Photo of K1ESE

K1ESE

  • 120 Posts
  • 14 Reply Likes

Posted 3 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
I have converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.
Photo of Ron Parsons

Ron Parsons

  • 73 Posts
  • 10 Reply Likes
Tim, is this issue still unresolved? I am still experiencing it on SSDR v2.0.19.
Any idea on time to resolution?
Ron
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
The defect is in an open and unassigned state. I do not have any ETA information on it. 
Photo of Jim K4JAF

Jim K4JAF

  • 361 Posts
  • 105 Reply Likes
I also having this problem..
Photo of Michael Thursby

Michael Thursby

  • 1 Post
  • 0 Reply Likes
I am also having this problem.
Photo of Dave - W6OVP

Dave - W6OVP

  • 275 Posts
  • 93 Reply Likes
Also having this problem here...  Flex 6300 w/1.11.12
Photo of Stewart, GM0GTU

Stewart, GM0GTU

  • 23 Posts
  • 2 Reply Likes
Hi John,
               I had a similar problem a wee while ago. Every time I turned-on my Flex 6500 the Flexcontrol settings were gone.
Dudley WA5QPX suggested that I delete or rename the ssdr settings file in SmartSDR, so that it would create a new file. This worked, and It's been fine since.
Worth a try?

Best regards,  Stewart  GM0GTU
Photo of Ira Stoler

Ira Stoler

  • 3 Posts
  • 0 Reply Likes
I'm having the same problem with FlexControl and SmartSDR.  Randomly but consistently mine lights up AUX2 when tuning knob is selected.  Where is the location of the ini file Stewart mentioned?

Thanks.
Ira K2RD
Photo of Ira Stoler

Ira Stoler

  • 3 Posts
  • 0 Reply Likes
Found it!!  Deleted ssdr.settings and problem seems to have disappeared!

73

Ira K2RD
Photo of Ira Stoler

Ira Stoler

  • 3 Posts
  • 0 Reply Likes
I spoke too soon.  Just took longer to happen.  Not fixed?
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 594 Posts
  • 129 Reply Likes
Something similar has been happening to mine lately.  Every so often, AUX3 (XIT) will come on by itself.  The setting hasn't changed, but it just activates itself without me pushing the button.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
Official Response
I have added a defect (#3934) to our bug tracker to investigate this reported behavior.
Photo of Jim K4JAF

Jim K4JAF

  • 361 Posts
  • 105 Reply Likes
I too noticed this defect yesterday after updating to 2.0.19.  The middle light will change randomly to the third light choice.  Will delete the ssdr.settings file and see what happens.. 
(Edited)
Photo of K1ESE

K1ESE

  • 120 Posts
  • 14 Reply Likes
After a help desk ticket and trying all suggested solutions, I still have this issue and got tired of trying to fix it.  As an aside, I usually use N4PY software with my Flex and N4PY assigns a large number of possible functions to the knob.  Never had the problem when N4PY accesses the knob, so assume the hardware is fine.
Photo of N5LB - Lionel B

N5LB - Lionel B

  • 194 Posts
  • 54 Reply Likes
Has this issue with the FlexControl changing function been resolved? 

Flex 6400 ver 2.1.32.104

Aux 1 is set to tune active slice.  After a few minutes, and this varies, it changes on its own to Aux 3 which is set to AGCT.  It does not on its own change to any other function after this.

I have not seen this prior to v2 when I was using a 6300. 
Photo of Tom

Tom

  • 47 Posts
  • 6 Reply Likes
Lionel, have you resolved your problem? I'm thinking about buying one but, unless I've missed it,  I haven't seen a published resolution since it was mentioned 2 years ago.
Photo of N5LB - Lionel B

N5LB - Lionel B

  • 194 Posts
  • 54 Reply Likes
Well, I've decided its no longer a problem though probably not a feature.  I use the three buttons, left to right, as AGCT, Slice Audio, and Slice Freq because I found the control was not switching randomly but always came back to the right most button.

Slice Freq is my most used it comes back from AGCT or Slice Audio on its own.  Now, for me it is useful. 

Also these are the only three Flex Control functions that I use.  Maybe I'll try some others.

I have no idea why it always switches back to the right most button, maybe it is supposed too.  Never noticed this until month ago.
Photo of K1ESE

K1ESE

  • 120 Posts
  • 14 Reply Likes
Still the same problem here.

73 de K1ESE,
John
Photo of W7NGA

W7NGA

  • 445 Posts
  • 189 Reply Likes
v2.1.33 
FlexControl changes state randomly without user interaction. Ends at right-most position.
(Edited)
Photo of John  - W8AGS

John - W8AGS

  • 48 Posts
  • 13 Reply Likes
John, Lionel,

Have you tried using the DDUtil program for the Flex knob? I used it with my 6500 and now the 6600. It’s a very good program that can be used for other functions ie. amps, tuners, etc. Never had a problem with the knob.

John, W8AGS
Photo of K1ESE

K1ESE

  • 120 Posts
  • 14 Reply Likes
I use N4PY which performs many of the same functions as DDUtil as well as others. 

The Flex Control woks perfectly with N4PY.  The problem only shows up when the Flex Control is being used directly with SmartSDR