Flex6700 / Maestro Ethernet problem-IPs broken SSDR not accessible

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hello there.
After receiving my new Maestro and unpacking the great stuff, I installed an wired the console exactly as written in the startup manual by Flexradio. The Maestro starts up the first time and performing well, its really great fun!

But after disconnecting the Maestro I tried to get a connect to my Radio by the PC as I did the work for the 2 years ago without any problemd at any time.

I can not connect anymore to my radio!

I noticed, that the IP adress of the Radio did change from my DHCP driven network 192.xxx to a 169.xxx what is the same subnet the Maestro shows me under connect.

The IP of the radio cannot be revertet, and also the Maestro does not accept the "normal" subnet I normally use (the 192.xxx).
The radio and the Maestro are connected both to a router wich has DHCP definitly enabeled. The network is checked, the router ist performing well. A WIFI is not present in the shack, so it has not been tried and enabled until now.

I made a complete shutdown, removing power, reconnect power and startup the flex6700 again twice without any changes to the internal flex IP which is now fixed by 169.xxx and which does not accept DHCP from the router anymore.

So my Radio cannot be accessed by WINSSDR anymore.

The Meastro does have the Firmware Version 1.72.xx by delilvery, the radio the 1.70.xx what has been downloadable at least.

What can I do anymore?
Thanks for your hints .
Frank
DJ0QZ
Photo of Frank DJ0QZ

Frank DJ0QZ

  • 3 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Paul - W3PH

Paul - W3PH

  • 26 Posts
  • 4 Reply Likes
That's a DHCP problem - if a device gets a 169.x.x.x IP number, it didn't get a DHCP assignment from the router.  Neither the Maestro nor the radio have DHCP-assigned IPs, but the PC does.  Maestro and radio can see each other because they're on the same 169.x.x.x subnet, but the PC is on the 192.x.x.x subnet and can't see the other devices.  PC can see the internet but the Maestro and radio, on 169.x.x.x, can't - they don't have a gateway they can use.  Try power cycling your router, and then power-cycle the radio and the Maestro and see if they get the 192.x.x.x IP numbers you need.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3479 Reply Likes
Frank,  if Paul's suggestion does not work, please submit a support ticket via our HelpDesk (http://helpdesk.flexradio.com) so we can assign you a case number.  For details on how to submit a HelpDesk support ticket, please refer to the following URL: http://helpdesk.flexradio.com/hc/en-us/articles/202118688-How-to-Submit-a-Request-for-Technical-Supp...   Once the support ticket is submitted, a support engineer will be in contact so we can work on the issue.  Make sure to include your radio's serial number.
Photo of Danny K5CG

Danny K5CG

  • 307 Posts
  • 45 Reply Likes
Start with the minimum needed to work, the Maestro and the Flex with a single Ethernet cable. They will both start up on the 169.254.x.x network. If that doesn't work then you've got a real problem with one or the other.

If it does work then connect them with Ethernet cables directly (not WiFi) to the same router. Verify they get the 192.168.x.x addresses you expect.

Keep working out away from the center and add a little more complexity each step until you get where you want.
Photo of Frank DJ0QZ

Frank DJ0QZ

  • 3 Posts
  • 0 Reply Likes
Meanwhile I detected the problem. I ́m here in the shack behind a fibre internet connection. Until days(weeks(?)) ago the (super)admin provided an DHCP to my subnet. This is due to security reasons and hardware changes not more available. I dind ́t notice that because all of the hardware (ports) is manually configured, from local IP to DNS servers. The station was at anytime accessible remotely from the internet.
But I had to cut off all lines due to a heavy thunderstorm. After repowering the shack I got ths problem.
So, infact, I have not  any DHCP available but the normal internet access etc. by my "hardwired" LAN ports, computers etc in the shack. All runs but FLEX is no more available by my PC because the machoine cannot reach the "new" IP.

The Flex falls to a 169.254.0.x adress, the Maestro runs with a 169.254.9.x adress, both in a 255.255.0.0 subnet. The both can run with each other, so the Flex works together with Maestro perfect, but with NO internet accessability, PC access not possible, no update possibility and so on.

I did not read/find any post by getting the IPs the right way for me for my Flex "by hand", so I will open a support ticket today to get a hopefull solution. Thanks all for the suggestions and Help!
73 Frank
Photo of Phil m0vse

Phil m0vse

  • 205 Posts
  • 38 Reply Likes
Hi Frank, it isn't (currently) possible to manually assign an IP address to 6x00 series Flex radios. You are best to try to enable DHCP on your router/firewall. If this isn't possible for security reasons, you can get LAN->LAN routers which can sit between your Internet router and LAN which can provide DHCP services. Another option would be to install a DHCP server on your PC.

Something like http://www.dhcpserver.de/ should work but I haven't tried it.

73 Phil
Photo of Frank DJ0QZ

Frank DJ0QZ

  • 3 Posts
  • 0 Reply Likes
Phil,
thank you for the recommendation.
I put a PI as a DHCP server in the network and that solves that problem actually as a workaround.
Hopefully we will be able some time to give a fixed IP to our radio by FRS.
Thank you and the other guys for helping. Great community.
73s
Frank

This conversation is no longer open for comments or replies.