Is Flex Winkeyer emulation changing when remoting so N1MM does not work properly

  • 1
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
During Russian DX Contest I was working with Maestro and N1MM over a remote connection to my 6700. But I could not get N1MM to work properly. For instance ESM mode did not work. Neither "Focus on other and swap".
I have noticed this several times. According to the N1MM team it can have to do with how the Winkeyer emulation in Flex is echoing to N1MM. Has anyone else noticed these anomalities when working remote?
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 279 Posts
  • 35 Reply Likes

Posted 1 year ago

  • 1
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 923 Posts
  • 260 Reply Likes
Kari, can you elaborate on your setup?  were you using SmartLink?  VPN?  it sounds like the data stream in SSDR CAT was having issues but I think we need a little more info.  Also if you could provide data on the quality of your link and your operating conditions internet wise.

~Chris
N6WM
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 279 Posts
  • 35 Reply Likes
Hi Chris, 
At home I have fiber (100 Mbit/s) but at radio end I run over 4G and end up having a overall latency of about 50 - 100 ms on an average. I was using SmartLink this time. 
The more I recall this seems to be the case - I cannot get 100 % N1MM functionality (ESM, focus other and swap) . And I believe it was also the same before SmartLink was released but I did not pay attention to it then. Running traditionally from radio site all is OK with 100 % N1MM functionality. So something is clearly happening when running remotely with Maestro+PC ->SDR CAT->internet->6700.  
I have seen this been reported by others as well on the forum. But I wonder how many run CW contests this way without PC at remote site.
Is the Flex Winkeyer a software emulation only or is there a chip inside the 6700? 
I know that when I used a non original Winkeyer HW box I got the same phenomena when testing locally. Its Winkeyer simulation was not 100 % compatible. 
What do you think? 
Photo of Matt NQ6N

Matt NQ6N

  • 109 Posts
  • 44 Reply Likes
I have been running 100% remote with my new 6600 and using SO2R.  There has been one issue I've had with OTRSP where N1MM+ does not toggle the green light for the inactive RX when the tilde key (~) is pressed. The other OTRSP commands that I use are: \, ctrl right arrow and ctrl left arrow, which all seem to work correctly.  OTRSP and remote audio seems to correctly follow N1MM+ logger focus changes as well. 

I did two CWT sessions yesterday remote SO2R with very high latency (> 300ms) and the OTRSP keystrokes all seemed to work as expected, albeit with some delays and audio glitching due to the very high latency and low quality of my connection from the current remote operating position. 

If the Smartlink connection is disconnected/reconnected I have found it necessary to open the N1MM+ configuration window and close it again to re-initialize the CAT / OTRSP serial connections. 

I'd be interested to hear about your continued efforts at remote operation, as that is the main purpose of my 6600 and I will be dealing with similar challenges. 

73,
Matt NQ6N
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 279 Posts
  • 35 Reply Likes
Hi Matt,
Yes I would be glad sharing my experiences. I have been doing it for about 5 years now. BUT I do not use a PC at remote location. Never have eventhough I started with a K3 and  that went without problems. 
With Flex and if you like CW as I do to accomplish remote CW from a local PC at home (for N1MM, WriteLog) and get the sidetone is a bit tricky. But as some do I use the remote rig 1258 MKII boxes. Works very nicely. I route back the sidetone to my home. 
Using CWX is not an option for contesting from a PC. But perhaps Flex will come out with something soon. 
I strongly beleive there is an issue with remote Winkeyer in a Flex remote set up as mine  as I have seen this phenomena for over a year. The cause for it I cannot understand unless there is some router issue. I usually have about 25-50 ms on 4G. 
So I doubt that is the case. 
There are also issues with doing dualing CQ and changing bands often-  both N1MM or WL to a lesser extent  reacts randomnly with "TX slice changing.." warnings. 
So it is not "peace of cake" I must say to make it work 100 % in a non PC remote operation as my set-up. But it is getting better and better....
(Edited)
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 923 Posts
  • 260 Reply Likes
your average of 50-100ms latency over the 4g has my attention.  if that is the average are you having events of higher latency?  SO2R contesting is not going to play well at all with intermittent latency.  perhaps you can simplify short term to 1 slice and see how things work for testing purposes.
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 279 Posts
  • 35 Reply Likes
I checked and I had a router issue (it changed between 3G and 4G time slots) so now I have 25-50 ms again. I doubt this has to do with the anomalities.
I might check with VPN and see if it affects it all.
Only one slice makes the same anomalities. Exactly what I have been experiencing with a non generic externalk Winkeyer which did not produce 100 % like emulation.  
Are you getting 100 % N1MM funtionality when working CW remotely?
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 875 Posts
  • 322 Reply Likes
Official Response
The short answer is that we don't do anything different in the application if you are connected via SmartLink once the connection has been established.  I suspect that you are seeing the effects of longer latency.
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 279 Posts
  • 35 Reply Likes
But could it really matter with 25-50 ms latency?  Could there be something in the router signalling that affects it? Not port forwarding as this is OK. 
I use a Netgear R6300 router at home. 
Photo of Kari Gustafsson SM0HRP

Kari Gustafsson SM0HRP, Elmer

  • 279 Posts
  • 35 Reply Likes
I have now tested with a another PC and Win 7 and now it all works over SmartLink. I cannot understand what on the other PC with Win 7 that can have made the difference and not being 100 % Winkey conpatible.  Strange that different PC:s can influende it. Same LAN and router...
I am glad that Flex SDR is working so fine in this respect. You can trust them! 
(Edited)