flex control wont work

  • 1
  • Problem
  • Updated 4 months ago
Windows 10, SmartSDR 2.4.9
Unable to find solution with search function.
Found USB serial device in device manager.
Was COM 3 and changed to 133.
Still unable to get it to work.
Was used on my Windows 7 machine for years.
Had to buy a new PC and can't seem to figure out the problem.
Thanks....
Photo of N3WWL

N3WWL

  • 36 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Gayle Lawson

Gayle Lawson

  • 92 Posts
  • 35 Reply Likes
Hi:

Maybe your computer is not recognizing the Control Knob.

On my Win 10 machine, Control Panel/Device manager/ Com Ports, my Flex Control is listed as  " FlexControl USB Control Knob (Com #)" where # is the com port number. 

Also under Control Panel "Devices and Printers"  section the Flex Control is shown under the unspecified section with the com number underneath (Com 15 in my case). 

If you cant find the control listed in those two control panel section I think your PC isn't finding the knob.  Try a different USB port on the PC

Gayle K0FLY 
Photo of Lou Dietrich

Lou Dietrich

  • 76 Posts
  • 33 Reply Likes
Just a thought...is FlexControl enables in SSDR , Radio Set-Up> Radio> FlexControl Enabled.

73

Lou N2TU


Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4203 Posts
  • 1338 Reply Likes
Check what Lou suggested first. 

But, you may have had another device conflicting with the FlexControl on COM3 which kept it from making the change to 133. 

Try unplugging the FlexControl, rebooting the computer, and then plugging it back in while watching Device Manager in Windows to see what number it is assigned.  Make sure it is working before you reassign it to another port.  (I would suggest something in the 98-102 range.)  Then you might need to reboot again.

If it doesn't show up, you may need to uninstall and reinstall the FlexControl Driver.
(Edited)
Photo of N3WWL

N3WWL

  • 36 Posts
  • 0 Reply Likes
It is not listed under device manager as  FlexControl USB Control Knob (Com #).
It simply says USB serial device and defaults to COM3.
All I did was change that to COM 133.
I just tried changing USB ports to no avail.
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4203 Posts
  • 1338 Reply Likes
Try this with your FlexControl Unplugged...in your file manager....

Open the folder    "This PC > Local Disk (C:) > Program Files > FlexRadio Systems > SmartSDR(whatever release version you are running) > 64-bit Drivers > Flex Control"

Then run "FlexControlUninstall.bat"

and then run "FlexControlInstall.bat" 

Then reboot the computer and try to connect the FlexControl again.

make sure it is activated in the SSDR radio setup tab.

If this doesn't help, I would suggest opening a support ticket.

Ken - NM9P
Photo of N3WWL

N3WWL

  • 36 Posts
  • 0 Reply Likes
Thanks to all.  I had to completely remove all of SmartSDR, DAX, etc..  A reinstall did the trick.