flex Control

  • 1
  • Problem
  • Updated 2 years ago
flex control: I swear I am just about ready to throw in the towel. Flex 6300, logitech keyboard and mouse. windows 10. Three main problems: 1. On cw when using the keyboard for very fast cw, sometimes the keyboard will just quit.Maybe it is rf since it is a wireless keyboard though the mouse always works. 2. Flex control about two weeks old now. Under settings on 6300 a window comes up that says flex control not detected even though flex control will work sometimes. Port 102. Was thinking about getting a maestro but if can't get the flex control to work, sure not going to spend that kind of money for a maestro.I have tried changing ports, plugging flex control in beforfe turning on radio (6300) and after turning on radio. Kind of frustrated. v2.1.33 Bob K
Photo of Robert Kearbey

Robert Kearbey

  • 19 Posts
  • 3 Reply Likes

Posted 2 years ago

  • 1
Photo of Bill English

Bill English

  • 127 Posts
  • 18 Reply Likes
That’s odd, I have a 6300 and the Flex Control. It’s never caused me any problems. Extremely useful addition. You do have it plugged into the PC, right?
Photo of KF4HR


  • 842 Posts
  • 276 Reply Likes
Reference your keyboard problem.  Try temporarily swapping out your wireless keyboard for a wired keyboard and see what happens.  It might be a wireless connectivity issue.

If you have your Flex Knob plugged into your Flex 6300, plug it into a USB Port on your PC.

Unless I missed it, I don't see your 3rd main problem.
Photo of Michael Coslo

Michael Coslo

  • 947 Posts
  • 259 Reply Likes
I'm calling two problems. First is RF getting into the computer.  Put some good ferrites on the mouse and keyboard. 

Second is check your ports in device manager. See if the knob is seen. If you aren't certain, pluc and unplug and see what happens. Next possibility is that maybe you plugged the flex control knob into a different USB port? Windows does some funny things with drivers
Photo of Duane, AC5AA

Duane, AC5AA

  • 467 Posts
  • 107 Reply Likes
Since the last Win 10 update, my FlexControl has also become mostly inop. If I plug it into a different USB port on the PC it will briefly work, then quit. It ran for 3+ years with no problems on 1.xx SSDR, and 2.xx release prior to the current one. I’m highly suspicious of a MS update issue. I’ve replaced the driver and tried changing the port number all with no joy. Apparently there are only a few of us having this problem.
Photo of Gerald Capodieci

Gerald Capodieci

  • 34 Posts
  • 1 Reply Like
My exact problem too. I changed to an old wired IBM original keyboard. If your antenna is too close to your radio computer and other problems my result from RFI. My computer would reboot.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9199 Posts
  • 3559 Reply Likes
Sorry to hear you are having issues.  As others have speculated, I think you have RFI problems.  The above suggestions are reasonable to correct the issue.
Photo of Duane, AC5AA

Duane, AC5AA

  • 467 Posts
  • 107 Reply Likes
In my case, no RF is required to cause the problem. Just turn on receive and never transmit. The FlexControl just stops working a few seconds after starting. Everything in this setup has worked perfectly for 3+ years with a 6500 and 1.x software. Worked fine with the new 6600 and the previous release of 2.x SSDR until a couple of weeks ago. This is not RF related on my setup.
Photo of AA0KM


  • 356 Posts
  • 65 Reply Likes
Photo of Michael Coslo

Michael Coslo

  • 947 Posts
  • 259 Reply Likes
And do not forget, Microsoft helps us by often resetting these settings when they update. 
Photo of Wayne


  • 614 Posts
  • 89 Reply Likes
Win 7 or 8 or 8.1 the only way to go ...
Photo of Michael Coslo

Michael Coslo

  • 947 Posts
  • 259 Reply Likes
Well - Win 7 anyhow. 8^)
Photo of Michael Wheatley

Michael Wheatley

  • 29 Posts
  • 4 Reply Likes
Your problems could be related to USB connections.  Make sure your devices are connected to USB ports on the back of the computer (not the front) or to a good quality powered USB hub which in turn is connected to a USB port on the back of your computer.

Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
I have had fewer RF problems at my station since I went to a wireless keyboard/mouse combo instead of a wired setup.

I have had few problems with FlexControl in about 5 years.  But very occasionally, as Michael said, Windows fouls it up.  I have usually had luck with disconnecting it, rebooting the computer, and then plugging it back in. (Sometimes I needed to repeat that)  I then sometimes need to open Device Manager and reassign the port to a higher port (100 at my station) .

There was one time that I needed to reinstall a corrupted FlexControl Driver.

Again, these problems have happened only about once a year.  Usually when I was participating in the fast-release Windows 10 testing program.  I have since quit that because I lack the time to do it justice.