Flex control knob

  • 1
  • Question
  • Updated 4 years ago

Taking a break from the arrl contest. Having a problem with my Flex control dial. running the flex 6500. When turning the control knob a little to fast, it keeps on going, like the little bunny. Have the step set at 1, and still keeps moving if I go just a little to fast. Is there another setting I am missing.

It makes working the contest very easy using the control knob....


Don...w2xb

Photo of Don

Don

  • 77 Posts
  • 5 Reply Likes

Posted 4 years ago

  • 1
Photo of Don

Don

  • 77 Posts
  • 5 Reply Likes

Update to the control know problem. When I change bands it works great! I was on 15 meters for an hour and it started to act up. Also notice the spikes above the water fall got jumpy when I moved the flex knob. Went to a different band and came back and it works fine. Strange .... But its working ok now.


Don...w2xb

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
This sounds suspiciously like a graphics issue.  Can you describe your PC and the graphics card you are using?
Photo of Don

Don

  • 77 Posts
  • 5 Reply Likes

Tim,

I am using an intel graphics card that came with my gateway PC.

Don...w2xb

Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 387 Reply Likes
(Edited)
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 387 Reply Likes
I have this problem all the time if I turn the knob too fast irrespective of the band...it just keeps on going if I go too fast (which need not be that fast at all) and turning it in the opposite direction has no effect.

I have it set of COM 50 and buffers disabled - the latter is meant to fix this behaviour.

I'm waiting for the next release before dealing with this. I plan to try it through DDUtil as well as SSDR to check if it is a software issue.

The problem is also much worse if using an integrated graphics card with shared system memory; I have even tuned below 0Hz.
Photo of IW7DMH, Enzo

IW7DMH, Enzo

  • 353 Posts
  • 84 Reply Likes
I have this problem also when I use my prototype knob.
During my tests I discovered that it systematically happens when I start the I/Q Stream using the DAX control panel.
When I turn very fast the knob I send a lot of "set VFO" commands to the rig (and probably the Flex control do the same). Each command has to be sent when the network traffic is very high due to the I/Q streams and this cause the response delay.
A solution could be reducing the I/Q sample rate or using a 1Gb network connection.
For my Knob I found the solution to send always the same number of "set VFO" command per second. This helps a lot as now commands are indipendent from turning speed.
(Edited)