Flex Control driver will not load at all

  • 1
  • Question
  • Updated 3 years ago

Using a Flex 6500 - SW 1.4.16.  My Flex control, which had been working has quit. I followed the procedures, "How to Manually reinstall a PowerSDR Flex Control" and "Removing Hidden or "Ghosted" Com Ports" several times. I had done these procedures previously - restored the Flex Control - and had no trouble with them so I am familiar doing it.

The driver "Flex Control USB Control Knob (com xx)" never loads. Of course, in settings, the Flex Control is greyed out.

Using device manager, I have checked the com ports and there are no conflicts.

Flex Radio Virtual Serial Ports com14, com15, com4 and com5 show up just fine.

In Step #8, Plug the Flex Control into a USB port, it never recognizes the device.

The radio works just fine otherwise. Only the Flex control refuses to work. Any thoughts or suggestions?           73, Jim

Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes

Posted 3 years ago

  • 1
Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

Here's something that might help. My Flex Control had been working perfectly until I rearranged my desk and moved my computer from one side to the other. All of a sudden, no Flex Control. I tried everything: reinstalling SSDR, com port assignments, everything short of reinstalling Windows. Then I found a short statement in the manual which fixed the problem. Once you install Flex Control you must ALWAYS plug its USB plug into the same USB port on the computer. Voila! Problem fixed.

This may not be your problem, but it is something to keep in mind. Hope this helps.

73, Bill W6WRT


Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
If the problem persists, I recommend that you open a HelpDesk support ticket (http://helpdesk.flexradio.com) so we can investigate further one on one.
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes

Bill, thanks for the reply. I did try that but also the driver for the Flex control does not load.

Tim, I just opened a ticket for this. Many thanks for the fast reply.   73, Jim

Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
Tim, is there a time we can discuss this?    I am at wits end, having tried your procedures several times. Many Thanks, Jim
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
Tim, I submitted a Help Desk support ticket last night and again just now. I hope this helps. Let me know if you did not receive them. Thanks, Jim
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
There are no new tickets in our queue submitted under your account.  Did you log on to the HelpDesk web page and submit your request?
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
Yes, Tim. I have done that twice now. Once last night and once today.  Not sure what went wrong. I will try again.       Jim
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
I see your ticket now in the queue.  We'll be with you shortly.
Photo of James Del Principe

James Del Principe

  • 274 Posts
  • 28 Reply Likes
Tim, I wanted to follow up to close the loop and let you know what the problem was. It turned out to be a defective USB port. Once I resolved that, it worked just fine.   Very Best, Jim