Flex and Quadra

  • 1
  • Question
  • Updated 6 months ago
I have been a user of DDUTIL since 2010... it has been a Great program.

I have just recently built a new Computer. I have my Flex 6600 working like a champ and DDUTIL is work with my Steppir and HRD software just like it always has. I am experiencing difficulties with my Quadra amplifier that I have used with DDUTIL for the last 8 years. In my new computer I kept the same PCIe Parallel card and installed the driver for the card that windows 10 provided... which were the same drivers as my last computer used. I am using the same interface cable that I built in 2010 to interface the Computer with quasar and am using the Data port 1 on the Quadra. When i power up the computer the parallel card is communicating to the Quadra. I can here a couple of relays clicks in the Quadra on power up of the computer just like it has always done. However I can not get the frequency tracking (BCD) to follow at all. I have looked at the I/O of the parallel port and calculated the Hex to Decimal like I have had to do a few times before... but this time the decimal code that I enter does not communicate with the Quadra. I have reinstalled the drivers multiple times... uninstalled, removed the card, shut down, reinstalled and let the computer find the new hardware.. reentered the  decimal code for the BCD control but it still will not respond.  Where I am confused is that the card says that everything is working properly, I here the relay clicking on power up of the computer in the Quadra which tells me the cable and card are sending information to the Quadra... but anything I have tried does not seem to help. 

I even pulled the card and plugged it into another PCIe slot on the mother board and all installed fine... it did reassign the LPT port$  before it was assigned as LPT3 now it is LPT2 and does have a different Hex number than it did while it was LPT3. But the new hex number converted to decimal still does not send the BCD data to the Quadra... however when I power up the Computer the relays click in the Quadra breifly even as LPT2.

I am not sure if I am missing something in setup of DDUTIL?  Any suggestions would be greatly appreciated!

New Computer is:

I7-9700K
MSI Z390M Game AC Motherboard
32 gigs of ram
Rosewill RC302E parallel card

Running Smart SDR V2.4.9
DDUTIL 3.2.7.05
Photo of Jeff-W7NEE

Jeff-W7NEE

  • 40 Posts
  • 9 Reply Likes

Posted 6 months ago

  • 1
Photo of John Culliton

John Culliton

  • 37 Posts
  • 3 Reply Likes
I know what I do was different for my quadra, I used https://www.amazon.com/gp/product/B00HKK4SCO/ref=ppx_yo_dt_b_asin_title_o06__o00_s00?ie=UTF8&psc... directly out of the flex usb. I still use it with my palstar. No ddutility required. Your problem sounds driver related. If you can's solve it, the ftdi usb cable is a good option. I heard their is a less expensive option from mouser.

Photo of DON

DON

  • 14 Posts
  • 3 Reply Likes


Just a thought

You might try LPT1 and see what happens.

Just shooting in the dark here..

In DDutil-Setup-Ports-Parallel Port did you select Enable and Other and then put in the Dec number?

Good Luck