Flex 6700 RCA Tx 1 reset on opening by DDUTIl V3

  • 2
  • Problem
  • Updated 2 months ago
Flex-6700. Use DDUTIL V3 to run HRD Logbook which until recently worked perfectly. Now each time I restart I have to manually go to FLEX/Settings/Radio Setup/Tx and ENABLE RCA TX 1 to be able to key the amplifier.  Something has changed in the last few months. Can anyone help please?
Photo of Dave - G3SBP

Dave - G3SBP

  • 18 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 2
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3032 Posts
  • 671 Reply Likes
Persistance comes to mind, your selection is not being remembered.
You can save all profiles and do a factory reset, this clears the persitance data base.
Photo of Greg - N8GD

Greg - N8GD

  • 220 Posts
  • 83 Reply Likes
See this post:

https://community.flexradio.com/flexradio/topics/ddutil-tx-1-4-inhibit

The information contained therein will resolve your problem.  DDUtil has to be told to enable the transmit outputs, which, by default, it turns off.  It's basically a configuration issue with DDUtil.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3032 Posts
  • 671 Reply Likes
Sorry my mstake, it is a ddutil problem not a Flex problem
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1210 Posts
  • 249 Reply Likes
In DDUtil, make sure you have OPER selected on main screen. This will keep TX 1 activated. 
The idea is coupled to DDUtil's Auto Drive, so toggling DDUtil between operate and standby toggles the amp keying line and also can be used to set power out per band when amp is in operate and when running barefoot.

More info at http://k5fr.com/DDUtilV3wiki/index.php?title=AutoDrive 

Dave wo2x

Photo of Dave - G3SBP

Dave - G3SBP

  • 18 Posts
  • 0 Reply Likes
Thanks Bill, Greg and Dave for your suggestions. I use an Acom 600S Amplifier which is controlled by the USB output for band switching and the PTT to transmit from the Flex-6700. DDUTil is only for HRD Logbook and does not in "theory" control the Amplifier. However as soon as I run DDUTil, RCA TX 1 reverts to Disabled.
I have tried your suggestions by modifying settings in AutoDrive on DDUTil but they make no difference.  With the arrangement above would DDUTil have any affect on RCA TX outputs?
Many thanks
Dave. G3SBP.
(Edited)
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1210 Posts
  • 249 Reply Likes
Try uncheck amp follows DDUtil in Auto Drive.

Also you can try disabling Auto Drive.

Dave wo2x
Photo of Dave - G3SBP

Dave - G3SBP

  • 18 Posts
  • 0 Reply Likes
Yes, tried both of those Dave, doesn't make a difference. I don't understand why DDUTil would have any influence when nothing checked in Auto Drive or Amps!
Only checks I have in DDUTil is Radio Select/Signature and HRD Apps 6.1.
Dave. G3SBP
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1210 Posts
  • 249 Reply Likes
I am a member of the DDUtil user group. Let me reach out to the author.

Dave wo2x
Photo of Dave - G3SBP

Dave - G3SBP

  • 18 Posts
  • 0 Reply Likes
Dave that would be much appreciated as stuck otherwise!

Dave G3SBP
Photo of Dave - G3SBP

Dave - G3SBP

  • 18 Posts
  • 0 Reply Likes
Gentlemen after many attempts I have got it working again by basically following David and Gregs suggestion but still fail to see why DDUTils should have any effect on the Flex. Now that's working after updating HRD Logbook JTAlert can no longer write to my log....
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1209 Posts
  • 249 Reply Likes
I’ll do some screenshots of my settings in the morning and post them here. Been using latest HRD, WSJT-x and JTAlert without issue.

If you would like i can do a TeamViewer session with you if the screenshots do not resolve it.

You can reach me direct at my call at arrl dot net

Dave wo2x
Photo of Dave - G3SBP

Dave - G3SBP

  • 18 Posts
  • 0 Reply Likes
Dave, this morning on opening JTAlert I got the following message:-

ERROR opening TCP/IP port.  Port may be used by other applications.
Go to Communication/TCP Server Setup and set other IP ports.

Not sure where one finds Communication/TCP Server?

Many thanks for your help

Dave. G3SBP.

Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1209 Posts
  • 249 Reply Likes
Hi Dave,

Check these settings:

In JTAlert-X go to settings/Manage Settings/Logging/HRDV5V6
Choose V6.3 or later and in Log Name use the pulldown to select your logbook name.
Click Save and OK.

In HRD Logbook go to Tools/Configure/Network Server.
Make sure AutoStart is checked and port is 7825. Database should match what you set in JTAlert-X logging setting.

Last, check your PC firewall. Both JTAlert-X and HRD Logbook should not be blocked for local/private network.

Below are screenshots of my settings.

Dave wo2x



Photo of Dave - G3SBP

Dave - G3SBP

  • 18 Posts
  • 0 Reply Likes
Dave, many many thanks for your suggestions. I have exactly the same as you but then thought about the Bullguard Firewall.  Turned it off and logging worked okay but couldn't see anywhere in the log that that had stopped the process but turned it back on and now working okay! Will do another check tomorrow when I re-boot the system from scratch.  In the meantime thanks again, its so good to have someone else suggest a check list as you!
Best wishes

Dave G3SBP.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1209 Posts
  • 249 Reply Likes
Great! Glad to help.

73
Dave wo2x