Flex 6700 and Netgear JGS524Ev2

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I have a Flex 6700 and just purchased a Netgear JGS524Ev2 gigabit switch. This switch is managed and I can change the port settings on the switch.

My Flex 6700 is having trouble auto negotiating speed/duplex with this switch. I've tried every possible setting speed/duplex trying to force it, but it still will not link up. Auto/Auto is the default.

On the Flex ethernet card, when looking at the RJ45 connector the right LED turns from red, to amber to green rapidly. The switch says the port is up & connected, but the flex is not passing any traffic and doesn't get an IP address. When I put another switch in line, the Flex links up with no issues to a dumb 10/100 switch.

I've checked the cable with a tester and it's good. Tried several different ports on the switch with no luck. Is there any diagnostics/logs on the Flex I could look at?
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
Here is the switch I purchased.

https://www.amazon.com/gp/product/B00...
Photo of Michael Coslo

Michael Coslo

  • 905 Posts
  • 233 Reply Likes
I have one. what router do you have?
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
TP-Link N600
Photo of Michael Coslo

Michael Coslo

  • 905 Posts
  • 233 Reply Likes
What's it do without the switch in the local network? Also have you ever used wireshark?

You can also assign a static IP though I don't think that's your problem.

As well, are you allowing the flex through the firewall?
Photo of Jim Gilliam

Jim Gilliam

  • 883 Posts
  • 195 Reply Likes

What is your configuration? Is the switch connected to a port on the router?

Photo of Brad Adams (N4PYI)

Brad Adams (N4PYI)

  • 24 Posts
  • 8 Reply Likes
The Flex radio and especially the Maestro want a 100mb switch. Nothing fancy. Works great.
(Edited)
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
The Flex is not a gigabit interface?
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
I wasn't going to post the configuration of the switch here, as there are hundreds of settings. I'm not doing any VLAN tagging, or LAG groups on the switch. Everything is default VLAN (1) and basically a straight out of the box configuration on the ports.

Yes, there is an gigabit uplink to a TP-Link router. No other computers/devices have an issue with the auto negotiation on the Netgear gigabit switch. All ports on the Netgear are in an auto/auto configuration.

I've seen this issue with some ethernet ports on our Cisco switches at work where huge SAN storage arrays from IBM just don't link up correctly and we have to force speed/duplex. I've tried that with no luck.
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 817 Posts
  • 191 Reply Likes
Unfortunately, network connectivity is an inconsistent and luck of the draw endeavor when it comes to hooking these radios up. FRS generally blames the issue on the network equipment when everything else on that network works just fine. Others will say it all works perfectly for them. It's real frustrating.

In my experience, even if you can get your setup working a reboot of any component could just as easily set you back to square one. I find this the most frustrating thing about my 6500.

I connect my radio directly to the computer. The interface is set to auto negotiate and it negotiates to 1 Gbps. No DHCP is  involved. It's using the self-assigned address. It works, mostly every time for me. I've tried various devices in between including a NetGear wireless router and a NetGear wireless extender. In both cases the radio was rarely discovered. In some cases the IP address was wrong. In cases where it worked - even when the computer was attached to the same switch - the Flex network diagnostics showed poor status with high drops.

I'm hoping you can resolve your issue and that your solution can be applied in general.

73 & GL,
Kevin K4VD
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
I've been running the flex with it directly connected to my PC for almost a year now with no issues, but decided I wanted to do JT65 from my couch with my laptop, hence putting it on my network.

When I had a 10/100 switch and a wireless laptop, it would get jitter on my wireless and the flex software would stop responding or I'd get audio drop outs. Now I run wired everywhere.
Photo of Rick - W5FCX

Rick - W5FCX

  • 220 Posts
  • 55 Reply Likes
Sounds like Flex can't auto negotiate for some reason...

Assume you made certain the switch port is not configured for bonding, LACP, etc. It should be a trunk port (no VLAN), which I believe you've verified.

Can you connect that same switch port to a different device, instead of Flex, to verify its negotiating as expected?
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
Correct. I connect my PC to that switch port and it does auto/auto fine. I've tried connecting the flex to almost every single port on that 24 port switch with the same results.
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2276 Posts
  • 917 Reply Likes
I have the same switch and no issues. Weird. 

As long as client (PC/Maestro) and server (radio) are on the same VLAN then there should be no issues. 

If it's not auto negotiating, you can just set the speed manually to gigabit or 100BaseT via the web interface.

In my years of networking experience including long days and nights spent at 111 8th Avenue, I have seen auto-negotiation fail in only one specific instance - and that was a media converter from a Verizon fiber line that specifically wanted 1 gigabit and would not negotiate any lower. 
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
You have this exact same switch with no issues? I'm assuming you have your port in auto/auto on the Netgear and it links up fine? Do you have the V2 of this switch or version 1?

I have tried setting it manually and I get the same results. The fast green/amber/red blink on the Flex ethernet card.
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
I don't think you can set a port to 1000Mb. See the screen shot below.

Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2276 Posts
  • 917 Reply Likes
Yes. it works on auto with mine. You're right, there is no 1000mb selection. Does it work at 100mb? 
Photo of Alex - KM5YT

Alex - KM5YT

  • 63 Posts
  • 9 Reply Likes
This is all consistent with my wish for an eventual modular/cage/VME-type architecture for the F7K series. At some point we may all wish/need to yank our ethernet and go with the optical interface du jour, and a trip back to Austin should not be necessary!
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 299 Posts
  • 60 Reply Likes
You might try swapping out your cables.  Sometimes they're marginal, working ok in one setup but not another.   The RS6K does not need 1Gb/s, so you may get more reliability if you forced everything to 100 Mb/s, which you seem to have tried.  Unfortunately, there's no way to force the radio to use a particular speed and not to autonegotiate.  Similar comment for the Maestro.  (That would be a good item for a future FRS update!)
Photo of Kyle Krieg

Kyle Krieg

  • 26 Posts
  • 2 Reply Likes
Official Response
I did a factory reset on my switch, swapped out the patch cable on both sides (switch and wall jack) and tested the structured cable run in the wall. Everything seems to be running correctly now. Not sure what did it, the factory reset or the patch cables, but thanks to everybody who offered suggestions to get this fixed.
Photo of David H Hickman

David H Hickman

  • 46 Posts
  • 3 Reply Likes
In my experience as long as it does not say cisco on it, auto should work. I am still anal and have everything in my rack set to manual. I have my flex plugged into a ubuiquti 48 port on a auto negociated vlan tagged port and it works fine,.

The machine apparently runs some kind of Linux, so unless it is running a really crappy network card, it should just work.

I would say that it is the cable.

This conversation is no longer open for comments or replies.