Flex 6500, DXLab, N1MM, WSJT-X interconnection - best approach

  • 1
  • Question
  • Updated 2 months ago
I've had the Flex 6500 for just a couple of weeks, have it integrated into my station and talking to the radio-related software OK, but in reading other threads here I suspect my configuration could be improved.  So, am looking for suggestions and comments on that.

Here's the current configuration: Flex 6500, Maestro, PC connected via ethernet cables to ethernet switch which is cable connected to DSL modem/router.  DXLab Suite used for logging, etc., WSJT-X, N1MM Logger+ for contests, SmartSDR CAT.  During DX contests, DXLab and N1MM would both be running and connected to the 6500. 

For the WSJT-X connection, I have port 5002 defined in SmartSDR CAT.  In WSJT-X setup, rig is defined as FlexRadio 6xxx and CAT control specifies localhost:5002. 

For the N1MM connection, I have a COM11 port defined in SmartSDR CAT and in N1MM, COM11 is specified as the port for the 6500.

In DXLab Commander,  I have the radio defined as SDR-6500, 100 ms. command interval, Primary CAT serial port of COM9 (which is also defined in SmartSDR CAT as COM9).

The PC runs Win 10 and the Maestro and 6500 are at 2.4.9 level. 
Photo of K8AC

K8AC

  • 47 Posts
  • 3 Reply Likes

Posted 2 months ago

  • 1
Photo of Bob Craig, K8RC

Bob Craig, K8RC

  • 243 Posts
  • 96 Reply Likes
Suggest you change the connection to Commander per:
 https://www.dxlabsuite.com/dxlabwiki/FlexSignature
Photo of K8AC

K8AC

  • 47 Posts
  • 3 Reply Likes
OK - did that, and thus freed up the COM port I was using.  It would be nice if N1MM would also allow communications via TCP.  WSJT-X supports specifying an IP address, but needs a port number.  I tried just putting the radio IP address there, but that didn't work. 
Photo of Jay / NO5J

Jay / NO5J

  • 1621 Posts
  • 235 Reply Likes
Floyd
With WSJT-X the TCP port needs to be set to use the Loopback IP address of the PC that SmartCat is running on, "not" the IP address of the radio itself. In WSJT-X Radio Setup, try setting either 127.0.0.1: 5002 or localhost:5002 which should work if your going to be using port 5002. The connection is made to SmartCAT, not directly to the radio, WSJT-X gets it's connection through SmartCAT's TCP connection to the radio.

    #FlexRadio IRC chat

For real-time discussions

        SDRgadgets

User created documentation.
           Volunteer!!

         73, Jay - NO5J

Photo of K8AC

K8AC

  • 47 Posts
  • 3 Reply Likes
I've been using the localhost:5002 method with SmartCAT and that's been working fine.  I thought maybe there was a way to make the connection without SmartCAT as DXLab Commander is able to do. 
Photo of Dave AA6YQ

Dave AA6YQ

  • 109 Posts
  • 62 Reply Likes
Configure WSJTX to user Commander for transceiver control, as described in

https://www.dxlabsuite.com/dxlabwiki/GettingStartedwithK1JTModes

With DXLab, you do not need SmartCAT.
Photo of K8AC

K8AC

  • 47 Posts
  • 3 Reply Likes
I previously had it set up that way, but changed it.  Frankly, I can't remember why, so will revisit that and change it back to using Commander.