Flex 6400M SmartSDR 2.49 can't find radio-video WITH NARRATION.

  • 1
  • Question
  • Updated 7 months ago
  • (Edited)
See the video.
https://youtu.be/soU6gQWmr74

How stupid am I?
Probably a lot
Photo of Burt Fisher

Burt Fisher

  • 1269 Posts
  • 485 Reply Likes

Posted 7 months ago

  • 1
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 916 Posts
  • 344 Reply Likes
What is the IP address of the radio? And the PC? It is likely that they are on different subnets. This means that the broadcast packet for discovery will make it and it will show up in the radio selection window, but it won’t connect.

The solution is to put both the radio and the PC on the same network. Sometimes this means just rebooting the radio to take on new network settings if you have changed the configuration. If the radio is set to a Static IP, it may mean needing to reconfigure that to match the network.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 583 Posts
  • 206 Reply Likes
Yup that says it all, Burt - don’t have separate networks. Bridge, don’t route.

As you can see above, your Flex and your laptop are on entirely different networks. You could probably not even get it to work with SmartLink either, because the appropriate routes (and forwards) would probably not be available between those two non-public networks.
(Edited)
Photo of Burt Fisher

Burt Fisher

  • 1269 Posts
  • 485 Reply Likes
Is there any way I can make it work.?

I have the box from Infinity as pictured, it has 2 outlets, one I use for the router, the other hooked to something not critical, the Flex is on router
I have a bridge but it is only 10MB, not 100 so  I used the router to allow my computers to run at 100.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 583 Posts
  • 206 Reply Likes
I don’t think I understand your network fully, Burt, but you must have your computers and Flex hooked up in such a way that they are assigned IP addresses (and thus networks) from different DHCP servers. The easiest way to solve your problem is to ensure only one flat network exists, both for wired and wireless. Does your Infinity device provide wireless access to your WiFi devices? And does the wired outlet on the Infinity device give out IP addresses on the same network as the WiFI? If it does, the easiest way to give yourself that flat address space is to put a simple 4- or 8-port switch on the Infinity device, and do NOT use a separate router (which may we’ll have its own DHCP server).

Alternatively, you could extend your WiFi to a distant wired network (again using that inexpensive 4- or 8-port switch) using a WiFi extender on your existing WiFi.

I hope I have not misunderstood your network setup. Good luck.
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 916 Posts
  • 344 Reply Likes
Burt — if the WiFi device is separate, just make sure that it is configured as a bridge or an access point. You just don’t want multiple DHCP servers setup that will put devices on separate network spaces.
Photo of Burt Fisher

Burt Fisher

  • 1269 Posts
  • 485 Reply Likes
Thank you Eric for spending well over an hour getting my 6400M on the same network and configuring my router. You went the extra 30 miles.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 583 Posts
  • 206 Reply Likes
The most amusing part about this video above was another that was associated with it, all about SDR dongles, describing an RSP. It ended with a ham snoring with VOX on :-)
Photo of Greg - N8GD

Greg - N8GD

  • 239 Posts
  • 88 Reply Likes
Burt,

Since you have Xfinity (Comcast), it appears that you may be connecting to the public Wi-Fi they have set up on most home modem/router combo boxes.  There should be a private Wi-Fi you can connect to (see the bottom/side of the cable modem router for the SSID and password - default ones).  If you know how to access the modem (in your case 192.168.1.1 most likely), you can login to the modem with a user name of "cusadmin" and a password of "highspeed" and configure your Wi-Fi as you desire.  Your Wi-Fi and hardwired networks should be on the same subnet if you connect to the private Wi-Fi and NOT the public one named "xfiniitywifi".

Connect your 6400M directly to one of the RJ-45 jacks on the Xfinity modem.  Don't use the router - it will just cause more problems.  Does your router have Wi-FI?  If so, setup a Wi-Fi network on it and connect to it (if you're going to use the router).  You can't use the Wi-Fi from the Xfinity modem and the hardwired connection from your router - you'll be on two different subnets!

Greg - N8GD

(Edited)
Photo of Burt Fisher

Burt Fisher

  • 1269 Posts
  • 485 Reply Likes
 I am not using the public one named "xfiniitywifi'
10.0.0.1 worked I am into the xfinity router, now what?
(Edited)
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 583 Posts
  • 206 Reply Likes
Is your router connected to the Xfinity using the router’s WAN connection, Burt? If so, and you disconnect the router and connect your Flex or desktop, do they get a 10.0.0.xx address, in the same network range as your laptop WiFi address? That would mean you are doing double NAT.

If this is the case, you should be able to turn off DHCP in your router, and just connect one of the router ports (not it’s WAN port) to the Xfinity and have it act as a dumb switch. This assumes (I know, I know, we all know what “assume” means :-) that your router has a 4-port switch built in - most do. Sorry, kinda shooting in the dark here and thinking out loud.
Photo of Greg - N8GD

Greg - N8GD

  • 239 Posts
  • 88 Reply Likes
Burt said there were two Ethernet ports on the rear of the cable modem.  Burt, plug your PC into one of them.  You don't need your router for this setup - the Xfinity modem has a router built-in.  You'll need to reboot your PC to get a 10.0.0.x IP address from the DHCP server in the Xfinity modem.  You don't really need to do anything on logging into the modem.  Just hook up the PC to it and reboot.  You should have connectivity thereafter!

Greg - N8GD