Flex 6400 - Can't transmit on FT8

  • 1
  • Problem
  • Updated 4 months ago
  • Solved
I have the latest WSJT-X software and the latest update for my brand-new 6400. I am receiving and decoding FT8 just fine, but I keep getting errors when I try to transmit. I've been over & over the setup many times without success -- the rig won't "key" and delivers error messages about Hamlib and configuration. I've read that WSJT-X is not yet compatible with the 6400. True? 

Has any one succeeded yet with the 6400 and FT8? Can you offer any workarounds ... ?

Thanks in advance & 73 -- 

Dave, N7DK
Photo of Dave

Dave

  • 4 Posts
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Mike Steiner, K7QDX

Mike Steiner, K7QDX

  • 25 Posts
  • 6 Reply Likes
Make sure you have DAX set up correct and selected.This is both for the software and the Smart SDR
Photo of Mike W9OJ

Mike W9OJ

  • 86 Posts
  • 27 Reply Likes
Photo of Larry Davis

Larry Davis

  • 69 Posts
  • 12 Reply Likes
if you got a hablib error you got wrong radio in or port take some screen shot and post the radio and ports setting
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1138 Posts
  • 235 Reply Likes
You should download the WSJT-X 1.90 rc3 from https://physics.princeton.edu/pulsar/k1jt/wsjtx-1.9.0-rc3-win32.exe 

Create a TCP CAT port in SmartSDR. (I used 5004)

In WSJT-X radio setup, choose FlexRadio and set the address. I used 127.0.0.1:5004 
If you use a port other than 5004 then just change it. 

PTT should be via CAT.
MODE should be Data
Split should be Fake It

Dave wo2x


Photo of Dave

Dave

  • 4 Posts
  • 0 Reply Likes
Many thanks to all who responded. I'll get back to work! 

I've been trying the 1.8 version of WSJT-X -- will go to 1.9 and check all other options you've offered. I'm still very much in 'tyro' mode, and I really need the help. 

I still have my Tentec OmniVII that I've managed to work all the digital modes with an outboard SDR. It all works, but it's really 'kloodgey'. I look forward to getting rid of all the USB/Serial adapters, COM port splitters, and the SDR and finally going all SDR. 

I'll probably be back with more questions (some of them pretty dumb, I'm sure) ... 

Thanks again, and 73!

Dave, N7DK
Photo of Dave

Dave

  • 4 Posts
  • 0 Reply Likes
Okay, got it! 

I couldn't get the TCP control to work, but I did finally get the COM port method to work.

My problem was that (I had long forgot) I had an RS232 card in my computer that had already registered COM4 as an available port. But the FLEX couldn't use it -- it saw a conflict with COM4.

Instead I set up a virtual serial port COM6, and that worked, using Kenwood TS-2000 as the "radio" as I have seen others do. 

I'll come back to that TCP method and probably find a way to get it working, but for now, I'm back on the air with FT8. Phew!

Thanks to all for help. Here's a screenshot of wsjt-x radio configuration working for the Flex 6400



73, Dave, N7DK
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
The recommendation of WO2X to use TCP does work.  I suspect you did not create a TCP CAT port in SmartSDR CAT with the port number of 5004.  This actually works better than using an emulated serial port; less latency and software that the data has to traverse to get to and from WSJT-X and the radio.
Photo of k0eoo

k0eoo

  • 594 Posts
  • 81 Reply Likes
Dave, do you have the DAX button on the PHONE panel selected (blue)?  it won't transmit without that being selected.



Dennis, k0eoo
Photo of Clay N9IO

Clay N9IO

  • 522 Posts
  • 123 Reply Likes
Well I have been digging through the community trying to find the answer to my issue with FT8 and my Flex-6600.  Same identical issue as Dave N7DK.

Thanks once again David Decoons wo2x, not the first time you hasve bailed me Dave...

Uninstalled 1.8 and installed 1.9 (didn't realize there was a newer version.)
Setup Flex 6xxx,  also set up an aditional TCP Port 5004 and WSJT setting I used 127.0.0.1:5004
WO2X graphics above dead on for me.

First and only FT8 qso so far was on 40m with HK6JG or so it tells me, ha...
Totally missed the 6m opening and earlier 160m opening, oh well next time at least it's working now...
Thank you Community Archives, only regret wish I could have found this earlier in the day...
Photo of mikeatthebeach .

mikeatthebeach .

  • 247 Posts
  • 38 Reply Likes
Worked EA8DBM off the West Coast of Africa Western Sahara to Los Angeles here on my Flex6600M with FT8 on yesterday's 6meter opening

WOW ! Great DX contact and confirmed in LOTW today

A number of West Coast Stations in Southern California worked Africa on FT8 

Check out PSK Reporter - Best 6 meter opening ever !!

Mike
Photo of Clay N9IO

Clay N9IO

  • 522 Posts
  • 123 Reply Likes
Knew I missed a good one Mike, maybe 6m will be up tonight again. Fingers crossed...