Flex 6300, SSDR v1.10.16, N1MM

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I finally broke down and upgraded from SSDR v1.6.17 to v1.10.16.  I fired up N1MM to set up for the RTTY contest and N1MM and the Flex are not talking to each other.  Ports for which I had set for N1MM (COM4 for radio and COM10 for CW/Other) no longer appear in CAT v1.10.17.  So I changed the radio to COM7, which appears in CAT, and changed to COM13, newly created for CW/Other.  I was unable to get COM4 and COM10 as port choices when trying to reset ports.

When I fire up N1MM it shows as the Process for these two com ports in CAT BUT when I start N1MM the 6300 goes to transmit and will not stop until I shutdown N1MM.  N1MM is not reading the radio frequency.  I can't begin to know if MMTTY will work until I can get the radio and N1MM talking to each other.

Looking like another case of 'don't fix it if it ain't broke' but that's where I am.  I just hate changing/upgrading when everything is already working.  Any suggestions for fixing the setup would be appreciated.

73 from the desert.....Fred/NA2U
Photo of Fred-NA2U


  • 53 Posts
  • 1 Reply Like
  • Bummed

Posted 2 years ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3747 Posts
  • 901 Reply Likes
It is always best to upgrade to the latest version, always!!
Photo of Delbert McCord

Delbert McCord

  • 116 Posts
  • 21 Reply Likes
Not with everything, I know ever time Windoz forces you to upgrade to a newer operating system it gives you a bunch of eye candy and takes something away that was useful. 

I may be just silly but I have learned with software do not upgrade unless you have to. Windoz, Foxpro, Quickbooks, have taught me this. I am still on the fence with my Flex radios. With all the problems I have seen with upgrading to the 2.x of the Flex software I have decided to leave my 6300's on the older stuff so I do not have to deal with the licensing problems and when I get my 6400 I will try it out and see what happens.

Upgrades are like sticking your finger in a light socket and wondering if its turned on or not.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3747 Posts
  • 901 Reply Likes
Sorry, I was refering to SSDR only, as that is what the subject was.
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1432 Posts
  • 723 Reply Likes

@Fred - a few thoughts:

1). it is always better to check through your settings and jot them down before any upgrade.  Personally I do Screen Captures for post-upgrade reference.  Also do the profile exports and follow the release notes.

2). avoid upgrading to anything other than the latest (Version 1 of Smart SDR is at 1.11.12) as the latest has the most "fixes" in it.  Unless there is a special reason to jump to a version between your old version and the very latest, you end up doubling your time and troubles making small steps.

3). third party software (like N1MM+) usually need to be carefully managed - again capture those settings and make sure you present version is compatible with the SmartSDR upgrade.  Often you have to upgrade the third party software at the same time to maintain compatibility.

You may have done all this, but looking at your present pickle:

1).  Go through you old N1MM install & configuration notes, of if you didn't make any follow their setup guide to work with SmartSDR.

2).  Check for Com Port issues, as some upgrades of SmartSDR include driver & cat upgrades.  You may have crossed one of those Rubicons.

3).  If nothing sensible really makes sense, consider opening a help ticket as Dudley & the Gang are really awesome if bailing a guy out.

Good luck and 73

Steve K9ZW

Photo of Fred-NA2U


  • 53 Posts
  • 1 Reply Like
SSDR 1.10.17 WAS the most recent v1 when I downloaded it.  I can try downloading 1.11.12 but I don't believe it's going to get me out of the soup with the ports issue.  And it might seem this is my first rodeo it's not.  I kept screen shots of all the N1MM config screens so I would know how to set something if it got screwed up in an upgrade.  The two COM ports I had used were 4 for the radio and 10 for CW/other.  Those ports are now not available in CAT and SSDR is not liking those I'm selecting.  Not to mention the rig switches to transmit when I start N1MM and won't stop transmitting until I close N1MM.

I'm going back in to try again but optimism is alluding me.....

73 from the desert......Fred/NA2U
Photo of Jim K4JAF


  • 361 Posts
  • 105 Reply Likes

The new SmartSDR CAT most likely assigned new com ports as the old ones were already allocated.  I use one of the various utility programs to delete the unused ports before upgrading my CAT new software versions..  I use COM_Name_Arbiter_Setter.exe  but there are many out there, use Google to find one..  Windows will always choose new com ports as the old ones still how up as allocated. 

As others stated always best to keep up to date with the latest versions available.  73s Jim K4JAF

Photo of Fred-NA2U


  • 53 Posts
  • 1 Reply Like

1.  When I say the Flex switches to transmit when I start N1MM I find that the LED on the rig turns RED but there is no power output.

2.  Except for the Flex Control USB Control Knob (COM3) ALL COM ports indicate on their Properties tab in Device Manage that "this device is working properly" (on the General tab) yet
review of the Resources tab reveals "This device isn't using any resources because it has a problem"  Each virtual port reads the same on these two tabs. 


Photo of Fred-NA2U


  • 53 Posts
  • 1 Reply Like
Official Response
Problem solved.  Had to create 'new' COM ports.  Also had to create a 'new' Winkey port as the original disappeared.  This just should not happen.  Upgrading versions should not change these existing settings.  It just shouldn't. 

I always make screens captures so I know later how things were set.  I guess that won't work with SSDR.

Thanks all for suggestions.

73 from the desert...........Fred/NA2U
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4173 Posts
  • 1331 Reply Likes
The latest V.1 update --- V.1.11.12 included, in addition to stability and other fixes, some CAT updates that eliminated the "all ports in use" error.  HOWEVER users who had that problem still need to go through the one-time procedure of clearing the bad ports or they can give you problems in a similar way as the "ghosted" DAX audio ports did.

This may have necessitated the recreation of your COM ports.  

Ken - NM9P

This conversation is no longer open for comments or replies.