Flex 3000 will not power on.

  • 1
  • Question
  • Updated 7 months ago
My Flex 3000 will not tune on.  When I push the power button in the button goes in a fan turns on but the blue light will not light and what I'm assuming is a relay does not engage.  
Photo of kb3byw

kb3byw

  • 6 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of WH6HI - Pat

WH6HI - Pat

  • 275 Posts
  • 38 Reply Likes
Chances are that an internal fuse has blown. Open it up and check.
Photo of Mal Bussey

Mal Bussey

  • 1 Post
  • 0 Reply Likes
Mine did something similar.  Once the case was off, it would turn on just fine. One of the front case screws was just long enough to touch the board under the switch side.  I put another washer under it as a shim and all is well. n5gkv
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2775 Posts
  • 611 Reply Likes
On the power plug make sure all wires are pushed in to make good contact, there are 2 red and 2 black, sometimes they pull out a bit. Push them in all the way.
Upon startup just after you push the power button you should hear 2 clicks very close together.
(Edited)
Photo of ei3gqb

ei3gqb

  • 7 Posts
  • 1 Reply Like
Send to your nearest flexradio servise center..have one and it needed work onit done...over here i sent it to flexrepair europe in de..got it back as new..regards.de francis(ei3gqb)
Photo of ei3gqb

ei3gqb

  • 7 Posts
  • 1 Reply Like
Send to your nearest flexradio servise center..have one and it needed work onit done...over here i sent it to flexrepair europe in de..got it back as new..regards.de francis(ei3gqb)
Photo of John

John

  • 432 Posts
  • 33 Reply Likes
Could also be a firewire card/cable or port issue. Try another card / cable and make sure the cable end are correctly inserted. If this fails, then send it to your nearest service centre.
Photo of kb3byw

kb3byw

  • 6 Posts
  • 0 Reply Likes
I will check the power wire, the fuse ,and the FireWire card and cable over the weekend. Thanks for the suggestions.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2775 Posts
  • 611 Reply Likes
Like I said, there should be two clicks on power on. If you hear just one, it may need service. The firewire cable or card will not stop it from powering up.
Photo of kb3byw

kb3byw

  • 6 Posts
  • 0 Reply Likes
I hear both clicks, the fuse is good. I took the cover off and powered it up and the blue light came on. I turned the radio off and and turned it on again and no blue light.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2775 Posts
  • 611 Reply Likes
Even if the blue light does not come on will it connect and you can run PSDR?
Photo of kb3byw

kb3byw

  • 6 Posts
  • 0 Reply Likes
No go
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2775 Posts
  • 611 Reply Likes
I really don't know what could be the problem, I have had a 3000 for 12 years, so I know the radio really well, but this has me stumped, sorry.
Photo of kb3byw

kb3byw

  • 6 Posts
  • 0 Reply Likes
Thanks for the help. I'm going to pick up a fuse tomorrow if I can find one. I looked at the fuse it looked like it was ok I checked and there was no voltage across it.
Photo of kb3byw

kb3byw

  • 6 Posts
  • 0 Reply Likes
I pulled the fuse and checked it and it is good.