FLDIGI & WSJT only work with DAX IQ RX

  • 1
  • Question
  • Updated 2 months ago
All,

I followed the videos on how to set up FLDIGI and WSTJ. Problem is neither of them receive anything when targeted at DAX Audio. Both are working with audio receive set to DAX IQ RX.

Last weekend I weekend I managed 100 QSOs with FLDIGI in the CQ contest (yes I use a computer) and today I have been running WSPR on WSTJ.

So does anyone have any ideas where I might have an error in my setup.

Thanks all,
Cheers,
Mick
W6MOB
Photo of Mick

Mick

  • 6 Posts
  • 1 Reply Like
  • that I am having fun

Posted 2 months ago

  • 1
Photo of Craig - KØCF

Craig - KØCF

  • 177 Posts
  • 61 Reply Likes
Have you enabled the correct DAX channel in the slice you are using? It's on the DAX dropdown menu on the slice flag.
Photo of Mick

Mick

  • 6 Posts
  • 1 Reply Like
Craig,
  I checked that, it set to DAX Channel 1 which I think is correct.
  As I said DAX IQ RX is working but not DAX Audio.
Cheers,
Mick
Photo of Gayle Lawson

Gayle Lawson

  • 17 Posts
  • 2 Reply Likes
Mick:

I will give it a guess.  First of all Hi Craig.

It is possible that Windows may have  gotten into the act and messed up the naming of the DAX ports and the associated drivers.    Open the "Sound" settings in the Control Panel.  You should see the following DAX listings.



If your settings look like this your Control pane;l then that is not the answer.  If you see for instance:

DAX RESERVED AUDIO RX #
FlexRadio Systems Dax IQ

That is incorrect.   The gray text is showing the driver for the port.

Here is the correct DAX IQ display.




If you find any of these incorrect in your settings, double click on the audio port and change it to the correct name in the highlighted block.  




If you find any differences then note what windows has it labeled and what you change to, so that you can recover in case thing get really goofed up..  Many times if the titles are incorrect you see a DAX error message when you start the software.

Gayle K0FLY
Photo of Pat - WH6HI

Pat - WH6HI

  • 329 Posts
  • 62 Reply Likes
I am not sure why you are looking at the PC Windows side at this point. Also wsjt-x does not produce IQ STREAMS. all you need to do is in the DAX. FIrst step set to your preferred audio stream any channel RX1 etc in the DAX pull down. Then go to wsjt-x and set the matching selection from the list in config. On the transmit side there is only one selection in the wsjt-x config. That should just work. No need to fiddle with PC audio. FLDIGI IS MUCH THE SAME but needs different RX Channel.
(Edited)
Photo of Craig - KØCF

Craig - KØCF

  • 177 Posts
  • 61 Reply Likes
Because Windows updates have a history of messing up the DAX port names. If they have been misnamed by Windows, they will NOT work as intended. It is vital that this be correct as Gayle notes above.
Photo of Pat - WH6HI

Pat - WH6HI

  • 329 Posts
  • 62 Reply Likes
What you describe is most likely a com registry problem . There are apps to help clean out wrong or old registry information. Clean my PC is one. What ever they did in win 10 to make registry problems worse is a crime. One reasone why I have stayed with win 7. But that may end soon as Flex will not support win 7 soon I think. Well good luck....
Photo of Ross W8TZ

Ross W8TZ

  • 21 Posts
  • 3 Reply Likes
I have had this problem before. It is exactly what Gayle has described. Windows has messed up the names of the DAX ports. They need to be renamed properly and saved.
Photo of Gayle Lawson

Gayle Lawson

  • 17 Posts
  • 2 Reply Likes
Windows updates maybe Flex's Achilles heel.   Mick have you made any progress? 

 I'm sure that several members on here that can use "Team Viewer" to help you out if you haven't got it fixed.  I lived with my DAX problem for several months before I got enough courage to go after it.  

Gayle K0FLY
Photo of Mick

Mick

  • 6 Posts
  • 1 Reply Like
All,
Thanks for the pointers.
Gayle is right about getting up the courage to go after Widows registry problems. I used to clean the registry regularly in earlier versions of Widows but have never done that in Windows 10. So I should get some time this week to take a look.
Thanks for the advice. Lets see what happens next.
Cheers,
Mick
W6MOB
Photo of Mick

Mick

  • 6 Posts
  • 1 Reply Like
All,

Tim from Flex fixed this for me. Apparently several of the DAX pointers were incorrectly tagged. They had to be manually edited.

So it is fixed
Thanks
Mick
W6MOB