fldigi will not work with Flex 6700

  • 1
  • Problem
  • Updated 2 years ago
I am using SSDR 1.10.16.174 and trying to interface with Fldigi 3.23.07.  Audio works fine but no rig control.  I've tried using the sourceforge download but it is an html file and fldigi wants an xml file and does not recognize it.  How do I convert or somehow get it to work?
Photo of Bill Hickey

Bill Hickey

  • 14 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of Jay Spaulding

Jay Spaulding

  • 66 Posts
  • 3 Reply Likes
Use Omni rig . and then use your cat program to pic the slice. That's what I do. Works very good. Something for WSJT-5. And I have them both reporting to Log4om. And the logger dents to QRZ hrdlog and wellLOTW and some others

Good luck
Photo of Ken Hansen

Ken Hansen

  • 336 Posts
  • 110 Reply Likes
I setup wspr on my 6300, couldn't get radio control until I selected Kenwood TS-2000 as radio, selecting Flex was a no-go.

The Flex radios are designed to support Kenwood-style rig commands, I'd give that a try.

Also, I believe I had to 'enable' transmit on the SmartSDR screen, on DAX audio panel? Sorry, away from radio.
Photo of Jay Spaulding

Jay Spaulding

  • 66 Posts
  • 3 Reply Likes
Oh I forgot. There is a later version on FLDIgi btw it's over 4.0 now. Could be some of the problem.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
The problem is your browser needs to download the RigCAT xml file as a raw file and not as HTML.  Try a "save as"
(Edited)
Photo of Hermann Fernandes Pais

Hermann Fernandes Pais

  • 8 Posts
  • 1 Reply Like
On the Rig Setup menu open the Hamlib tab. Select the Kenwood 2000 radio. Select the comm port for the slice that you're dedicating to fldigi. Remember to click on "enable .hamlib".

Remember to go to the audio tab and pick the correct slice under port audio for receive.

FLDIGI defaults to the first comm port and the first audio slice. This can cause conflicts if you have other clients using the flex.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9197 Posts
  • 3557 Reply Likes
Both Hamlib and OmniRig are very limited in functionality.  RigCat supports all radio modes properly including preset filter switching.
Photo of Bill Hickey

Bill Hickey

  • 14 Posts
  • 2 Reply Likes
Tim, Thanks for the reply.  I tried a Save As but Raw was not one of the options.  My choices are Complete, Archive, or HTML Only.  What?  Bill AB7AA
Photo of Andrew Russell

Andrew Russell

  • 278 Posts
  • 44 Reply Likes
Bill,
Try with another browser such as chrome.
That works for me.
Andrew de VK5CV
Photo of Bill Hickey

Bill Hickey

  • 14 Posts
  • 2 Reply Likes
Tim-W4TME,  Thanks for the reply.  I tried a Save As but raw was not one of the options.  My choices are Complete, Archive, or HTML Only.  What?   Bill AB7AA
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9197 Posts
  • 3557 Reply Likes
You may need a different browser
Photo of Michael Coslo

Michael Coslo

  • 947 Posts
  • 259 Reply Likes
Bill, I have a howto on Youtube https://www.youtube.com/watch?v=IVOhj244e30&t=1s 

It was based on a 6300, but will work for the 6700.  You should be able to simply click on the sourceforge link with a left click, and it will download the xml file with no questions asked about how to save it, getting you the xml file
(Edited)
Photo of Bob KC9RF

Bob KC9RF

  • 34 Posts
  • 4 Reply Likes
Hi Bill 
There is a XML file(s) that need to be loaded typically to C:\Users\(your user name)Documents\fldigi.files\rigs

These files are  SMARTSDRsliceA.xml   and same name but slices b,c and d. etc

Here is the link  for these files https://sourceforge.net/projects/fldigi/files/xmls/flex/

The  setup should look similar to this depending on what slice you are using. Press initialize then check flex for correct freq controlled by fldigi.



Audio for fldigi should look similar to window below. Note don't forget to turn on dax channel in slice (x)
I'm using slice B this is the config used.

Bob KC9RF