fldigi hardware PTT

  • 1
  • Question
  • Updated 3 years ago
  • Answered
hi All,

I been through the forum and tried many option but still having a issue getting Fldigi hardware PPT working. everything else is working find.

so here what I have:
  • Fldigi 3.22.05.
  • SSDR 1.4.3.
  • Windows 8.1.

I have setup up a com port for PTT with RTS selected.
In Fldigi I have hardware PPT selected with my new comport (lower number).
(see below for all settings sections)

Whats happening is, the radio is keying but no tone is being transmitted..
(Mode is CW).

RTTY and PSK ( and other digital modes ) through DAX is working great. Got my logging software Log4OM  working well also. This is my last piece. :-)



Photo of Mike Colonna

Mike Colonna

  • 9 Posts
  • 3 Reply Likes

Posted 3 years ago

  • 1
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1561 Posts
  • 552 Reply Likes
Are you using the radio in CW mode? That would probably block AFSK tones from Fl-Digi. Try setting up a DIGU slice with a nice narrow filter and save it as a Profile to use in CW.
(Edited)
Photo of Mike Colonna

Mike Colonna

  • 9 Posts
  • 3 Reply Likes
Hi George,
Yes I'm am using CW,  Okay I switch to DIGU mode set up a filter up and saved it, switch back to CW and selected that transmit profile but the the same thing the radio keys but no tone. however in DIGU mode the radio does key and tone is sent. was I to stay in DIGU mode for CW?
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1561 Posts
  • 552 Reply Likes
Yes, when you switch modes to CW, the audio inputs are disconnected.
Photo of Mike Colonna

Mike Colonna

  • 9 Posts
  • 3 Reply Likes
Just out of curiosity how do people key the radio in CW mode (contesting for example )is it even possible. With my old radio I used a rigblaster pro. so I'm thinking a external keyer.. for now I'm just going to use my paddle. Lol thank you for your help.
Photo of Duane, AC5AA

Duane, AC5AA

  • 394 Posts
  • 85 Reply Likes
Mike, I haven't tried contest software keying, but I believe it's done by assigning RTS to one of the COM Ports created in the CAT app.  One of the nice things in the later releases if you're using a paddle connected directly to the rig is that you can set up CWX memories and speeds, and that speed is sync'ed with the non-CWX keyer.  So, only one speed setting to control.  I've also found in 1.4.3 that the CWX doesn't even have to be selected to use the F-keys to send those messages!  Nice!
Photo of Duane, AC5AA

Duane, AC5AA

  • 394 Posts
  • 85 Reply Likes
CW mode is only for CW.  If you want digi modes, including RTTY (at least until they deliver an FSK capability), you need to use DIGU for FLdigi.  (DIGL for MMTTY).  You're sending audio tones and CW mode does not support that.  (I've actually accidentally used USB mode and it's worked, but I try not to do that!)
Photo of Mike Colonna

Mike Colonna

  • 9 Posts
  • 3 Reply Likes
Hi Duane, Okay I now understand, thank you..
Photo of Vincent Martin - N5ATM

Vincent Martin - N5ATM

  • 31 Posts
  • 0 Reply Likes
I am now grappling with this same issue and just found this thread.  I use com 1 with a w3yy (http://w3yy.com/fsk.htm) interface.  With the radio in CW mode and the program CWTYPE this works just fine, so I know it's not an issue with SmartSDR, com port or interface.

When I use Fldigi and the radio in CW mode however, I get the same result as Mike.  Why would fldigi care what mode the radio is in?  Does it not have the capability to send CW via the com port like directly like programs such as CWTYPE?

I guess what I'm really asking is.  Is this a problem with fldigi and SmartSDR or is this just simply a problem with or limitation of Flidig?  Thanks for your input.
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 891 Posts
  • 166 Reply Likes
I have written a new tutorial which you can find on this forum.
Fldigi has been developed quite a bit. Be sure to install the newest version
and the new SmartSDR xml files for RigCat. PTT works like a charm.
73, Alex DH2ID
Photo of Vincent Martin - N5ATM

Vincent Martin - N5ATM

  • 31 Posts
  • 0 Reply Likes
Hi Alex,

PTT is not the issue.  CW via com port in CW mode is the issue.  Apparently FLDIGI does not support this.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
For your convenience, the Fldigi How To by Alex is available via the HelpDesk
https://helpdesk.flexradio.com/hc/en-us/articles/204954466-Setting-up-Fldigi-with-SmartSDR
(Edited)
Photo of Vincent Martin - N5ATM

Vincent Martin - N5ATM

  • 31 Posts
  • 0 Reply Likes
Confirmed by Dave, the author, Fldigi does not support com port keying for CW or FSK and he has no plans to add the functionality.  Sad news.  However, the software is open source and we are free to modify it as necessary.  If only I were a programmer.  :)
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 891 Posts
  • 166 Reply Likes
http://www.w1hkj.com/FldigiHelp-3.21/html/cw_configuration_page.html

fldigi CW keying is quite good, but I use a ZLP Electronics CW Keyer with HRD DM780 or Log4OM Winkeyer mode.
Photo of Vincent Martin - N5ATM

Vincent Martin - N5ATM

  • 31 Posts
  • 0 Reply Likes
Alex, your message is confusing.  Fldigi does not do CW/FSK keying via the com port. 
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 891 Posts
  • 166 Reply Likes
Sorry, I didn't want to confuse.

To clarify: fldigi uses a CAT command for PTT in my setup.
SmartSDR mode set to DIGU. CW settings can only be used with a
Winkeyer or directly with a key or a paddle.



It would be great if flwkey could be integrated into fldigi, a Winkeyer
is a great asset for CW.