fldigi changing modes incorrectly

  • 1
  • Problem
  • Updated 2 years ago


Are there any fldigi gurus out there? Running SSDR 1.9.13.173 with a 6300 and latest version of fldigi

I'm having a problem with mode control. Whenever I change operation modes within Olivia such as going from 8-250 to 8-500 fldigi changes the mode of the SSDR to USB instead of leaving it on DIGI-U and therefore does not transmit until I manually change it back.

I have looked at all the fldigi config tabs to see if I have something set wrong but I don't see any solution.

While it does work, it is annoying to have to constantly manually reset the  mode.

All suggestions welcome.

73, Bill W6WRT

Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

Posted 2 years ago

  • 1
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 823 Posts
  • 191 Reply Likes
The dropdown just below the frequency readout - does it say DIGU? Are you using RigCAT with the proper SmartSDR_Slice[A|B|C|D].xml selected? I believe DIGU is defined in the .xml file.

Are you using fldigi with the fldigi-dxlabs gateway? If so, sheck the gateway setup tab, PSK/etal and set to Data-U.

Once I set DIGU in fldigi then I can jump around to any digital mode or sub-mode and it seems to stay at DIGU for me.

Kev K4VD
Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

Yes, all of the items you mention above are set correctly. Something must be corrupted witing one of those programs. I am going to uninstall and reinstall, starting with the gateway. Thanks for your help.

W6WRT

Photo of Michael Coslo

Michael Coslo

  • 912 Posts
  • 234 Reply Likes
It doesn't transmit? It should still work FB, except you won't get the bottom end of the DIGU settings. I'll check and report back.
Photo of Michael Coslo

Michael Coslo

  • 912 Posts
  • 234 Reply Likes
Hi Bill,

I have not been able to duplicate your problem. Once I have set the DIGU setting in fldigi, it stays there no matter what I do. Are you still having the issue?
Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

Yes, even with DIGI-U set in both fldigi and gateway, the problem is still there. As I said in another post, I think something is corrupted in one of the programs, so I am going to uninstall and reinstall, starting with the gateway.

73, Bill W6WRT


Photo of Jay / NO5J

Jay / NO5J

  • 1621 Posts
  • 235 Reply Likes
Bill

Maybe a clue, maybe not, I've had the same issue with the mode being switched to USB, in the past. are you seeing "DIGI-U" listed as a mode in the Fldigi mode list?
In my Fldigi mode list its spelled "DIGU". When mine was doing this in the past it was spelled "DIGI-U". It ought to be getting the mode spelling from the .xml file. the list in my Fldigi only lists the mode spellings that SmartSDR uses.

By any chance are you using Commander or DXLabs-Fldigi-Gateway? I use the gateway, along with the .xml files, I have the Gateway configured so that Fldigi is selected for rig control, if I select Commander instead then I get the mode switching problem.

On my main Commander window, it's being spelled "DIGU" also. But I've seen it spelled as "Dig-U" when I had the problem. However, in the Gateway I've got the PSK/etal option set to "DIG-U"

I get better results letting Fldigi handle Rig Control in the Gateway.

DIGI-U, DIG, DIG-U, and DIGU all sound similar but, might mean very different things to different radios and Digital apps.

I'm setup with these options below, before giving up. ...






Addendum:
When I do run into this problem occasionally, It seems to be a sticky problem, Even after reverifying I'm Setup correctly, it will continue to switch modes until I close and restart SmartSDR, Fldigi, DXLabs Suite, and the Gateway. Then It behaves.
   
If you're not using DXLabs and the Gateway then I apologize for the long post.


 SDRgadgets

73, Jay - NO5J

(Edited)