first rudimental audio remoting

  • 2
  • Idea
  • Updated 4 years ago
Hi,

playing with new DAX, I was able to listen the selected slice/DAX receiver in LAN connected PC.

Running SmartSDR in a remote PC, selecting DAX1 for a slice, configuring DAX1 as preferred record device for Windows and activating "listen this device".

I can listen (with latency) on PC speakers.
Some pops and crack.....but works.

73 Beppe
ik3vig
Photo of Beppe IK3VIG

Beppe IK3VIG

  • 56 Posts
  • 15 Reply Likes

Posted 4 years ago

  • 2
Photo of Takeshi Yamada

Takeshi Yamada

  • 168 Posts
  • 48 Reply Likes
I observe some noises when I use DAX to listen to the band, too.
Also I cannot monitor CW when I use DAX.
X/RIT is not implemented yet?

Overall, I recognized a good progress! Excellent work Flex Radio!

de JA2IYJ/1
Photo of Bob G   W1GLV

Bob G W1GLV

  • 639 Posts
  • 107 Reply Likes
X/RIT is working
Photo of Chris DL5NAM

Chris DL5NAM

  • 567 Posts
  • 126 Reply Likes
Where is the PC? Remote means over WAN. Tell us how it works.
Photo of Beppe IK3VIG

Beppe IK3VIG

  • 56 Posts
  • 15 Reply Likes
I wrote "LAN" not "WAN".

The PC is in other room, connected to a switch with others PC and F6700.

73 Beppe
ik3vig
Photo of Greg

Greg

  • 656 Posts
  • 63 Reply Likes
Beppe, I have not yet been able to confiugre this. It seems when I installed the update on my Lenovo Yoga ultrabook I totally lost the use of the built in speakers. It may work on attached phones or speakers connected to the audio port but I have not tried that yet.

Do you have a lot of traffic over your LAN? How bad is the latency? How do you have CW configured?

73
Greg
AB7R
Photo of Beppe IK3VIG

Beppe IK3VIG

  • 56 Posts
  • 15 Reply Likes
Greg,

I have configured DAX 1 device, checking "listen this device" in Windows audio tab form, but I'm not sure all PC soundcards are able to do this.

The PC soundcard is the preferred listen device (old Lenovo X61 in warehouse for daily shipments in WoodBoxRadio), so, the DAX1 is routed to PC audio out.

The latency is, as usual, "WIndows generated".
I have tried 40M SSB only.

The LAN is a Gigabyte, a simple wired 8 ports switch for all my PCs at WBR and F6K for test.

73 Beppe
ik3vig
Photo of Greg

Greg

  • 656 Posts
  • 63 Reply Likes
Thanks Beppe. I will have to plug in some headphones to see if I have the audio there. The mixer levels are bouncing around while listening so I know its there...just need to get it to the phones or speakers.

73
Greg
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1529 Posts
  • 541 Reply Likes
Works pretty well here - I have DAX 2 set up with "listen to this device" in Windows. DAX 1 is set up for my digital modes.

When I am out and about, I can use LogMeIn (or any other favorite remote desktop app) to see the SSDR screen on your home PC. By engaging DAX 2, audio streams very well. I've tried it on my iphone over cellular data, on my home LAN, and other LANs. It's a very cool feature.

You may want to use PC speakers that can be turned off/down from the speakers themselves (not from Windows) so your audio adventures don't wake the house.

Also - for Takeshi - RIT/XIT are implemented on both the SSDR interface and through the FlexControl. Very handy. You do have to toggle them on by pressing the RIT/XIT buttons.
Photo of K1UO - Larry

K1UO - Larry

  • 730 Posts
  • 119 Reply Likes
Greg, Right Click on your speaker Icon on the task bar. select playback devices and when that window opens select the Recording Tab. Under this Tab double click on the RX/TX number you are using and when this window opens select the Listen Tab and check 'Listen to this device' box in that Tab. Right underneath make sure the 'Playback through this device' has your PC speakers selected in the window.

MX and HNY
Larry K1UO
Photo of Greg

Greg

  • 656 Posts
  • 63 Reply Likes
Thanks Larry. That is what I have been trying to do but somehow when I did the install on my ultrabook I no longer seem to be able to connect anything to its internal speakers. Even online videos no longer play any sound and I cannot find the internal sound device for the speaker in the playback options. I am going to try a set of headphones to see if that works.

73 and Merry Christmas!
Photo of K1UO - Larry

K1UO - Larry

  • 730 Posts
  • 119 Reply Likes
Ah...I understand..I read on here that some of the installs have changed the default sound device to something other than the original speaker setting. Hard to change the speakers back to the default playback device if you cant find the speaker Icon!
Good luck..... Lots for this old fella to learn and more importantly...remember.