Excess power detected on receiver error message - flex 6500 & maestro

  • 1
  • Problem
  • Updated 1 month ago
This started last night after a fault occurred with my kpa1500 while i was on 160m,it
receives fine, I get the Error Has Occurred - Excess Power Detected pop up every time i try to transmit or tune.
This happens on both antenna ports and with or without a dummy load.

Nothing unusual on the front panel at start up or transmit. on transmit, relay clicks and the LED blinks red back to green and the error pops up.   This happens on both windows or Maestro (2.4.9)

I opened a ticket, but does anyone have any other ideas ? I did do a factory reset with no joy.

Thanks,
Rich
n2ry
Photo of Rich

Rich

  • 7 Posts
  • 0 Reply Likes
  • not good

Posted 1 month ago

  • 1
Photo of kd5foy

kd5foy

  • 20 Posts
  • 2 Reply Likes
Photo of Rich

Rich

  • 7 Posts
  • 0 Reply Likes
saw that, read it, nothing helped. same cables worked on other radios just fine at 100 watts (AM no less). 6500 wont even tune at 10-15 watts

known good  cables, and running straight into a dummy load doesn't work either.


Photo of Steven Linley

Steven Linley

  • 331 Posts
  • 53 Reply Likes
Visually inspect and/or replace all coax connectors/cables.
Start PL-259's still in RF path to Dummy Load.
Photo of Rich

Rich

  • 7 Posts
  • 0 Reply Likes
Just noticed this, this morning .....  lower right corner says " TX  TX fault"

Sign of a hardware error ?


Rich
n2ry


Photo of K1UO - Larry

K1UO - Larry

  • 833 Posts
  • 135 Reply Likes
Rich,  What firmware level was you running on your KPA150.  Versions below 2.0 had a very serious fault on some units when using on 160 meters that could damage or destroy the PA transistors.
Photo of Rich

Rich

  • 7 Posts
  • 0 Reply Likes
Hi Larry,

I was running v.2.0.9

I updated to 2.0 as soon as I got the email about it. And then to 2.0.9 a week or so ago.

Ironically, I lost the PA's shortly after getting the amp in early Nov and running on 160m, I believe the version was like 1.78 ?

It was repaired under warranty, and less than a month or so the v2.0 email came out.


Rich
n2ry