Unhandled timer exception error in SSDR v1.3

  • 3
  • Problem
  • Updated 5 years ago
  • In Progress
  • (Edited)
Used the 6300 all day yesterda. Got up this morning and got this Unhandled Error popup. I can hear the radio working and can tune with the FlexControl----Just no display. Rebooted PC and rig. Tried a quick reinstall of  Ssdr without first removing the program and got the same error. Any suggestions? Steve N4LQ
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes

Posted 5 years ago

  • 3
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Official Response
We are aware of this error and have previously entered it into our bug tracker as a defect.  It is currently being investigated.  Thanks for the report.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
This bug has been squashed and will be included in the next release of SmartSDR of Windows.
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
What's the procedure to recover? I tried a system restore to 8/21. No help. It pops up instantly when connecting to the radio. Should I reset the 6300? Remove SmartSDR? 
Glad I have a backup rig.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
We don't have one yet.  We are working on it.
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
I happened to have a laptop which has 1.3 installed on it so I disconnected my direct connection to the main PC and connected directly to the laptop. No error but I could see the control panels only, no scope or waterfall. 
I then did a "factory reset" on the 6300 by holding down the power button for 5 seconds as I applied DC. Everything came back to normal on the laptop as it would with a new installation and works. 
So then I plugged the 6300 back into the desktop and attempted to run it. Immediately the ERROR pops up. So I plugged it back into the laptop and got controls only, no pan scope display and now no audio or control ability. 
So I did another factory reset and now it's back up on the laptop.

I guess I'm dead on the main computer now. Something is corrupted. To the best of my knowledge the only change I did yesterday was to the Mic.bias for a new microphone. 

So my question is this....If this is a "Bug" and someone is working on it, do we wait several months for a new software version before we can use these rigs or is someone going to email us with a cure. I'm just trying to make plans here.

Steve
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Steve please do this.  Navigate to the %APPDATA%\roaming\FlexRadio Systems folder.  Copy the file SSDR.settings to a different location, then start SmartSDR.  If this fixes your issue, I need a copy of the SSDR.settings file to do forensics on it.
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
Where is the folder? I can't find it. Also note that I have uninstalled 1.3 and cat then reinstalled but no change. 
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
In the Windows search bar, enter %APPDATA% and click on the folders in the path.
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
Found it. Your path doesn't work though. Those % signs aren't recognized. Searching on the file name works though. I moved the file and now it runs again at least for a while.
I'm searching for a way to attach the file.
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
<?xml version="1.0" encoding="utf-8"?><Settings>
  <ApplicationVersion>1.3.0.116</ApplicationVersion>
  <LastButtonPressed>Knob</LastButtonPressed>
  <ButtonMiddleFunction>Master AF</ButtonMiddleFunction>
  <ButtonLeftFunction>RIT</ButtonLeftFunction>
  <FocusHelperDelay>2</FocusHelperDelay>
  <UpdateSettings>True</UpdateSettings>
  <FlexControlEnabled>True</FlexControlEnabled>
  <FocusHelperTarget>None</FocusHelperTarget>
  <FavoriteMode0>USB</FavoriteMode0>
  <FavoriteMode2>AM</FavoriteMode2>
  <MainWindowPlacement>&lt;?xml version="1.0" encoding="utf-8"?&gt;&lt;WINDOWPLACEMENT xmlns:xsd="http://www.w3.org/2001/XMLSchema"; xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"&gt;&lt;length&gt;44&lt;/length&g...;
  <FocusHelperOtherWindowName>
  </FocusHelperOtherWindowName>
  <AutoShowTutorial>False</AutoShowTutorial>
  <FavoriteMode1>CW</FavoriteMode1>
  <PrimaryKnobFunction>Tune Slice</PrimaryKnobFunction>
  <chkShowTXWindow>True</chkShowTXWindow>
  <SetupWindowPlacement>&lt;?xml version="1.0" encoding="utf-8"?&gt;&lt;WINDOWPLACEMENT xmlns:xsd="http://www.w3.org/2001/XMLSchema"; xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"&gt;&lt;length&gt;44&lt;/length&g...;
  <FocusHelperN1MMPort>12060</FocusHelperN1MMPort>
  <ButtonRightFunction>XIT</ButtonRightFunction>
</Settings>
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Send it to my e-mail
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
Well you'll have to tell me what your email address is. 
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
my first name at flexradio.com
Photo of Steve Jones

Steve Jones

  • 104 Posts
  • 23 Reply Likes
Is this a problem with just the 6300 or also affecting the other models? If its just a 6300 issue it might sway my purchase decision towards the 6500.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
It is an equal opportunity defect, affecting all models.  We are not sure what causes a value in the settings file to have an out of range value, but we are taking action to prevent it from crashing SmartSDR.  If you have this issue, deleting the SSDR.settings file will allow the SmartSDR to start.
Photo of Steve Jones

Steve Jones

  • 104 Posts
  • 23 Reply Likes
Thanks Tim
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
We have added a fix to the next release of SmartSDR that will prevent this bug from crashing the radio.
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
Steve Jones. I doubt if you will get an answer on that question from Flex. All I ended up doing is searching for a file named ssdr.settings and deleting it. That cured the error. The file gets remade the next time you close Smart SDR. It just contains your settings from the previous screen. Somehow it got corrupted. 
Photo of Steve Jones

Steve Jones

  • 104 Posts
  • 23 Reply Likes
Noted thanks.