Erratic behavior of Noise Blanker and Noise Reduction - buttons

  • 1
  • Question
  • Updated 3 years ago
Has anyone else noticed this?

- SmartSDR does not always remember the last state of the NB & NR buttons.

- Sometimes when SmartSDR starts or when you change bands or open a new slice, the NB and/or NR buttons will be blue, indicating they are turned on. However, I am hearing a lot of noise, like the function is not turned on, which is sometimes the case.

Click the NB & NR buttons off and on again. Now the NB and/or NR ... are blue and the noise is gone or reduced - they are now working.

It can happen with either the NB or NR and sometimes both.

- NR button may be active and working, however clicking it off and then back on and sometimes it will do a better job of reducing noise. (making receiver more quiet)

SmartSDR v1.43
Flex 6500
Windows 8.1
i7 Quad Core CPU, 8GB RAM, 2GB Nvidia graphics card card

73..  Ken - VE5KC
Photo of Ken - VE5KC

Ken - VE5KC

  • 48 Posts
  • 12 Reply Likes

Posted 3 years ago

  • 1
Photo of Robbie - KI4TTZ

Robbie - KI4TTZ

  • 479 Posts
  • 77 Reply Likes
I've noticed something kinda opposite of that - if I have NR/NB (either/or/both and I'm adjusting the sliders, toggling one or the other on/off, adjusting some more, (etc), eventually the audio goes almost silent like I turned the volume to zero.

Then, if I turn both NR/NB off, it resets it back to the standard volume level and I can turn them back on and start adjusting the sliders again.  I don't remember the exact pattern I was doing to reproduce it, but if flex needs more info, I can try to document what I was doing.

-Robbie
Photo of Burt Fisher

Burt Fisher

  • 1010 Posts
  • 365 Reply Likes

It also doesn't remember the speed setting in CWX

Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 642 Reply Likes
Burt, there did change that in that now the speed setting on CWX is identical to speed on the right hand side dialog, they used to be independent of each other. I believe they should be in synch.
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1678 Posts
  • 573 Reply Likes
Walt,
I think that is the default when V1.4.3 is installed but you can change it.

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com



(Edited)
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3471 Posts
  • 1335 Reply Likes
NR and NB and ANF improvements (Science Projects) are slated to be part of Version 1.5

But if someone else is able to confirm this behavior and/or it is not a design feature Tim might add it to the bug tracker.
Photo of Robbie - KI4TTZ

Robbie - KI4TTZ

  • 479 Posts
  • 77 Reply Likes
I can confirm it, I just started up ssdr after a reboot of everything (needed to install a few windows patches), NR was enabled (blue) on a slice after startup but it wasn't really NR-ing anything. Toggled it off and on, problem resolved.
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 83 Reply Likes
NB has had that ADD-like behavior for a while, IMHO...sure hoping the 'science project' pans out..