DXlab and Winwarbler

  • 2
  • Question
  • Updated 3 years ago
New 6700 user (ie: today) and have the Flex working fine with Dxlab. The only issue is with RTTY transmit. I followed the instructions on the Flex wiki and Winwarbler works fine sending CW and receiving RTTY. I left the PTT tab in Winwarbler's Config as "Xcvr Ctrl App" and port to none (I have PTT enabled on port 8). Cannot send RTTY or if I select port 8 for PTT . DAX working fine. I am sure I am missing something simple. Any ideas?

Tim VE6SH
Photo of Tim Ellam

Tim Ellam

  • 222 Posts
  • 25 Reply Likes

Posted 3 years ago

  • 2
Photo of Dave AA6YQ

Dave AA6YQ

  • 93 Posts
  • 54 Reply Likes
Just now saw your post, Tim. Did you get this sorted, or are you still unable to TX in RTTY?
Photo of Tim Ellam

Tim Ellam

  • 222 Posts
  • 25 Reply Likes

Hi Dave. I have been so busy I have not returned to it, but I think I know the issue. I was trying to set it up with FSK rather than AFSK. I will try this weekend and let you know if any issues.

73


Tim

Photo of Tim Ellam

Tim Ellam

  • 222 Posts
  • 25 Reply Likes
I still have this issue. I followed the instructions th the letter but Winwarbler will not put the Flex into transmit either using the messages or "start" key .
Photo of Dave AA6YQ

Dave AA6YQ

  • 93 Posts
  • 54 Reply Likes
In the middle of the General tab of Commander's Configuration window, there's a "PTT" panel with TX and RX buttons. Do these buttons switch your 6700 between RX and TX?
Photo of Tim Ellam

Tim Ellam

  • 222 Posts
  • 25 Reply Likes
Thanks Dave. No I tried that. They do not in any mode.
Photo of Dave AA6YQ

Dave AA6YQ

  • 93 Posts
  • 54 Reply Likes
What version of Commander are you running (look in its Main window's Title bar)?

On the Configuration window's General tab, to what is the Radio panel's Model selector set?

Is Commander able to track and control your 6700's frequency and mode?
Photo of Tim Ellam

Tim Ellam

  • 222 Posts
  • 25 Reply Likes
12.0.2. SDR6700 and yes, the Commander panal tracks the frequency and mode.
Photo of Tim Ellam

Tim Ellam

  • 222 Posts
  • 25 Reply Likes
Dave. Winwarbler in CW mode works fine and puts the Flex into transmit.
Photo of Dave AA6YQ

Dave AA6YQ

  • 93 Posts
  • 54 Reply Likes
OK. Please do the following:

1. on the Configuration window's General tab, check the "log debugging info" box

2. terminate Commander

3. start Commander

4. Using Commander's Main window, 

4a. QSY to 28500 in SSB

4b. QSY to 14005 in CW

5. on the General tab of Commander's Configuration window

5a. in the PTT panel, click the TX button

5b. in the PTT panel, click the RX button

6. on the Configuration window's General tab, check the "log debugging info" box

7. attach the errorlog.txt file from your Commander folder to an email message, and send it to me via

aa6yq (at) ambersoft.com
Photo of Dave AA6YQ

Dave AA6YQ

  • 93 Posts
  • 54 Reply Likes
On the CW tab of WinWarbler's Configuration window, how do you have the Keying panel configured?
Photo of Dave AA6YQ

Dave AA6YQ

  • 93 Posts
  • 54 Reply Likes
Thanks for the errorlog, It shows that Commander is not sending a "transmit" command to your 6700 when you click the TX button, but does not reveal why not.

I have added diagnostics to a new version of Commander, and sent you email with instructions for obtaining it and running the next test.

As you have WinWarbler configured, it is transmitting CW by conveying the data to Commander, which in turn conveys the data to your 6700 via a "transmit cw" command. This command immediately switches your 6700 to TX, and then back to RX after the last of the CW has been transmitted. Evidently this mechanism isn't impeded by whatever is stopping Commander from sending your 6700 a "transmit" command when you click the TX button. The errorlog generated by the new Commander version should reveal why.
 
Photo of Tim Ellam

Tim Ellam

  • 222 Posts
  • 25 Reply Likes
This was fixed thanks to Dave's diagnosis.

First, in the config panel in Commander I had the "suppress CAT" box checked. Unchecking the box allowed me to use the PTT buttons in Commander for RTTY TX. I still could not get the RTTY memories in WinWarbler to trigger the TX/PTT.

The culprit turned out to be in the External Modem tab in WW config. I had RTTY "enabled" on this tab. Unchecking the box cleared up the issue. What I had done was to load an older profile for WW when I reinstalled the program on my new computer. The profile dated from the time when I was using an external modem.

In other words "operator error". Thanks all for the suggestions.

Now to get the Genovation keypad to trigger the macros.

73

Tim VE6SH
Photo of W5XZ - dan

W5XZ - dan

  • 564 Posts
  • 83 Reply Likes
wow, is AA6YQ captain america, or what???

'genius, billionaire, playboy, philanthropist, diplomat...'

u da man, dave...
Photo of Dave AA6YQ

Dave AA6YQ

  • 93 Posts
  • 54 Reply Likes
Nope, just a happily married DXer crawling towards DXCC Challenge 3000 and developing DXLab on the side.
Photo of Dan -- KC4GO

Dan -- KC4GO

  • 339 Posts
  • 68 Reply Likes
"Nope, just a happily married DXer"  Sounds like a happy Ham to me!!!
Thanks for your efforts Dave...
Dan -- KC4GO