Duversity Mode

  • 1
  • Problem
  • Updated 1 year ago
I just discovered a minor bug with Diversity reception on the 6700 and SSDR 1.10.15.  I was in diversity mode when I exited SSDR. When I restarted SSDR, it indicated it was still in Diversity mode, both flags were displayed (A and H), but there was no audio from the A side. I exited Diversity mode and the audio was back in both channels. I then restarted Diversity mode and audio was working properly.
Photo of Mark Erbaugh

Mark Erbaugh

  • 371 Posts
  • 32 Reply Likes

Posted 1 year ago

  • 1
Photo of KF4HR

KF4HR

  • 428 Posts
  • 113 Reply Likes
I haven't tried the Diversity Mode on my 6700 yet, but I'm curious if this features functions as a true diversity receiver, selecting the best input signal between two antennas, or is it just receiving two signals at the same time?
Photo of Mark Erbaugh

Mark Erbaugh

  • 371 Posts
  • 32 Reply Likes
No, it's not automatic. I just sets up two slices that are synchronized except one is on one antenna and one is on another. I
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8670 Posts
  • 3254 Reply Likes
Mark, I can't reproduce the behavior you described.  When I restart SmartSDR there is audio from the parent slice (A) and the child slice (E).
Photo of Mark Erbaugh

Mark Erbaugh

  • 371 Posts
  • 32 Reply Likes
Well, I've repeated the test and have interesting results. Most of the time after shutting down and restarting SSDR, it restarts with slices A and H with not audio on slice A (I have repeated this and seen it several times).  You say you have slices A and E. Why am I seeing slices A and H?

Then, just to make it interesting, twice when I shut SSDR down in Diversity mode, which was using slices A and H synchronized, it cam back up with slices A and B on two separate frequencies, no slice H and no Diversity.