DSP

  • 6
  • Problem
  • Updated 6 years ago
  • Solved
NR, NB, and ANF do not seem to be working.
David
Photo of David

David

  • 6 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 6
Photo of Ed, K0KC

Ed, K0KC

  • 288 Posts
  • 20 Reply Likes
Seems that way to me as well.
Photo of Michael N6BRP

Michael N6BRP

  • 48 Posts
  • 5 Reply Likes
smart sdr 0.15.13 -- Yes it seems that NR, NB and ANF do not appear to be functioning properly (if at all). I was hoping the NB recovery would be fixed in this addition. I also noticed that when changing the NB slider, it disengages the NB.
Photo of W4YXU

W4YXU

  • 75 Posts
  • 6 Reply Likes
I see the exact same problem.
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
I see the same here.
Photo of James Kennedy-WU5E

James Kennedy-WU5E

  • 338 Posts
  • 35 Reply Likes
after two reboots , my DSP is working but not to the degree as 0.13.10

Jim
WU5E
flex 6500
Photo of Richard Clafton W4/G7EIX

Richard Clafton W4/G7EIX, Elmer

  • 455 Posts
  • 117 Reply Likes
Yup - confirmed. Just tried to use them and seems to make no difference.
Photo of Richard Clafton W4/G7EIX

Richard Clafton W4/G7EIX, Elmer

  • 455 Posts
  • 117 Reply Likes
After a power recycle of the radio...I now have what seems to be a working NR, but NB and ANF seem to be ineffective.
Photo of Richard Clafton W4/G7EIX

Richard Clafton W4/G7EIX, Elmer

  • 455 Posts
  • 117 Reply Likes
Ok, so as reported below...NR seems to be working...as ANF.
Photo of Duffy NA5MM

Duffy NA5MM

  • 1 Post
  • 0 Reply Likes
I must need the secret decoder ring. If I am in USB and cram the NR to 100 and engage it I get ANF, which will notch a cw signal. However if I flip to LSB and move passband over the cw note and engage NR I get little or no notch. Obviously the controls are mislabeled and do not work correctly .I can not see any effect of the other 2 DSP controls. Wow 4 weeks since ver 13 release and all those Alpha, Beta, black box and gray box testing and this is what we get. Jeeez. 6700 win7 64 bit hp laptop Duffy NA5MM
Photo of W4EG

W4EG

  • 43 Posts
  • 6 Reply Likes
Flex 6700... DSP_ NR - NB -ANF
Not working, no matter how many time I shut off the radio or computer; but they can be grabbed and slide on CW or LSB.
Photo of Michael N6BRP

Michael N6BRP

  • 48 Posts
  • 5 Reply Likes
Tried Rebooting radio and computer several times and still no NB, NR or ANF (at least on SSB). Other aspects of this release seem to be improved.
Flex 6500, SmartSDR 0.15.13, Windows 7 Ult 64 with Intel based computer

-Mike
Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
I never saw them working in 0.13.10 so they are working the same for me.
Photo of Dave - WB5NHL

Dave - WB5NHL

  • 288 Posts
  • 66 Reply Likes
Tuned in a steady carrier signal and NR does seem to knock it down
Photo of W5XZ - dan

W5XZ - dan

  • 571 Posts
  • 86 Reply Likes
NB totally busted here...bummer
Photo of K1UO - Larry

K1UO - Larry

  • 886 Posts
  • 135 Reply Likes
havent been able to notice where these controls are having any effect at all.
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1853 Posts
  • 672 Reply Likes
CW NR - with 0.15.x NR is acting like an Automatic Notch Filter. Easy to demonstrate:

- Tune in a steady carrier
- engage NR
- carrier will disappear in a few seconds
- goes faster with a higher NR slider setting

Happens every time here....if this is a consistent finding, doesn't it seem like this should have been caught in one of the earlier testing stages? Maybe this is only happening in a few cases????

In any event, It sounds like this should be added to the "regression test case list."

Regards, Al / NN4ZZ
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9197 Posts
  • 3557 Reply Likes
Official Response
Thanks to all who have reported issues with the DSP. We tracked this down to an issue with our production release build process. The DSP will be fixed in next SmartSDR for Windows release.

This conversation is no longer open for comments or replies.