Downgrade of SmartSDR kills VSP

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
I am sending in my new Flex 6400 for service.  Because of this, I had to put my venerable Flex 6300 back in service.  The 6300 had never been upgraded to version 2, so I knew I would have to downgrade the software.

So, I did that.  I uninstalled the 2.1.30.  I reinstalled v1.11.12, exactly.  I was careful to uninstall the DAX drivers.

When I got it all back up, it all seemed to work.  Except.  SmartCAT, while it displayed all of my ports (and all the ports show up in device manager), they never connect, because SmartCAT prominently displays "Radio Not Connected".

So, some investigation reveals that (judging from the dates), that uninstalling version 2 did _not_ uninstall FlexVSP.  So, I separately uninstalled that, uninstalled SmartSDR 1.11.12 for good measure and installed again.  And again.  And again.

Sometimes, it told me that FlexVSP was still missing (even though I saw the install screens fly by during install).  Other times, I get back to the same old "Radio Not Connected" from SmartCAT.

I even used this procedure:

. . .and found out where the FlexVSP drivers were and carefully installed them from that directory.  Moreover, I did so from a command line that I had specifically started up as the Administrator to get around any questions about authority.

That failed, too.

I then tried the Repair.  It failed the first time because I forgot to close SmartCAT (or, at least maybe SmartCAT died).  I did a second repair (seemed OK) and a reboot.

SmartCAT still says "Radio Not Connected".

I don't know what to do.  The radio is barely usable.  I have no logging and no Digital Modes.
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 233 Posts
  • 37 Reply Likes

Posted 2 years ago

  • 1
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 348 Posts
  • 56 Reply Likes
You may have already done the following but, if so, it may help someone else. I hope it helps you.

I usually have the best success by first saving my profiles then uninstall SSDR/DAX and CAT, including drivers, using the Control Panel. Then I go into the device manager &, if they remain, uninstall each Flex port & Sound device individually.

After that I go to the C: Drive > Program Files folder and delete the "Flex Radio Systems" folder.

This way the new installation will be fresh with nothing left over from the past. You'll have to load your profiles back and reconfigure anything you haven't saved before.

I've never worried about any Windows Registry entries and have never thought I needed to edit any of those.

Good luck!
Photo of Robert Lonn

Robert Lonn

  • 458 Posts
  • 175 Reply Likes
Can you share with us why the 6400 is heading back to Flex???
Photo of Michael Coslo

Michael Coslo

  • 947 Posts
  • 259 Reply Likes
Get Revo uninstaller - the free version will work. uninstall everything flex, using the deep scan method. This will clear out things that regular uninstallers miss. Then reinstall SmartSDR. I'd reset the radio as well. That should get you back in action. 
Photo of W9WLX-Chuck


  • 82 Posts
  • 20 Reply Likes
Did you select the correct radio from SmartSDR CAT?  
-Open the SmartSDR Cat window
-Left click on the verbiage "Radio Not Connected"

This should present you with a radio selection.  Choose the radio you want SmartSDR CAT to link up. 
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 233 Posts
  • 37 Reply Likes
Wow.  Didn't know that was a function, it looks like a status line only.

Seems to have worked. 

Right click has a check mark next to "On startup, autoconnect to last radio"  If that works, I should be back to where I should be.

Thanks, Chuck!
Photo of Delbert McCord

Delbert McCord

  • 132 Posts
  • 25 Reply Likes
I also would like to know the problem you needed to return the 6400 to Flex for. I have a 6400 sitting here in the box I received a couple weeks ago. I did not have the proper cable for the Mic so I ordered it and have it but just have not had time to mess with it again since I received the cable. 
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 233 Posts
  • 37 Reply Likes
I would go right ahead and install your 6400.

There needs to be a guide for 6300 upgraders.  The checklist I have is:

1.  Use the (bigger) power cable that comes with the 6400.  That prevents excessive voltage drops.

2.  Get the dongle (that you did) to enable the older 8 pin "foster" Mikes to be connected.

3.  Make sure you have the "mike" bias setting (most often, "off") in SmartSDR.  Recent mikes have been electroset, the older ones are not.

I'm not going to make a big deal of my problems.  The 6400 was not dead, it was quite usable, despite my sending it in for a fix.  You probably will experience no troubles, especially if you attend to the three factors above.
Photo of Delbert McCord

Delbert McCord

  • 132 Posts
  • 25 Reply Likes
Thanks, Hopefully this week. I am working on a couple loads for 7.62x39 so I will be ready when my new upper gets here, priorities I guess.