Does the new VSP driver still occupy all COM ports? It seems to do that on my PC.

  • 1
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
Having installed version 2 of SmartSDR without having uninstalled the old FlexVSP driver
first I notice that all COM ports are still occupied by the new FlexVSP driver (or is the old one
still running??). Anyway my OS (W7) shows the driver to be version 1.0.5.

My question is: Do I have to uninstall the FlexVSP driver and reinstall version 2 to get free
COM ports or do I have to use the software, which can free them up?

73, Alex - DH2ID
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 840 Posts
  • 150 Reply Likes
  • happy, as I saw a lot of animals at the Chobe!

Posted 7 months ago

  • 1
Photo of Dan -- KC4GO

Dan -- KC4GO

  • 327 Posts
  • 65 Reply Likes
Not here only the 4 I have assigned.  
I have the for the CAT assigned and 1 for Flex Control all others should be available.
Photo of Mark - W3II

Mark - W3II

  • 112 Posts
  • 31 Reply Likes
Here are two useful links regarding COM port management.

https://helpdesk.flexradio.com/hc/en-us/articles/200883925?mobile_site=true&_ga=2.76186966.214997903.1501764556-533861665.1435584078

http://www.uwe-sieber.de/misc_tools_e.html#arbiter

I hope one of these helps.
73

PS. You can also right click on the CAT Remove button to expose the "Reset FlexVSP Ports" action.
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8305 Posts
  • 3098 Reply Likes
Official Response
Alex,

The new FlexVSP driver in SmartSDR v2.0.17 corrects the problem related to com ports being marked as in use when the PC is rebooted.

In the SmartSDR v2.0.17 Release Notes, in the description of the new driver, there are instructions for you to reset the reserved or in use ports, after installing SmartSDR v2.0.17  I suspect you have not run this procedure.  

Mark above listed the URL to the HelpDesk article that describes how to reset the in use com ports.
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 840 Posts
  • 150 Reply Likes
Resetting the COM ports did it. I mistakenly thought, that the new FlexVSP driver
would do that by itself ;-)
73, Alex - DH2ID
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8305 Posts
  • 3098 Reply Likes
Nope, that is a Windows registry thing.  It is good to hear that everything is OK now.

This conversation is no longer open for comments or replies.