Network issue with v1.9.7

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
If you upgrade to 1.9.7 you cannot connect to Flexradio any more.

How to solve:
Connect your Flexradio with direct lan cable to pc with ssdr (NO DHCP !!!!)
Downgrade using SSDR 1.8.4.
Restore your profiles.
Photo of Hardy

Hardy

  • 25 Posts
  • 3 Reply Likes

Posted 3 years ago

  • 2
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 562 Posts
  • 191 Reply Likes
Hardy

I have no problem connecting my radio to 1.9.7, I am afraid you will be worrying a lot of people with your note needlessly. Have you contacted Flex to see what is going on?
Photo of Hardy

Hardy

  • 25 Posts
  • 3 Reply Likes
Dear Neal,

yes, I have contacted support.
I tried several times. As soon as dhcp is used, there is no contact after upgrade.
I can easy reproduce this issue. Only way ro solve is a direct cable connect
and then downgrade.
Others have reported this error in this forum too.
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1782 Posts
  • 547 Reply Likes
A network issue is not necessarily a smartsdr software issue. I hope you resolve your problem but I also feel your post title is too alarmist. If it ends up being your network and not 1.9.7, what then?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Hardy.  At this time the issue is only affecting a very, very small percentage of users.  We appreciate your efforts and they will not go unnoticed as we identified the issue and will have a fix out in short order.

BTW, I hate to hear that you will no longer be supporting the Community. 
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3784 Posts
  • 1637 Reply Likes
This was an issue reported by some of the Alpha group who had fixed IP reservations in their DHCP Server.

The solution seems to be remove the Fixed IP reservation in your DHCP Table

Then Upgrade to 1.9.7

Then use SSDR FIxed IP reservation to set ur fixed IP

NO Need to downgrade to 1.8.4

1.9.7 works OK
Photo of John G3WGV

John G3WGV

  • 199 Posts
  • 37 Reply Likes
I do have a fixed IP reservation for the 6500 in my DHCP and the 1.9.7 upgrade worked just fine with all my various home brew clients, SSDR and Maestro. Just powered everything up from cold this morning and it's still working perfectly.

I suppose I ought to set up the SSDR static(?) IP address now it's available but as it ain't broke I've not attempted to fix it.
Photo of Hardy

Hardy

  • 25 Posts
  • 3 Reply Likes
Fixed IP reservation is a must here.
What is "Then use SSDR FIxed IP reservation to set ur fixed IP " ?

So there is a dhcp issue in Flexradio which should be fixed soon!
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3784 Posts
  • 1637 Reply Likes
Hardy

You mistook my words

Flex has added the ability to set a fixed IP directly from SSDR rather than using a DHCP reservation.

In some case, routers get confused if they see a fixed IP already set outside of the DHCP table

The DHCP Issue is likely in the router as it forces the Flex to pick a different Initial IP.

THE SOLUTION IS TO REMOVE THE FIXED RESERVATION FROM THE ROUTER
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
To put Howard's post another way...some routers go crazy if you try to use BOTH static IP and Reserved DHCP IP for the same device at the SAME TIME.

My ASUS router didn't have a problem, but others have reported problems. It may depend upon whether the static IP you are choosing is inside or outside the range that your router's DHCP is set to assign to DHCP clients on the net.

Also, be sure that you are not trying to use a static IP that is on a different subnet from the rest of your Local Area Network.
Photo of Dan -- KC4GO

Dan -- KC4GO

  • 340 Posts
  • 70 Reply Likes
Mine did :), I have tried both individually and they work just fine, but together even if there set to the same it seems to dislike having both set.
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Dan...Just a question for diagnosis...is the Reserved IP inside or outside the range that you have set for DHCP to assign to DHCP clients? Mine was set to assign outside the DHCP range...I.e. My DHCP assigns port numbers 192.168.13.50 to 192.168.13.199 and the reserved ip was set for 192.168.13.200. I don't know if that makes a difference or not, but it might be another piece of the puzzle?

Here, I confirmed that static ip worked and then went back to reserved DHCP ip because I don't need static ip.
(Edited)
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes
My IP reservation didn't need to be changed after the upgrade, still works like a charm. I love it when things work. :D
Photo of David G4NRT / Z21NRT

David G4NRT / Z21NRT

  • 285 Posts
  • 38 Reply Likes
I have upgraded to v1.9.7 on my FlexRadio 6500 and my Maestro (not without some trepidation I have to say!) and it all went very well.  
No issues or problems found and I can attach from both the Maestro and from SSDR.

David G4NRT
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2314 Posts
  • 956 Reply Likes
I have use static DHCP reservation and upgraded to 1.9.7 just fine.
Photo of KF4HR

KF4HR

  • 827 Posts
  • 274 Reply Likes
Hardy, 1.9.7 works fine here!!!!!!!!!  No problems.
Photo of Lawrence Gray

Lawrence Gray

  • 182 Posts
  • 87 Reply Likes
1.9.7 works fine here--DHCP with reserved address.   No issues at all with the upgrade or operation after the upgrade.
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 199 Reply Likes
I think we should remove this post or at least rename the title. Can that be done.

It could be "problems with 1.9.7 upgrade with DHCP reservation"

Mike va3mw
Photo of Clay N9IO

Clay N9IO

  • 633 Posts
  • 170 Reply Likes
Sorry not a very responsible post at all. I agree, re-name it. 
Photo of Ross - K9COX

Ross - K9COX

  • 352 Posts
  • 108 Reply Likes
Lesson learned, never write something when you are angry and have not had time to think about it.
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 916 Posts
  • 344 Reply Likes
The preferred way to allocate IPs in modern networks is to use DHCP.  I cannot emphasize this strongly enough.  Use a static DHCP entry in the router if you want the radio to stay on the same IP address.

Please don't confuse the addition of the Static IP feature as a suggestion from Flex that you should be using it.  Only those that absolutely HAVE to should be using the Static IP feature.  It should be considered an Advanced feature.  It is completely possible to put your radio on a network that you cannot access from your computer without also manually setting your computer's IP address.  Failing the ability to do this would result in you not being able to communicate with the radio without doing a factory reset and losing your settings.  Note that using Static IPs on a network the has a DHCP server is one easy way to end up with IP address conflicts.  This is not recommended unless you are comfortable with advanced networking.

As others have pointed out, if you are trying to use a Static IP on a network where there is a static DHCP entry for the same IP address, this may result in problems depending on the router.

I hope I haven't been unclear.  ;)

====================

Now, with all of that said...

Hardy, were you able to resolve your issue?  If not, I would recommend opening a helpdesk ticket so that we can help you figure it out.  They are likely going to want to know your network configuration, so be prepared to describe your topology (e.g. modem <-> router <-> Computer/Laptop/Radio).
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 916 Posts
  • 344 Reply Likes
As noted below, this may be due to using a non-Private Network address space on your network.  See the comments below for more info.
Photo of Mark NS9N

Mark NS9N

  • 70 Posts
  • 26 Reply Likes
There is clearly a change in 1.9.7 which needs to be corrected. All previous versions worked fine with both static IP and DHCP ranges set in my router. Now with 1.9.7, I can connect fine with both my computer and Maestro when I have a direct cable connection between them. When I connect the system using my wired network, remember no change in my network, the radio will show up in the connection screen but will not communicate when the "connect" button is pressed. There should be no reason for me to change anything in my router or network to make this update work. BTW, the actual actually worked perfect over the wired network and when I return to 1.8 everything works perfect. We need a fix for 1.9. 
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 916 Posts
  • 344 Reply Likes
Mark,

I'm happy to help resolve this issue and if a software fix is necessary, we can make that happen.  The best way to resolve this is to gather the necessary information so that we understand the problem and can replicate it here.  Unless you really want to post all of your network details publicly, I would recommend that we take the conversation offline.  A helpdesk ticket is always the right place to start.  Please email me directly (eric@flex-radio.com) and I can help get that process going while also collecting your network details.

We will report back to the thread what we find.
(Edited)
Photo of Mark NS9N

Mark NS9N

  • 70 Posts
  • 26 Reply Likes
Thank you Eric. Always appreciate the fast response from Flex. You have an email from me with all the details. Please keep up the excellent customer service.
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 199 Reply Likes
I have seen something similar ... possibly. At time I have to actually tap the radio on the radio list and then hit the connect. Just a thought.
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 916 Posts
  • 344 Reply Likes
Official Response
OK .. I think we have figured out the root cause here.  Because our API currently has no authentication, we increased security by implementing a restriction to only be able to connect to the radio from Private IP addresses (RFC1918).  This is what was getting in the way here.

We have a plan to optionally allow the user to turn off this security (and thus accept responsibility for potential issues as a result).  This is captured in our system as #3996.  In the mean time, using a Private IP address is a workaround.
(Edited)
Photo of Hardy

Hardy

  • 25 Posts
  • 3 Reply Likes
Would have been nice to see such changes in release notes!

So I, and all others with public ip addresses, have to stay on 1.8.4 until next version.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Yes.  But that will not be long.  We are testing a program change internally as I write this to allow the user to configure the radio to work on public IP address space.
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 199 Reply Likes
I would be curious to see how big the user base is for those on a public ip base.
Interesting.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Right now that number is approximately an order of magnitude less than 1%.
Photo of Mark NS9N

Mark NS9N

  • 69 Posts
  • 26 Reply Likes
But remember those ham stations inside corporate firewalls. OK sad to say but maybe they are almost extinct.
Photo of PA2TA

PA2TA

  • 17 Posts
  • 1 Reply Like
And also remember those ham stations running inside the ampr.org network...
Photo of Hardy

Hardy

  • 25 Posts
  • 3 Reply Likes
Hi all!

I got a new beta 1.10.x, which fixed the issue.
.
Good news for all others with public ip addesses:
"We are planning on releasing a maintenance release of SmartSDR v1.9 (SmartSDR for Windows and Maestro) with this fix later this week. Until that time, you can continue to use the fix release. "
Photo of Stu2

Stu2

  • 5 Posts
  • 0 Reply Likes
Now - to get IPv6 added! ;)
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 645 Reply Likes
I saw the dot seven and thought, ' I'll just wait this out' I am glad I did. Why do I say this? "Do more by doing less" is considered advise I gave after 45 yrs in software engineering. Apparently a waste of breath. I am also a user and concerned about quality.
Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 199 Reply Likes
Walt, there is zero risk in upgrading or down grading. The Flex team has made our ability to do that pretty painless. If fact, you can have multiple versions loaded and easily switch back and forth, but I am sure you are aware of that.

Why would you say this is a waste of breath? :) I've only been at this for 37 years.... Of course, all software has bugs in today's day and age.

Mike va3mw
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Official Response
This issue will be fixed in a SmartSDR v1.9 maintenance release that is planned for distribution in the near future.

This conversation is no longer open for comments or replies.