Network issue with v1.9.7

  • 2
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
If you upgrade to 1.9.7 you cannot connect to Flexradio any more.

How to solve:
Connect your Flexradio with direct lan cable to pc with ssdr (NO DHCP !!!!)
Downgrade using SSDR 1.8.4.
Restore your profiles.
Photo of Hardy

Hardy

  • 24 Posts
  • 3 Reply Likes

Posted 2 years ago

  • 2
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 717 Posts
  • 211 Reply Likes
Official Response
OK .. I think we have figured out the root cause here.  Because our API currently has no authentication, we increased security by implementing a restriction to only be able to connect to the radio from Private IP addresses (RFC1918).  This is what was getting in the way here.

We have a plan to optionally allow the user to turn off this security (and thus accept responsibility for potential issues as a result).  This is captured in our system as #3996.  In the mean time, using a Private IP address is a workaround.
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
Official Response
This issue will be fixed in a SmartSDR v1.9 maintenance release that is planned for distribution in the near future.