Do I need a new router for Smartlink?

  • 2
  • Question
  • Updated 5 months ago
I live in a rural area and use AT&T's Homebase for internet access.  I know nothing about networking.  I have an ethernet cable from Homebase to a switch which connects my PC, 6600 and Maestro and it works, which is about the extent of my knowledge.  I'll leave out the litany of everything I've tried to make Smartlink work and just say that I cannot seem to stumble across the right combination of settings, and it appears from searching the community that I'm not alone.

From what I've read, the popular solution seems to be to purchase a new router that's hopefully easier to configure for Smartlink and feeding it with the internet feed from Homebase.  Is this correct?  If so, what would be a good idiot-proof choice?

73
Rick WR0H
Photo of Rick WR0H

Rick WR0H

  • 34 Posts
  • 7 Reply Likes

Posted 5 months ago

  • 2
Photo of Dennis Terry W4SG

Dennis Terry W4SG

  • 70 Posts
  • 9 Reply Likes
I can understand how frustrating this must be.  I looked at a ATT Homebase manual (hope there is only one) and there is a feature in the router section of the Homebase called UPnP (Universal Plug and Play) that the default is defaulted to disabled.  To use Smartlink this needs to be enabled.  When Version 2.0 came out this came up a lot.  This feature allows certain data packets to get to the Flex for Smartlink.  If you search this forum for Port Forwarding you can find the details.  Also search for UPnP for further info.  I am not sure who manages the Homebase for you but they can enable the UPnP feature for you and you should be good to go.  Good Luck, 73, W4SG
Photo of Dennis Terry W4SG

Dennis Terry W4SG

  • 70 Posts
  • 9 Reply Likes
Rick, adding another router will not help as the packets have to get through the Homebase to any outboard router.
Photo of Rick WR0H

Rick WR0H

  • 31 Posts
  • 7 Reply Likes
Rats. Like I said, I know nothing about networking.  I was hoping that since Homebase passes the internet to my switch, it would pass what I need to another router that might be easier to set up.

I've tried the UPnP setting in Homebase but with the same result--all "fail" in the Smartlink test.
(Edited)
Photo of Dennis Terry W4SG

Dennis Terry W4SG

  • 70 Posts
  • 9 Reply Likes
One thing Rick, after changing the status of UPnP in Homebase was it power cycled?  Some routers require this after changing some settings. The next step is to set up the router to always give the Flex the same IP address.  This is called DHCP Reservations.  After that the Homebase is to be configured to do Port Forwarding of two ports that the Flex requires.  This is a little more complicated but it appears that the Homebase does allow it.  I am surprised that the UPnP enabled did not fix it.
Photo of Dennis Terry W4SG

Dennis Terry W4SG

  • 70 Posts
  • 9 Reply Likes
Rick, After re-reading the Homebase manual there is also a built-in Firewall that may be preventing the two ports needed for Flex Smartlink (Ports 4993 and 4994).  Check that out.
Photo of Dennis Terry W4SG

Dennis Terry W4SG

  • 70 Posts
  • 9 Reply Likes
Might be time to ask Flex for help with the Homebase unit.  
Photo of Rick WR0H

Rick WR0H

  • 31 Posts
  • 7 Reply Likes
Thanks Dennis.  This thing is a piece of work, isn't it? :-)
Photo of W5AP

W5AP

  • 134 Posts
  • 15 Reply Likes
I have heard that the Even Route "IQ" router solves the "buffer bloat" issue 

https://smile.amazon.com/IQrouter-Self-Optimizing-router-improved-quality/dp/B06WP5GTS8/ref=sr_1_1?keywords=even+router+iqrouter&qid=1559993513&s=gateway&sr=8-1

I'm going to get one and try and see if it helps with my dropped packets or high jitter which results in chopped audio - even though my ISP speeds are 25 Mbs down and 4 up (but it falls off as the day progresses - to the point of "poor" network conditions under Network in my Flex 6600M.
Photo of Craig Williams

Craig Williams

  • 238 Posts
  • 72 Reply Likes
I hope the MTU adjustments in the upcoming software will solve my iPad stuttering. If my router sees anything bigger than 1470 is splits the packets.