Direct ethernet connection unreliable ?

  • 2
  • Question
  • Updated 4 years ago
I received my 6300 today and connected it directly to my computer (no switch). I could not get SmartSDR to recognize the radio. I finally connected it to a switch which is connected via WLAN to my LAN router/switch in another room. That connection worked fine. I called FLEX and they said the direct connection should work just fine and sure enough the direct connection started working as we spoke on the telephone. (Magic voice I guess). About an hour later the connection died again and I had to go back to using the switch.  I saw where someone else had the same problem and it was listed as resolved with no more comments allowed. I wonder what their resolution was?
Photo of Mike W9OJ

Mike W9OJ

  • 80 Posts
  • 24 Reply Likes

Posted 4 years ago

  • 2
Photo of John n0snx

John n0snx

  • 229 Posts
  • 54 Reply Likes
Hi Mike

  I received my 6300 yesterday and have it direct to my pc with no problems....  You might uninstall the software and reinstall it and maybe it will work then... Murphy's law always can come into play when we least expect it.

John
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8294 Posts
  • 3093 Reply Likes
Uninstalling SmartSDR will not make any difference.  The issue is in the TCP/IP stack on the PC and that is integrated into the operating system (Windows).
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8640 Posts
  • 3239 Reply Likes
Mike - if you have multiple network connections on your PC, sometimes Windows goes wonky (a technical IT term).  I'd connect the radio to the switch and be done with it.  That way you can use a wireless PC running SmartSDR or the K6TU iPad app to access the radio.
Photo of Jay -- N0FB

Jay -- N0FB, Elmer

  • 534 Posts
  • 210 Reply Likes

Mike, a couple ideas.  Some Ethernet cards can be configured to be manually set for speed and duplex (full or half) or it can be set for auto-negotiation.  Chances are, it is set for auto-negotiation and is usually the best setting for most occasions. As a test, you might try setting the Ethernet (if possible) to 100 Megabit and Full Duplex on your PC. The radio will no longer need to try to negotiate the link speed and the link may then "just become reliable".  

The reason that you are not having the problem when connected to the switch, each port on the switch is doing its own negotiation with each device.  It works out any differences between the connected devices internally.

(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3803 Posts
  • 1157 Reply Likes
Also check the power/performance setting to make sure that your computer isn't powering down the Ethernet hardware (and USB port, if you are using FlexControl Knob) as part of the power saving routine. Things can get wonky that way, too. This is important whether you are on a switch or not.
Photo of Lee

Lee, Elmer

  • 677 Posts
  • 283 Reply Likes
Try updating the Ethernet drivers to the latest hardware specific drivers (ie not windows stock drivers).  I agree setting the speed to a fixed speed is also a good idea  

Good to hear from you Zeke!  Hope you are well.  Welcome to Flexlife  

73  W9OY
Photo of John n0snx

John n0snx

  • 229 Posts
  • 54 Reply Likes
No crossover cable needed...I have my 6300 direct with no issues.... it may take a few minutes for it to show up..Did you run the CD that came with it to make sure all the drivers for the 6300 were installed. I too am running win7    Good luck

John
(Edited)
Photo of Sid

Sid

  • 11 Posts
  • 0 Reply Likes
Using the cable supplied and the CD supplied but dont have a lan router system to plug into.
Photo of Sid

Sid

  • 11 Posts
  • 0 Reply Likes
Mike W9OJ was your direct connection resolved if so could you help with a solution.

Sid
Photo of Mike W9OJ

Mike W9OJ

  • 78 Posts
  • 22 Reply Likes
I gave up on a direct connection and used a $15 wireless router which is "talking" to another wireless router in a different room.

Mike W9OJ
Photo of Sid

Sid

  • 11 Posts
  • 0 Reply Likes
I travel a bit and one of the reasons I bought this unit was to be able to work portable so I do not want to carry a router with me. Has anyone who has had problems with direct connections ever resolved the problem. Thanks for your comments Mike. 
Photo of W5XZ - dan

W5XZ - dan

  • 562 Posts
  • 82 Reply Likes
if you drill down into the "Zendesk" part of this community, you will find http://helpdesk.flexradio.com/hc/en-us/articles/202118518-Optimizing-Ethernet-Adapter-Settings-for-M...
another adapter setting, a good while back, was to turn off "green ethernet"...not sure why I don't see that any more
73, w5xz, dan





Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8640 Posts
  • 3239 Reply Likes
Sid - Please open a HelpDesk support ticket if you are still having issues with communicating to the radio.
Photo of Sid

Sid

  • 11 Posts
  • 0 Reply Likes
New to SDR so not sure how to open helpdesk support ticket
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8640 Posts
  • 3239 Reply Likes
Photo of Sid

Sid

  • 11 Posts
  • 0 Reply Likes
Thanks Tim will check it out.
Photo of Sid

Sid

  • 11 Posts
  • 0 Reply Likes

Hi Tim,

Had an email from Matt and he said Dudley was going to help. I have been through your settings and updated the drivers but still comes up with unidentified network.

Sid

Photo of Bill W2PKY

Bill W2PKY

  • 423 Posts
  • 74 Reply Likes
Another idea is to use an Ethernet->USB adapter that plugs into a USB port for the radio connection. Amazingly, the built in WIFI adapter on the host computer can still function as the internet gateway.
Photo of Bob

Bob

  • 2 Posts
  • 0 Reply Likes
I too am having issues with direct connection, installing radio out of the box. No Ethernet to shack because it is remote to home. Direct to PC I got some weird IP adress that stops the SmartSDR program. Put in 150 foot CAT5 as temporary to update. Updating is taking now 5 hours so far. I wish it had some way to indicate progress.
Photo of Lee

Lee, Elmer

  • 677 Posts
  • 283 Reply Likes
the ethernet port in the computer is probably on the wrong subnet.  I solved an issue like this with a different radio by changing my ethernet address in the computer on that particular port to a static IP in the same subnet.  I was running 2 ethernets and a wifi on a windows 8.1 box

73  W9OY
Photo of Larry da Ponte

Larry da Ponte

  • 158 Posts
  • 15 Reply Likes
On a new 6500 I am experiencing a similar issue with a direct connected MacBook Pro. During RX SSDR 1.3 will freeze and when I restart SSDR the radio is not found. Reboot of radio seems to fix the problem temporarily. Using Flex supplied cable.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3403 Posts
  • 1292 Reply Likes
The issue is caused by the fact that somehow your radio is losing IP address and picking up a new IP on a different subnet

Best possible solution. Do not use direct connection. But rather connect your radio thru a router so that it always gets a routable IP address. This should solve your problem.
Photo of Larry da Ponte

Larry da Ponte

  • 158 Posts
  • 15 Reply Likes
Is it possible to set a static ip in the radio or view it's network configuration?
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3403 Posts
  • 1292 Reply Likes
Not easy with a direct connection

Through a router u can use the MAC address to fix the IP.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3403 Posts
  • 1292 Reply Likes
U can view the IP in SmartCAT
Photo of Larry da Ponte

Larry da Ponte

  • 158 Posts
  • 15 Reply Likes
Windows will assign a class B IP address to the PC's NIC if there is no DHCP. How does the flex radio assign it's IP address when there is no DHCP?
Photo of Jon - KF2E

Jon - KF2E

  • 586 Posts
  • 171 Reply Likes
Photo of NX6D Dave

NX6D Dave

  • 273 Posts
  • 70 Reply Likes

When I was yielding to my desire to purchase a 6300 at Dayton, I spent a few minutes talking to Tim about how the radio would be integrated into my household network.  As it turns out, the gigabit portion of the network is located adjacent to my shack, so a wired connection to the radio was no problem.  The computer already had a wired GB connection.  I use a D-Link GB switch which acts as a hub for the GB network.  The router is a venerable Linksys WRT54G, which is not a GB rated device, but neither is the "broadband" connection to the outside world.  The router provides all DHCP services.  Modern router/switches are all GB, so my configuration is unusual these days.

Tim enthusiastically agreed that I should simply "plug the radio into the switch". There would be no bandwidth problems.  That's what I did and I've never noticed any.  If any problems appeared, I would start by assuming a defective switch, noisy wires, etc.  This is common off the shelf tech.

Yes, you can configure Windows or IOS or Linux to supply DHCP and run a two node network without a switch, but why press your luck?  These systems all expect to be connected to a high speed router/switch network that provides these services.  They are bound to be more stable in this client configuration rather than the DHCP server configuration.

Certainly, it makes sense to spend some time looking at the NIC configurations, but I would expect most out of the box configurations to be pretty good.  Might not be quite so good in Linux systems, as they are intended to be closely configured by pro Admins.


Photo of Larry da Ponte

Larry da Ponte

  • 158 Posts
  • 15 Reply Likes
It's an annoyance to add a router when you have only two devices
Photo of Larry da Ponte

Larry da Ponte

  • 158 Posts
  • 15 Reply Likes
I'm going to try enabling internet connection sharing, I believe this will enable DHCP on the NIC directly connected to the radio.
Photo of James Kirk

James Kirk

  • 79 Posts
  • 12 Reply Likes
I have a laptop and desktop both using internet access via WiFi to a router, quite common now. Both computers have Ethernet ports and when I plug them into a 6300 with the WiFi internet connection enabled it just works. Everything is plug and play...what else can I say.
Photo of Lee

Lee, Elmer

  • 677 Posts
  • 283 Reply Likes
If you can force the nic into the same subnet as the radio it will fix itself without dchp servers and all that. The problem is if windows doesn't know what to do it forces a 169.xxx.xxx.xxx address and if your radio is not on that subnet communications won't be estsblished. You probably want the nic on 192.168.0.x 255.255.255.x or 192.168.1.x 255.255.255.x. You can just empirically assign your nic port to a IP address in one or the other of these subnets and its likely your radio will fire up. Its triviasl to return the nic to dchp if bit doesn't work

73 W9OY
Photo of James Kirk

James Kirk

  • 79 Posts
  • 12 Reply Likes
My 6300 connects directly at 169.254.9.212, the wireless happens to be at 192.168.5 as assigned by the router. What I don't understand is why his radio would not be on the correct subnet assigned during initial negotiation when powered up for a direct connection. The stack works fine both on Win7 and Win8.1.
Photo of Lee

Lee, Elmer

  • 677 Posts
  • 283 Reply Likes
It has to do with the way windows handles multiple NIC ip addresses in the same machine. Windows networking has always been a pita since the days of 3.1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 1977 Posts
  • 479 Reply Likes
It has been well documented in many post that going through a router is the way to connect, but people still try and go direct no matter what....
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3403 Posts
  • 1292 Reply Likes
A router is really so inexpensive so why screw around with unreliable direct connect.

Only $35 on Amazon

http://smile.amazon.com/Linksys-EA350...
(Edited)
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2083 Posts
  • 496 Reply Likes
Most anyone on a home network has one, It is just so simple. In the beginning Flex may have thought direct would be the thing to do but as many have found out a router is the best way to go.
Photo of Larry da Ponte

Larry da Ponte

  • 158 Posts
  • 15 Reply Likes
The radio and laptop will be traveling and i'd like to find a solution that doesn't involve a router. I'm fine with the forums recommendation on adding a home network. If I discover a stable solution for direct connection I'll share it with you all. Cost is not an issue
(Edited)
Photo of James Kirk

James Kirk

  • 79 Posts
  • 12 Reply Likes
I wish that I had a solution for you Larry, all I can tell you is that I plug the radio directly into my laptop and it works, I plug it into my desktop and it works flawlessly. Nothing special on either computer, both have functioning wireless connections that connect automatically on power up. Win 7 and Win 8.1, sorry.
Photo of James Kirk

James Kirk

  • 79 Posts
  • 12 Reply Likes
Just to rub salt in the wound, I tried no WiFi, Ethernet to the radio first, radio powered up before plugging in Ethernet, and during lightening storm...could not get it to not connect. Truly plug and play.
Photo of Larry da Ponte

Larry da Ponte

  • 158 Posts
  • 15 Reply Likes
So far enabling windows 8.1 internet connection sharing (ICS) is allowing the direct connect to work.  Have been on for three hours and no lock-up of SSDR and I can see that the radio is getting an IP address from the ICS DHCP that is on the same subnet as the computer's NIC.  I was also able to upgraded the radio to SSDR v1.3 using this setup. I did notice that the radio sometimes configured itself with a link local address in the 169.254/16 range and when this happened, it was also in the same subnet as the PC's port which also uses the same method to assign a link local IP in 169.254/16 (note - ICS not enabled at this point).  The radio operates for a while in this configuration and then SSDR display hangs and the radio no longer appears in the radio chooser.  Anyway, ICS seems like a viable solution for direct connections, YMMV.  Sending my WireShark captures that contain the moment of the freeze and you can see the traffic from the radio stop.
(Edited)
Photo of Lee

Lee, Elmer

  • 677 Posts
  • 283 Reply Likes
Try some variation on this. http://sdr-w9oy.blogspot.com/search?u...