Direct ethernet connection for FLEX-6500

  • 2
  • Question
  • Updated 6 years ago
  • Answered
My new FLEX-6500 could not connect with the PC when directly connected with the Ethernet cable. It works fine when connected through a router. This is a very minor issue. Do I need to upgrade the ethernet card in the PC? It is over 5 yrs old.

The new radio has extraordinary receive audio. Looking forward to more operating time!

Keith
KE4TH
Photo of Keith - KE4TH

Keith - KE4TH

  • 24 Posts
  • 1 Reply Like

Posted 6 years ago

  • 2
Photo of Mickey N4MB

Mickey N4MB

  • 49 Posts
  • 10 Reply Likes
>>Do I need to upgrade the ethernet card in the PC?

Maybe.

The likely reason that this is not working is that your PC NIC might be 100BASET - which is not bi-directional - you have to make/get an Ethernet cross-over cable or get a new Gbit NIC. Gbit arbitrates transmit and receive so that you can directly plug into all devices but 100BaseT doesn't - every interface is set up as a either a switch/hub or a nic.

73,

Mickey N4MB
Photo of Steve Conklin

Steve Conklin

  • 15 Posts
  • 0 Reply Likes
The radio needs to obtain an IP address from a DHCP server. This is built into all home routers.

With a direct cable between the PC and radio, the radio can't obtain an IP network address and network services can't be started.
Photo of Steve - N5AC

Steve - N5AC, VP Engineering / CTO

  • 1057 Posts
  • 1097 Reply Likes
Official Response
The radio has Link Local support (RFC 3927) as well as automatic cable flip (MDI-X) in the Ethernet PHY. Theoretically, there should be no issue on 100BaseT based on the data sheet, but most of the testing we have done is on Gigabit cables. The Ethernet PHY we use is fairly sophisticated and has a bunch of on-board diagnostics to figure your cable out and adjust to make it work. See tables below:



Photo of W5XZ - dan

W5XZ - dan

  • 571 Posts
  • 86 Reply Likes
wow, now THAT'S impressive !!! this IS quite a 'beast' we have !!!
Photo of Keith - KE4TH

Keith - KE4TH

  • 24 Posts
  • 1 Reply Like
Update - I tried a new PCI network card with the MDI-x feature. No luck, still unable to connect directly. I also updated the drivers for the existing card. I also tried a crossover cable, and still no luck. Running Windows XP SP3. Limited connectivity error message is always unable to acquire network address. So using a router as a switch for now. I can connect directly with my two year old Windows 7 laptop, so the issue is not on the radio side. An IT person at works thinks this is an XP issue. Any thoughts are welcome! Thanks!
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3550 Reply Likes
Keith - open up a HelpDesk ticket so we can do sone one on one troubleshooting.
Photo of Steve - N5AC

Steve - N5AC, VP Engineering / CTO

  • 1057 Posts
  • 1097 Reply Likes
You can disable APIPA (Local Link) on Windows XP in the registry. You might look to see if this has been done on your machine. Here's a reference:

http://www.techrepublic.com/article/d...

You want to do the OPPOSITE of this article, of course.

Steve
Photo of Keith - KE4TH

Keith - KE4TH

  • 24 Posts
  • 1 Reply Like
Steve, I did the registry edit and set the value to 1 to ensure the local linking feature is active. This did not help. I'll try some internet research this weekend to see if I can find a similar issue. Thank for your suggestions.
Photo of Steve - N5AC

Steve - N5AC, VP Engineering / CTO

  • 1057 Posts
  • 1097 Reply Likes
OK I figured that was a long shot. I would do some more searching for "APIPA Disabled Windows XP" and see if you can find any other experiments that might help figure out what's wrong.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3550 Reply Likes
Keith - I have converted your issue into a HelpDesk ticket so we can do some in depth one-on-one troubleshooting.
Photo of Michael - N5TGL

Michael - N5TGL

  • 308 Posts
  • 101 Reply Likes
Not sure if you have your network card set to a static IP, but that prevented my upgrade until I switched it back to dynamic.
Photo of Bill-W9OL

Bill-W9OL

  • 726 Posts
  • 56 Reply Likes
Does it make any difference whether it's connected to the computer or the router.
I just naturally assumed the router was the preferred as I get the downloads and this help forum.
But if you guys think it's better to connect to the rig, I can do dat!
Actualy no I can't
my computer only has one cat port and that one's taken. It's connected to the router.
So I guess the 6.5K MUST be connected to the router.
Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
If your computer has a static IP address, then you should be able to use a DHCP server to assign an IP address to the radio.

http://sourceforge.net/projects/dhcps...

A handy feature here would be the ability to view and change the IP address settings through the front panel display and buttons.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3550 Reply Likes
This topic has been solved in Zendesk
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3550 Reply Likes
This topic has been solved in Zendesk

This conversation is no longer open for comments or replies.