Digital Mode Headache

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
Using fldigi and DAX.....sometimes it works, sometimes it doesn't. It worked in the beginning, Now, it mostly doesn't work. I have tried rebooting everything, to no avail. I install, uninstall, and reinstall DAX RX/TX 1. Nothing seems to matter. Either I am doing something incredibly dumb, or there is some kind of problem. Am I the only one experiencing this? (Yes, I have checked fldigi audio and radio settings, for those who are about to ask)
Photo of W5UN_Dave

W5UN_Dave

  • 316 Posts
  • 30 Reply Likes

Posted 6 years ago

  • 1
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ

  • 212 Posts
  • 45 Reply Likes
Dave,

When you say doesn't work, are not seeing the frequency displayed, no seeing anything in the waterfall of FLDigi, or just fails to come up and what kind of error when this happens?
Photo of W5UN_Dave

W5UN_Dave

  • 316 Posts
  • 30 Reply Likes
FLDigi is working fine,. Frequency display is correct, waterfall working, PTT engages, just no modulation. Here are my flDigi settings
Photo of Ned K1NJ

Ned K1NJ

  • 322 Posts
  • 83 Reply Likes
Dave,
There is a "SmartSDR.xml" file on the FlDigi site. Written by Tim,
I think. http://www.w1hkj.com/xmlarchives.html
I have no idea what the difference might be.

Ned, K1NJ
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1681 Posts
  • 617 Reply Likes
If you've re-installed DAX, there's a good chance there are a BUNCH of ghost audio devices still in the Device Manager.They seem to remain after an uninstall, even after rebooting. Try uninstalling DAX again, then rebooting, then going to Device Manager (Windows Control Panel). Ensure you select View -? Show Hidden Devices. Delete every last DAX device. Reboot. Reinstall DAX.
You may need to re-configure FLDigi to get the new devices to "stick."

Good luck!
Photo of Ernest - W4EG

Ernest - W4EG

  • 625 Posts
  • 122 Reply Likes
Dave,
George's advice worked for me. After doing his suggestion HRD, in my case works flawlessly.
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
How do you reinstall DAX? I thought DAX was part of the 1.0.24 beta install and not a separate entity like SmartCAT.
Photo of Ernest - W4EG

Ernest - W4EG

  • 625 Posts
  • 122 Reply Likes
I deleted all SmartSDR, CAT and DAX from Control Panel and downloaded a fresh SmartSDR. I made sure there was no remnants Smart anything any where.
Photo of Greg

Greg

  • 656 Posts
  • 63 Reply Likes
Just for the heck of it, try a different DAX channel. I have a problem with CH1. But whith Ch 5 it works fine. This is with DXLabs, not FLDigi.

73
Greg
AB7R
Photo of W5UN_Dave

W5UN_Dave

  • 316 Posts
  • 30 Reply Likes
George, I did as you said, I opened Device Manager and deleted all DAV references under Sound.then rebooted. Boy has this gotten me in trouble. Now, whenever I reboot the computer I get the error message "DAX has stopped working" Looks like I have a mess. What next: reinstall SmartSDR 1.0.25?
Photo of W4EY

W4EY

  • 153 Posts
  • 7 Reply Likes
I had the same problem until I UNCHECKED the RIGCAT Box in the Fldidi RIG window. Everything was rebooted and works good. Also, I opened the SmartSDR.xml file in the RIG window. Saved the Fldidi configuration before I rebooted.
Photo of Roger Rockwell/na4rr

Roger Rockwell/na4rr

  • 69 Posts
  • 10 Reply Likes
Once I got fldigi settings to work I have not changed them. If I just quit smartcat and then re-start smartcat most of the time this alone will make fldigi start working again. If not, next I toggle DAX on and off. For the last couple of days doing one or both of these have worked.

roger
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
Dave, you are using com24 for RigCat, however, it should be the com port that is created when you first install SmartCAT. In my case it is com4 as that is the CAT port directly to the radio. To confirm what that port is open SmartCAT and under the main tab look at what is displayed in the "Connect 3rd Party Program to Port". That is the CAT port you want to use in fldigi. Second, as already mentioned you need SmartSDR.xml not PowerSDR.xml. I also use Hardware PTT where I created a PTT port through SmartCAT and assigned RTS as active. I then enabled Hardware PTT in fldigi specifying the lower port number of the pair created for PTT and the I checked "Use separate serial port PTT" and also checked "Use RTS". You can use this or stay with the "CAT command for PTT" in the RigCAT tab in fldigi.

As far as what to do since it doesn't work now, I would uninstall SmartSDR and SmartCAT, reboot, and then reinstall both. Hopefully you should be ok after this.

Don
Photo of W5UN_Dave

W5UN_Dave

  • 316 Posts
  • 30 Reply Likes
close this one out for me,fldigi working fine with SmartSDR now. The simplest problems can turn out to be a headache.

This conversation is no longer open for comments or replies.